Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-02-03, 05:19 AM   #1
TZOTZIOY
Registered User
 
Join Date: May 2003
Location: Athens, Hellas
Posts: 1
Send a message via ICQ to TZOTZIOY
Default FYI: 4363 with custom kernel in MDK9.1

This post might help some of you guys.
I installed the driver using the .run file in my brand new 9.1 installation, and everything worked fine. Then I built a custom kernel for my K6-III system, without bothering to deselect many modules I would not need (ie I built most things as modules).
Booted my kernel, and I could not have graphics, even though I reinstalled the driver.
After a lot of searching, it seems that there were two nvidia.o files in the lib/modules/...custom directory: one under ide/pci for the nforce chipset, and one in the kernel/video, which was the one I wanted. I renamed the ide module, and then everything worked.
Please note I am not at home now and cannot be absolutely certain for the subdirectories (eg was it ide/pci or pci/ide ?), but you get the general idea.

Cheers!

(btw, gears with the std kernel was about 390 fps, with the k6 kernel jumped over 500 fps --both with the 4363 driver. A weird performance increase, but I won't mind
TZOTZIOY is offline   Reply With Quote
Old 06-02-03, 08:19 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

This was a known issue for a very small number of 2.4.21-preX kernels. The nForce IDE driver is now ("now" being a couple of -preX kernels after it was first released) integrated into the AMD Viper IDE module (since it's the same chipset, or very similar, or something). In other words, if you use 2.4.21-rc6 (or thereabouts), you won't have this problem.

And of course, if you don't use the nForce IDE driver, it doesn't matter what it's called. So your solution works too.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random crashes, NVRM Xid messages Iesos NVIDIA Linux 90 10-04-12 03:27 AM
Corrupted display - 302.17 - Dell Precision T3500 (G98 [Quadro NVS 295]) gbailey NVIDIA Linux 1 06-27-12 10:24 AM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Crash when logout from X TGL NVIDIA Linux 10 09-13-02 08:22 PM

All times are GMT -5. The time now is 10:26 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.