Go Back   nV News Forums > Software Forums > Gaming Central

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-21-10, 12:36 AM   #1441
JasonPC
Registered User
 
Join Date: Feb 2007
Posts: 2,103
Default Re: GTA IV PC Official Thread

I finally forced myself to finish this game. Didn't realize I was so close to the end. I was very underwhelmed. Am I the only one who doesn't understand what made this game so great? It has nice physics, textures, immersion, etc. But it's just not fun and lacks character. I reinstalled Grand Theft Auto San Andreas and to me there's no competition. San Andreas is just tons more fun.
JasonPC is offline   Reply With Quote
Old 09-18-10, 10:53 AM   #1442
Intel17
Is not an Intel fanboi
 
Join Date: May 2004
Location: Burlington, VT
Posts: 1,368
Default Re: GTA IV PC Official Thread

I bought this game a long time ago and it just sat on my steam game list (it was on special). Started playing it a little while ago and I have to say the actual GAME is pretty fun (except the combat's a little clunky). However on my SLI'd 470 + Core i7 860, I should not have any problems running this game maxed out...but I do! It hovers around 30-50 fps in the outdoor scenes, which is pretty ludicrously low. Oh well.
__________________
Intel Core i7 980X Extreme Edition @ 4.00GHz, 2.94GHz uncore| Corsair H60 | ASUS P6X58D-E | Zotac GTX 580 @ 872/1744/2145|Western Digital Caviar Black 1.5TB (Games/Steam)| Seagate 1.5TB (media/misc.) |Seagate 1 TB (OS/Main) | 24 GB G.Skill RipJaws X 1.5V DDR3-1333 | Creative X-Fi Titanium | Sennheiser HD 202 Headset | Dual Gigabit Realtek LAN | Antec True Power Quattro 1200W | Acer G235Hbmbd 23" LCD Display | Logitech K320 Wireless Keyboard | Logitech Performance MX Mouse
Intel17 is offline   Reply With Quote
Old 09-18-10, 11:26 PM   #1443
WeReWoLf
 
Join Date: Jul 2004
Location: Australia
Posts: 5,015
Send a message via MSN to WeReWoLf
Default Re: GTA IV PC Official Thread

SLI doesn't really work with GTA4.
WeReWoLf is offline   Reply With Quote
Old 09-19-10, 12:39 AM   #1444
JasonPC
Registered User
 
Join Date: Feb 2007
Posts: 2,103
Default Re: GTA IV PC Official Thread

The most recent patches murdered performance. Turning down shadows some should gain you a lot of FPS. Don't even try running shadows on very high, it causes a very unstable framerate (at least for me). Also make sure night shadows are off. You also may want to try disabling SLI for the game, because when I had SLI I noticed it made very strange framerate fluctuations even though the average was higher. Also make sure the view distance sliders aren't too high. Around 50-60 should be fine.

With these settings I'm getting a consistent 60 fps with vsync on with a 5870 and from what I've seen this game tends to like nvidia cards better.
JasonPC is offline   Reply With Quote
Old 09-19-10, 03:41 AM   #1445
WeReWoLf
 
Join Date: Jul 2004
Location: Australia
Posts: 5,015
Send a message via MSN to WeReWoLf
Default Re: GTA IV PC Official Thread

I'm currently running GTA4 with everything set to 100, shadows and night shadows on very high. Never drops below 40fps.
WeReWoLf is offline   Reply With Quote
Old 09-19-10, 09:37 AM   #1446
Soetdjuret
Teh lazy swede
 
Soetdjuret's Avatar
 
Join Date: Mar 2008
Location: Svea
Posts: 1,982
Default Re: GTA IV PC Official Thread

Bullsh*t
__________________
R.I.P Stage6 | per haud Justiciá illic exsisto haud pacís...
Soetdjuret is offline   Reply With Quote
Old 09-19-10, 01:28 PM   #1447
JasonPC
Registered User
 
Join Date: Feb 2007
Posts: 2,103
Default Re: GTA IV PC Official Thread

BTW installing the IE9 beta breaks the game's launcher. Just another sign of a quality port.
JasonPC is offline   Reply With Quote
Old 09-19-10, 01:32 PM   #1448
trivium nate
Registered User
 
Join Date: Dec 2007
Posts: 4,023
Default Re: GTA IV PC Official Thread

IE is fail anyways...FF all the way
__________________
CM-HAF-932//AMD Phenom-II-X4-965-BE-Deneb-3.4 GHz-Quad Core//CorsairH50
ASRock 770 EXTREME3 Mobo//EVGA GTX-480(1536MB GDDR5)-Arctic Cooling Accelero Xtreme+cooler
180GB SSD//3TB//G.SKILL Ripjaws X Series 8GB//DVD-RW//blu-Ray//1000 Watt Corsair PSU
42"Vizio TV-1920x1080-1080P-120Hertz//Win 7 Ultimate(64)//XBox360-pc controller
Saitek Eclipse 2 keyboard//Razer DeathAdder Mouse//250gb-Xbox 360//160gb-PS3
trivium nate is offline   Reply With Quote

Old 09-19-10, 01:34 PM   #1449
JasonPC
Registered User
 
Join Date: Feb 2007
Posts: 2,103
Default Re: GTA IV PC Official Thread

I think the game and launcher use IE which is one bad decision out of many for this abomination of a game.
JasonPC is offline   Reply With Quote
Old 09-19-10, 01:41 PM   #1450
Nitz Walsh
Registered User
 
Join Date: Jul 2002
Posts: 622
Default Re: GTA IV PC Official Thread

Quote:
Originally Posted by Soetdjuret View Post
Bullsh*t
He's got a 4ghz i7 - never dropping below 40fps should be damn well expected.
Nitz Walsh is offline   Reply With Quote
Old 09-20-10, 11:58 AM   #1451
Soetdjuret
Teh lazy swede
 
Soetdjuret's Avatar
 
Join Date: Mar 2008
Location: Svea
Posts: 1,982
Default Re: GTA IV PC Official Thread

Quote:
Originally Posted by Nitz Walsh View Post
He's got a 4ghz i7 - never dropping below 40fps should be damn well expected.
Dude, CPU isn't everything. My 3.5ghz quad q9550 with 12mb cache shoudn't be able to perform similar? BS

And i have similar performance gfx card as him (gtx 295)

Quote:
Originally Posted by JasonPC View Post
BTW installing the IE9 beta breaks the game's launcher. Just another sign of a quality port.
what kind of error message do you get?
__________________
R.I.P Stage6 | per haud Justiciá illic exsisto haud pacís...
Soetdjuret is offline   Reply With Quote
Old 09-20-10, 12:04 PM   #1452
JasonPC
Registered User
 
Join Date: Feb 2007
Posts: 2,103
Default Re: GTA IV PC Official Thread

What happens is the Rockstar Social Club launcher just doesn't launch at all. If you click it about 10 times or so it may randomly launch. Then you click to play the game and it just crashes after the intro screen if any saved games are present. If you remove the saved games the game will not crash if you happen to get it to launch. But as soon as you make a new save it ends up crashing again.

A bunch of people on the steam forum also reported the same exact problem and it was solved by uninstalling IE9. Some people think it may be the new version of flash that is installed with IE9 that's causing the problem.

Also my problems with the game weren't framerate related. If I ran the benchmark the framerate appeared to be fine (if you just looked at the number) even with full settings. But when you looked at it with your eyes it was a stuttery mess (caused by very high shadows for me). The last couple of patches messed with the shadow quality.

Performance is so inconsistent. For some people it's fine for other people with the same exact system it's horrible. But the consensus is performance is a lot worse ever since the patch that came out with EFLC.
JasonPC is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Official GeForce GTX 670 Review and Discussion Thread MikeC NVIDIA GeForce 600 Series 23 10-28-12 10:19 AM
Official nForce 2 Thread Matthyahuw CPUs, Motherboards And Memory 148 04-16-03 04:39 AM
Official Linux driver 1.0-3123 thread bammbamm808 NVIDIA Linux 126 12-05-02 06:21 PM
Official Grand Theft Auto 3 thread volt Gaming Central 6 08-01-02 07:04 AM

All times are GMT -5. The time now is 09:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.