Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-28-02, 07:41 PM   #1
loudawg
Guest
 
Posts: n/a
Default Geforce 440 Go, SuSE 8.0, and new Nvidia drivers

Hello everyone. I just bought a Toshiba Satellite 5105-S701 laptop a couple nights ago and am trying to get SuSE running on it. Here's my problem. I install SuSE. It gets to the configuration section for X. I choose the option that says "Use 3d acceleration". It gives me that message saying that this is just at dummy driver and the real 3d driver needs to be downloaded via Yast2's online update. Ok, no problem I think. So I choose the VESA 1600x1200@60Hz display adapter, because it obviously was not able to detect this screen by itself. I think it only allowed me to choose up to 16bit color, which is fine for now. I click Test, and wow, it's working perfectly! I'm happy. So I finish the installation, go to online update, get the new drivers, and reboot. Screen flickers a few times, and X fails to load. It says that a screen was found, but there was no usuable configuration.

I've been playing with this thing all day trying to get it to work. With the new NVIDIA drivers, the highest settings that X will work in now is 1280x1024, 24bit color, which isn't all that bad, but the fonts suddenly are HUGE and plus I know this thing will handle the 1600x1200, and so that's what I want!!

I've tried getting the drivers off of Nvidia directly. I got the ones made for this distro, didn't work. I got the source files and rebuilt them, didn't work. The ONLY way this has worked so far is to use the "dummy" driver "nv". And at this point right now, Yast is only allowing me to use 8bit color at 1600x1200. I hate stupid GUIs sometimes. I know it'll handle 16bit color cause it just did it a few hours ago! And it's actually supposed to be able to handle 24bit.

I played around with xmode and putting that line in the XF86Config file but that didn't really seem to help. It'll either just not work, or it'll choose 1280x1024 instead.

Is there ANY way to force this thing to use the settings I KNOW it can handle? Thank you very very much for any help.

Louie
  Reply With Quote
Old 08-29-02, 12:25 PM   #2
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

Hi Louie,

Hmm ... you can do all graphics and video settings
in ordinary text mode.
If you change the vga entry in the lilo.conf into
vga=normal and if you change the boot-time runlevel
into "without xdm" you should get the good old text mode login prompt.

!!! Do ALWAYS run "lilo" after you have made
any changes in /etc/lilo.conf !!!

then install Sax2,

You can start sax2 from a text console
after login as root. I think Sax2 offers more flexibility
than the yast2 video setting, especially the accelerated graphics support
. sax2 writes to the xf86confi
g file. Maybe you should check this out on your laptop
But why do you need such extremely high resolutions
on a laptop?? It's really bizarre :-)

When this works check the infos of the GLX README with the actually settings in your Xf86config file!

PS: DO not start or use Sax2 in X, it will crash and your keyboard and screen is dead!

Klaus
Klaus-P is offline   Reply With Quote
Old 08-29-02, 01:31 PM   #3
loudawg
Guest
 
Posts: n/a
Default

Klaus:

I've been using SaX2 almost the whole time while trying to get this thing to work, but to no avail. I actually got the test to work at 1400x1050 or something like that, but when booting X it just went to 1280x1024 anyways. I've tried everything, believe me. I know the YaST2 setup kinda sucks for the graphics stuff, but I've been using SaX2 the majority of the time. It will work in X, also. I have had it crash a couple times, but right now it has been working fine in X.

The reason I want that high of a resolution is because when it originally worked, I thought it just looked beautiful. Everything was in proportion and looked nice. After going down to 1280x1024, things looked too big. The fonts were way oversized, and I had to change the settings to make them look normal (size 9 is what I changed it to).

Also, because I know it can handle the higher resolution, I want the capability to use it. I'm kind of a perfectionist, you see, and it drives me nuts when I can't get things just the way I like them. :-) This is why Linux can sometimes drive me insane. I'll never leave it though. I love it too much..hehe

Lou
  Reply With Quote
Old 08-30-02, 04:40 AM   #4
Klaus-P
Registered User
 
Join Date: Aug 2002
Location: Germany
Posts: 134
Default

Lou,

you wrote:

> I actually got the test to work at 1400x1050 ....
it just went to 1280x1024 anyways.

This might be caused by the mode entries in the Screen Section of your Xf86config.
1400x1050 seems to be your default resolution. Check the manual resolution change
by pressing Ctrl, Alt, + or -(grey). I don't know whether or not this
will work on your laptop keyboard. Do also take a look at /var/log/XFree86.0.log
Among tons of stuff there should be a line beginning
with (**) then "validated modes... ". These are modes that are currently available.

Well test it also with a conventional keyboard (not necessarily
cableless :-)) plugged in if your laptop allows it.
Anyway, if this still doesn't work try setting the default resolution
to the highest possible level by using Sax2. I think
you should be able to run through all your predefined resolutions
choosen, tested and saved with SaX2. OK, the highest available resolution
, trillions of colors and highest speed performance is what you want, right? ;-)
If nothing is working ax all wrong resolution entries in your Xf86config.

Btw. running the nv-driver i got pixel and font salad in starOffice. Installing
the official nvidia driver fixed it.

Klaus
Klaus-P is offline   Reply With Quote
Old 06-01-04, 12:54 AM   #5
yestrday
Registered User
 
Join Date: May 2004
Posts: 1
Default Re: Geforce 440 Go, SuSE 8.0, and new Nvidia drivers

I'm using FC2 and have been experiencing the same problem since RH8.something. I have a Toshiba 5105-S701 also, and with the official nvidia driver I cannot get a resolution greater than 1400x1050. I've also noticed that the font in konsole appears larger with the nvidia driver than with the nv driver.

Here are attached my config and log files. FC2 uses Xorg xserver because of some sort of beef with the developers of the more common build, hence the Xorg.0.log logfile and xorg.conf replacing XFree86Config.
Attached Files
File Type: txt xorg.conf.txt (2.7 KB, 228 views)
File Type: txt Xorg.0.log.txt (28.5 KB, 201 views)
yestrday is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:06 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.