Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-03-08, 09:20 AM   #1
gastverh
Registered User
 
Join Date: Apr 2006
Posts: 36
Default nVidia and FC10

Hello,
In the past I was working fine in FC8 with installed:
kmod-nvidia and xorg-x11-drv-nvidia.
Yesterday, I successfully made an upgrade to FC10.
That means I came into the FC10 X-Window.
But the FC10-window was larger than the monitor-screen.
Code:
yum list installed | grep nvidia
did show that the old FC8-Version from kmod-nvidia and the other one was installed?
The I made an upgrade
Code:
yum upgrade kmod-nvidia
with automatically the other nvidia-packages.
Code:
================================================================================
 Package                    Arch   Version            Repository           Size
================================================================================
Installing:
 xorg-x11-drv-nvidia        i386   177.82-1.fc10      rpmfusion-nonfree   3.4 M
Installing for dependencies:
 kmod-nvidia                i686   177.82-1.fc10.4    rpmfusion-nonfree    23 k
 kmod-nvidia-2.6.27.5-117.fc10.i686
                            i686   177.82-1.fc10.4    rpmfusion-nonfree   2.4 M
 xorg-x11-drv-nvidia-libs   i386   177.82-1.fc10      rpmfusion-nonfree   6.0 M
A reboot did show only a Black Screen with a Blinking Cursor on it.
With the Rescue Option from my FC10 Installation CD, I could remove the nVidia drivers, and then I had my FC10 X-Window back.
Please, what can be the reason why the nVidia drivers did not match with FC10?
Many thanks in advance for any answer or solution,
Kind regards,
Gaston Verhulst.
gastverh is offline   Reply With Quote
Old 12-03-08, 10:46 AM   #2
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: nVidia and FC10

I'm using the NV drivers with Fedora 10 without issue.

I suspect the issue is simply that rpmfusion hasn't updated their packages to match the kernel in Fedora 10. You will probably have better luck installing using the official installer from www.nvidia.com.
Stephen Warren is offline   Reply With Quote
Old 12-03-08, 11:34 AM   #3
gastverh
Registered User
 
Join Date: Apr 2006
Posts: 36
Default Re: nVidia and FC10

Hallo,
Thank you for you prompt reply.
My videocard is nVidia GeForce FX 5200.
In www.nvidia.com I see an older Version from July 30.
So I think, it may be the best to be a little patient, until a newer driver is available?
Kind regards,
Gaston Verhulst.
gastverh is offline   Reply With Quote
Old 12-03-08, 01:38 PM   #4
kewlemer
Registered User
 
Join Date: Dec 2008
Posts: 3
Default Re: nVidia and FC10

http://www.fedoraforum.org/forum/sho...d.php?t=190223
kewlemer is offline   Reply With Quote
Old 12-04-08, 02:48 AM   #5
gastverh
Registered User
 
Join Date: Apr 2006
Posts: 36
Default Re: nVidia and FC10

I tried some tips from the link ...
One was:
Code:
yum install akmod-nvidia
and automatically other ones.
But the result was the same: a black screen with a blinking cursor.
I am thinking to be patient and to wait for an kernel and kmod-nvidia update.
I should need it only for TV-Out.
Thank you all for answering.
Kind regards,
Gaston Verhulst.
gastverh is offline   Reply With Quote
Old 12-04-08, 04:36 AM   #6
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: nVidia and FC10

You need to install 173.14.15 because newer drivers(177.x/178.x) don't support your card.
Thunderbird is offline   Reply With Quote
Old 12-04-08, 04:47 AM   #7
vadp
Registered User
 
Join Date: Jan 2005
Posts: 1
Default Re: nVidia and FC10

http://www.nvnews.net/vbulletin/showthread.php?t=122606

Quote:
Legacy releases for GeForce 5 series GPUs
Stable: 173.14.12
Beta: 173.14.15
oops a bit late
vadp is offline   Reply With Quote
Old 12-04-08, 01:11 PM   #8
gastverh
Registered User
 
Join Date: Apr 2006
Posts: 36
Default Re: nVidia and FC10

Thank you very much for the tip.
First of all, I like to read the readme file, about installing and configuration.
After that I will try it, and I will report the result.
Greetings,
Gaston Verhulst.
gastverh is offline   Reply With Quote

Old 12-04-08, 01:16 PM   #9
Belegdol
Registered User
 
Join Date: Oct 2004
Posts: 118
Default Re: nVidia and FC10

yum install xorg-x11-drv-nvidia-173xx
Belegdol is offline   Reply With Quote
Old 12-05-08, 02:53 AM   #10
gastverh
Registered User
 
Join Date: Apr 2006
Posts: 36
Default Re: nVidia and FC10

Hello,
Thanks for the reply ... and trying helping to solve it.
So I have tried:
Code:
# yum install xorg-x11-drv-nvidia-173xx
...
================================================================================
 Package                        Arch Version            Repository         Size
================================================================================
Installing:
 xorg-x11-drv-nvidia-173xx      i386 173.14.15-2.fc10   rpmfusion-nonfree 3.0 M
Installing for dependencies:
 kmod-nvidia-173xx              i686 173.14.15-1.fc10.4 rpmfusion-nonfree  23 k
 kmod-nvidia-173xx-2.6.27.5-117.fc10.i686
                                i686 173.14.15-1.fc10.4 rpmfusion-nonfree 2.5 M
 xorg-x11-drv-nvidia-173xx-libs i386 173.14.15-2.fc10   rpmfusion-nonfree 5.5 M


Transaction Summary
================================================================================
Install      4 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         
...
I am sorry I have to say that the result was the same bad one: first a black screen with a blinking cursor, followed by a black screen without cursor.

Looking in the /etc/X11/xorg.conf, I saw Driver "nvidia".

After
Code:
# yum remove xorg-x11-drv-nvidia-173xx
and again Driver "nv" in my xorg.conf,
I can reboot without any problem, a good thing too!

Kind regards,
Gaston Verhulst.
gastverh is offline   Reply With Quote
Old 01-28-09, 07:27 AM   #11
urbans
Registered User
 
Join Date: Jul 2007
Posts: 2
Default Re: nVidia and FC10

Its been a while since this thread was active. But I just upgraded my FC8 laptop to FC10 and realized that the nvidia driver won't work since I need the legacy driver for a 5200 card. And the legacy (173.14) does not support X11R7.4/Xorg 1.5 which is included in FC9/FC10. Is this correct?

Does anyone know if there has been any patching done to the legacy driver for the new X server so an old 5200 nvidia card could work?

Thanks,
Urban
urbans is offline   Reply With Quote
Old 01-28-09, 07:48 AM   #12
kwizart
Registered User
 
Join Date: Feb 2005
Location: Paris, France
Posts: 129
Default Re: nVidia and FC10

Legacy series 173xx 96xx (and even recent 71xx)
DO support recent Xorg server libdrm etc. (even for the Fedora11/Rawhide version)

What you need is to follow the Fedora HowTO for nVidia at rpmfusion.org

One of the most common mistake with the packaged driver for Fedora is that as replacement library need to be handled by a ModulePath addition in the xorg.conf . This is done automatically on reboot.

So please verify that you have in your /etc/X11/xorg.conf:
on x86 system:
Quote:
Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection
on x86_64:
Quote:
Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Last edited by kwizart; 01-28-09 at 08:57 AM. Reason: common mistake
kwizart is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.