Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-28-09, 10:01 AM   #73
nldudok1
Registered User
 
Join Date: Sep 2004
Posts: 40
Default Re: 180.11 powermizer still broken

installed 180.35
It is still broken.

Is it so hard to fix this?
Or do you have trouble to reproduce it?
Get a ACER aspire 6930G.
Install ubuntu 7.10 x86_64
Build and install kernel 2.6.27.6 with my supplied kernel config.
install nvidia 180.xx driver.
start glxgears
start nvidia-settings.
See that the higher powermizer levels are not reached.
Fix the driver untill it does.
Put driver releases on hold. Don't release any new drivers untill it it is fixed.
Any colleages that complain about not being able to release new drivers features:
Put them to work on fixing this issue.
Any bosses that complain about the driver being on hold.
Show them that this nvidia hardware does not perform with any driver release so far.
Show them the complains of their customers.
Tell them to contact us (customers) to explain why we have to keep working with broken non-performing drivers while they put up new marketing campains telling everybody that nvidia cards give you more performance.

THEY DON'T IF THE DRIVER IS BROKEN.

Here follows my experience with 180.35, still about the same as every driver I tested so far.

Since dmesg showed that MMCONF was used I tried the kernel parameter pci=nommconf.
This also did not help.

only performance level 0 and 1 (0: nvclock 169 memclock 100, 1: nvclock 275, memclock 250)
level 2 and 3 are never reached ( 2: nvclock 400 memclock 400, 3: nvclock 430, memclock 400)

64 bit system
driver: nvidia 180.35
system: ACER aspire 6930G
kernel: 2.6.27.6
kernelparams: pci=nommconf
distri: ubuntu gutsy 7.10 x86_64
Model: GeForce 9600M GS
IRQ: 16
Video BIOS: 62.94.3c.00.17
Card Type: PCI-E
DMA Size: 40 bits
DMA Mask: 0xffffffffff
Bus Location: 01.00.0

attached is my new nvidia-bug-report my kernel configuration and grub menu entry.
Attached Files
File Type: gz nvidia-bug-report.log.gz (46.0 KB, 61 views)
File Type: gz config-2.6.27.6.gz (21.5 KB, 45 views)
File Type: txt kernel-params.txt (197 Bytes, 56 views)
nldudok1 is offline   Reply With Quote
Old 02-28-09, 10:20 AM   #74
Mostrapotski
Registered User
 
Join Date: Feb 2009
Posts: 24
Default Re: 180.11 powermizer still broken

The thing that make me angry is that i saw people from nvidia posting around, AaronP, Stephen Warren, zander, ... and any of them are answering us. Not doing a good driver is a thing, ignoring us for a so long time is THE thing.

I won't let the post going down until someone from nvidia tell us "ok, we will fix it". I suggest everyone reading to post, once again, the bug report.

Here is mine, driver 180.29 (not the last i know but 35 is useless). Running on a MSI megabook GX620-069, with a 9600M GT.
Powermizer is going from 0 to 1, ignoring levels 2 and 3.
OpenSUSE 11.1, kernel 2.6.27.19-3.2-trace.

Join me plz, keep this post on the top
Attached Files
File Type: gz nvidia-bug-report.log.gz (31.7 KB, 94 views)
Mostrapotski is offline   Reply With Quote
Old 02-28-09, 05:08 PM   #75
wiresquire
Registered User
 
Join Date: Mar 2008
Posts: 81
Default Re: 180.11 powermizer still broken

ws asked: For 8700M GT does powermizer ever get to performance level 0 ?

Quote:
Originally Posted by kodiakmax View Post
I have not seen it hit performance level 0 yet. I was thinking maybe that desktop effects were maybe the cause for that. Of course nividia-settings thinks my power source is Battery as well. I believe that is because I am having acpi issues too. I have no files in /proc/acpi/ac_adapter which I believe might be caused by a buggy DSDT.
Sorry, forgot to mention that I had disabled Compiz/desktop effects because of tearing etc, so it was running in Performance Mode: Desktop. The power source was also correctly detected. Mine still never get to Performance level 0 when running on AC :-(

ws
wiresquire is offline   Reply With Quote
Old 03-07-09, 01:27 PM   #76
nldudok1
Registered User
 
Join Date: Sep 2004
Posts: 40
Default Re: 180.11 powermizer still broken

Installed 180.37
It is still broken, only lower powerlevers are ever used,

Only performance level 0 and 1 are used(0: nvclock 169 memclock 100, 1: nvclock 275, memclock 250)
level 2 and 3 are never reached ( 2: nvclock 400 memclock 400, 3: nvclock 430, memclock 400)

64 bit system
driver: nvidia 180.37
system: ACER aspire 6930G
kernel: 2.6.27.6
kernelparams: pci=nommconf
distri: ubuntu gutsy 7.10 x86_64
Model: GeForce 9600M GS
IRQ: 16
Video BIOS: 62.94.3c.00.17
Card Type: PCI-E


Attached are my new nvidia-bug-report, my kernel configuration and grub menu entry.
Attached Files
File Type: gz nvidia-bug-report.log.gz (45.7 KB, 51 views)
File Type: gz config-2.6.27.6.gz (21.5 KB, 47 views)
File Type: txt kernel-params.txt (185 Bytes, 32 views)
nldudok1 is offline   Reply With Quote
Old 03-09-09, 11:30 AM   #77
skektek
Registered User
 
Join Date: Oct 2004
Posts: 10
Default 180.29 powermizer still broken

I went out of my way to purchase a Notebook with an Nvidia card specifically for the Linux support and I get screwed. 9800M GS crippled @ 169/100MHz (0 of 3 "Performance Levels") thanks to PowerMizer. Adding Dwords values to xorg.conf or /etc/modprobe.d unlock my card to a whopping 275/300MHz (1 of 3 "Performance Levels"). Running nvidia-settings in a loop has absolutely no impact on the "Performance Level".

Mandriva 2009 PWP 32bit
Kernel 2.6.27.14
GeForce 9800M GS
Driver Version 180.29
VBIOS 62.94.55.00.00
Xorg 1.4.2
Attached Files
File Type: bz2 Nvidia_powermizer_bug.tar.bz2 (32.2 KB, 103 views)
skektek is offline   Reply With Quote
Old 03-09-09, 12:09 PM   #78
Mostrapotski
Registered User
 
Join Date: Feb 2009
Posts: 24
Default Re: 180.11 powermizer still broken

This is nvidia dev's call of duty! Same prob

Same problem,
openSUSE 11.1,
driver 180.29,
kernel 2.6.27.
Attached Files
File Type: zip nvidia-bug-report.log.zip (41.9 KB, 117 views)
Mostrapotski is offline   Reply With Quote
Old 03-14-09, 09:57 AM   #79
lavoisier
Registered User
 
Join Date: May 2006
Posts: 9
Default Re: 180.11 powermizer still broken

The topic should be renamed to "powermizer still broken". Maybe NVidia developers are ignoring this because of mentioning about version 180.11.

Within Gentoo installation I've gained much more 3D performance using solid kernel. Only ALSA modules and nvidia proprietary module are being used (must).

Glxgears (yes, no good performance test) shows ~1850 fps now. On previous distribution (Mandriva) it showed only 850-1250 fps (depending on configuration). It should be several thousands fps with PowerMizer working of course.

Gentoo 2008.0, driver 180.37, kernel 2.6.28.
Attached Files
File Type: gz nvidia-bug-report.log.gz (30.6 KB, 90 views)
lavoisier is offline   Reply With Quote
Old 03-15-09, 10:02 AM   #80
nldudok1
Registered User
 
Join Date: Sep 2004
Posts: 40
Default Re: 180.11 powermizer still broken

Installed 185.13
It is still broken, only lower powermizer powerlevers are ever used,

Only performance level 0 and 1 are used(0: nvclock 169 memclock 100, 1: nvclock 275, memclock 250)
level 2 and 3 are never reached ( 2: nvclock 400 memclock 400, 3: nvclock 430, memclock 400)

64 bit system
driver: nvidia 185.13
system: ACER aspire 6930G
kernel: 2.6.27.6
kernelparams: pci=nommconf
distri: ubuntu gutsy 7.10 x86_64
Model: GeForce 9600M GS
IRQ: 16
Video BIOS: 62.94.3c.00.17
Card Type: PCI-E

Another problem I still have is:
After returning from the XServer to console mode (ctrl-alt-F1) all I can see is a black screen. I can still work at the console - guessing what I type in - but I'm not able to see what I do.
Screen is black, backlight seems to be off.

This problem has been reported before, but I would like to mention here that it is still not solved.
It could be related to the powermizer problems although I doubt it.

See these related posts about the black/blank console:
http://www.nvnews.net/vbulletin/showthread.php?t=126854
http://www.nvnews.net/vbulletin/showthread.php?t=128017
http://www.nvnews.net/vbulletin/showthread.php?t=121355

Attached are my new nvidia-bug-report, my kernel configuration and grub menu entry.
Attached Files
File Type: gz nvidia-bug-report.log.gz (46.1 KB, 51 views)
File Type: gz config-2.6.27.6.gz (21.5 KB, 48 views)
File Type: txt grub-entry-kernel-params.txt (185 Bytes, 48 views)

Last edited by nldudok1; 03-15-09 at 10:53 AM. Reason: typo in driver version
nldudok1 is offline   Reply With Quote

Old 03-15-09, 12:02 PM   #81
Mostrapotski
Registered User
 
Join Date: Feb 2009
Posts: 24
Default Re: 180.11 powermizer still broken

Agreed, 185.13 doesn't help.
__________________
nvdevs, would you please fix the powermizer issue ?
my bug report.

Hope makes ppl leaving, i m beginning to leave too much.
Mostrapotski is offline   Reply With Quote
Old 03-17-09, 09:55 AM   #82
lavoisier
Registered User
 
Join Date: May 2006
Posts: 9
Default Re: 180.11 powermizer still broken

Same problem with blank screen in text console. Maybe stopping DM and forcing unload of nvidia kernel module could help, but I dont recommend it at all (dangerous !). Seems Nvidia drivers do something badly when using linux kernel. Waiting several months for the fix too.

But on the other side, NVidia drivers seem to be MUCH MUCH more stable than on Windows Vista. Never failed on Linux by me. On Vista it is usual the default behaviour when running 3D games :-). There is one site solving these problems and some of the solutions partially work (http://www.nvlddmkm.com/). So we should be satisfied, that 3D functionality works quite fine on linux.

But I will use Nouveau driver after getting more mature. I dont like binary blobs running in kernel mode. Only NVidia driver is the case.
lavoisier is offline   Reply With Quote
Old 03-17-09, 11:11 AM   #83
Reklawyks
Registered User
 
Join Date: Mar 2009
Posts: 3
Default Re: 180.11 powermizer still broken

maybe mass emailing about the powermizer issues would bring more attentions.
everyone should send an email to linux-bugs@nvidia.com explaining (re-explaining..) the bug with the attached nvidia-bug-report.log
Reklawyks is offline   Reply With Quote
Old 03-17-09, 02:34 PM   #84
Mostrapotski
Registered User
 
Join Date: Feb 2009
Posts: 24
Default Re: 180.11 powermizer still broken

send...
__________________
nvdevs, would you please fix the powermizer issue ?
my bug report.

Hope makes ppl leaving, i m beginning to leave too much.
Mostrapotski is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Daily Deal - Broken Sword Triple Pack, 75% off! News Gaming Headlines 0 06-11-12 01:50 PM
King Arthur Devs Reveal Broken Sea News Archived News Items 0 06-11-12 05:30 AM
Powermizer problem, nvidia 9500m gs ubuntu backtoback NVIDIA Linux 3 05-25-12 12:13 PM
ICC profile / LUT loading broken on the 302 betas? afxmac NVIDIA Linux 2 05-22-12 02:56 PM
Problem with powermizer, nvidia 9500m gs backtoback NVIDIA GeForce 7, 8, And 9 Series 0 05-18-12 02:10 PM

All times are GMT -5. The time now is 08:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.