Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-06-08, 07:33 PM   #1
Tonglebeqk
Registered User
 
Join Date: Jun 2008
Posts: 30
Default how to completely disable mode validation

In a nutshell, I'm going crazy because no matter what resolution I specify, the nvidia driver complains it wasn't able to validate it, so it defaults to 1024x768 when my monitor's native res is 1680x1050. It has a corrupt edid so I'm trying to just tell nvidia to use the ******* 1680x1050. I've tried using NoDFPNativeResolutionCheck, NoVirtualSizeCheck, but nvidia still wants to try to validate 1680x1050. How can I tell the nvidia driver to shove it and just use the damn resolution I ask it to use?
Tonglebeqk is offline   Reply With Quote
Old 12-07-08, 07:57 AM   #2
GraveR
Registered User
 
Join Date: Nov 2008
Posts: 6
Default Re: how to completely disable mode validation

You might want to use
Code:
Option         "UseEdidFreqs" "False"
to ignore the 'corrupt' edid.

Also, make sure that you fill in
Code:
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
matching your monitor.
GraveR is offline   Reply With Quote
Old 12-07-08, 09:21 AM   #3
Tonglebeqk
Registered User
 
Join Date: Jun 2008
Posts: 30
Default Re: how to completely disable mode validation

Well, that unfortunately hasn't done any good. Here's my xorg.conf if any clues can be had from this:

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
EndSection

#Section "Monitor"
# Identifier "CRTMonitor"
# VendorName "Envision"
# ModelName "EFT720"
# HorizSync 30.0 - 72.0
# VertRefresh 50.0 - 130.0

Section "Monitor"
Identifier "LCD"
VendorName "Samsung"
ModelName "2232BW"
Option "UseEDID" "false"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "Mode" "1680x1050"
EndSection

Section "Device"
Identifier "NvidiaCard"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "OnDemandVBlankInterrupts" "true"
Option "NoLogo" "TRUE"
Option "Coolbits" "1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NvidiaCard"
Monitor "LCD"
DefaultDepth 24
Option "ModeValidation" "NoDFPNativeResolutionCheck, NoVirtualSizeCheck,NoMaxPClkCheck,NoHorizSyncCheck ,NoVertRefreshCheck,NoWidthAlignmentCheck"
SubSection "Display"
Depth 24
Modes "1680x1050"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
Tonglebeqk is offline   Reply With Quote
Old 12-07-08, 09:22 AM   #4
Tonglebeqk
Registered User
 
Join Date: Jun 2008
Posts: 30
Default Re: how to completely disable mode validation

And here's the relevant portion of Xorg.0.log:

(**) NVIDIA(0): Ignoring EDIDs
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(GPU-0): Not probing EDID on CRT-0.
(II) NVIDIA(0): NVIDIA GPU GeForce GTX 260 (GT200) at PCI:2:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 917504 kBytes
(--) NVIDIA(0): VideoBIOS: 62.00.1a.00.60
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce GTX 260 at PCI:2:0:0:
(--) NVIDIA(0): CRT-0
(--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Mode Validation Overrides for CRT-0:
(II) NVIDIA(0): NoMaxPClkCheck
(II) NVIDIA(0): NoHorizSyncCheck
(II) NVIDIA(0): NoVertRefreshCheck
(II) NVIDIA(0): NoWidthAlignmentCheck
(II) NVIDIA(0): NoDFPNativeResolutionCheck
(II) NVIDIA(0): NoVirtualSizeCheck
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1680x1050"; removing.
Tonglebeqk is offline   Reply With Quote
Old 12-07-08, 10:03 AM   #5
adamorjames
Registered User
 
adamorjames's Avatar
 
Join Date: Oct 2008
Posts: 39
Default Re: how to completely disable mode validation

Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Seiko"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
EndSection
and then under screen

Code:
Monitor        "Monitor0"
DefaultDepth    24
Option         "metamodes" "1680x1050_60 +0+0;
or maybe

Code:
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1680x1050"
    EndSubSection
Make sure to change some of the info to reflect your monitor.
adamorjames is offline   Reply With Quote
Old 12-07-08, 12:06 PM   #6
Tonglebeqk
Registered User
 
Join Date: Jun 2008
Posts: 30
Default Re: how to completely disable mode validation

None of that works. I just want nvidia to skip mode validation altogether and use what i ask it to use!
Tonglebeqk is offline   Reply With Quote
Old 12-09-08, 10:32 AM   #7
flakrat
Registered User
 
Join Date: Apr 2007
Posts: 14
Default Re: how to completely disable mode validation

I'm running into the same problem. My user has a Dell 2005FPW monitor that has a native resolution of 1680x1050 at 60Hz.

The monitor is connected via the analog connector (she has the DVI plugged into another machine) into a Quadro FX 550 card on a RHEL4 x86_64 system.

I've tried a bunch of different ways to get it to go to 1680x1050, but I always end up with the dreaded "No valid modes for "1680x1050"

Here's the output after using the above suggestion:

Quote:
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "MetaModes" "1680x1050_60 +0+0"
(**) NVIDIA(0): Enabling RENDER acceleration
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
(II) NVIDIA(0): NVIDIA GPU Quadro FX 550 (NV43GL) at PCI:7:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 05.43.02.97.01
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on Quadro FX 550 at PCI:7:0:0:
(--) NVIDIA(0): CRT-0
(--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1680x1050_60+0+0"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(WW) NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) NVIDIA(0): from CRT-0's EDID.
(**) NVIDIA(0): DPI set to (58, 70); computed from "DisplaySize" Monitor
(**) NVIDIA(0): section option
(==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
And here's the latest xorg.conf file

Quote:
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell 2005FPW (Analog)"
# UseModes "16:10"
DisplaySize 444 277
HorizSync 30.0 - 83.0
VertRefresh 60.0
# Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA PCI-Express Quadro FX 550"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
# Option "Overlay" "True"
Option "metamodes" "1680x1050_60 +0+0"
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1680x1050" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1680x1050"
EndSubSection
EndSection
flakrat is offline   Reply With Quote
Old 12-09-08, 01:31 PM   #8
Vortex
Registered User
 
Vortex's Avatar
 
Join Date: Jan 2005
Posts: 20
Default Re: how to completely disable mode validation

Code:
(WW) NVIDIA(0): No valid modes for "1680x1050"; removing.
I guess you have to specify a Modeline, then.

First generate a Modeline using the tool gtf:
Code:
$ gtf 1680 1050 60

  # 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
  Modeline "1680x1050_60.00"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync
Then put the Modeline in the "Monitor" Section of your xorg.conf. Note that the new mode you just defined is called "1680x1050_60.00" and not "1680x1050" so you have to change the "Modes" line in your "Screen" Section, too:
Code:
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1680x1050_60.00"
EndSubSection
EndSection
I think you can remove all the "metamodes" and whatnot.
Vortex is offline   Reply With Quote

Old 12-09-08, 04:32 PM   #9
flakrat
Registered User
 
Join Date: Apr 2007
Posts: 14
Default Re: how to completely disable mode validation

Thanks, I didn't know a about the gtf command.

It looks like I was a victim of two competing issues:
1. Originally a missconfigured xorg.conf file
2. The user having an improper resolution set in their .gconf/desktop/gnome/screen/default/0/%gconf.xml file

They had <stringvalue>1600x1024</stringvalue>, which was overriding what I'd set in xorg.conf

The monitor doesn't support this resolution, and they ended up with a part of the desktop being cropped.

Oh, and combine that with linux reporting that it was a Dell 2005FPW when it's actually a 2007FP, I've been trying to force 1680x1050 when it should have been 1600x1200.

Bleh, oh well, I learned a good deal during this process. It's difficult troubleshooting display settings when you don't have physical access to the machine.
flakrat is offline   Reply With Quote
Old 06-30-09, 04:48 PM   #10
chinaski5
Registered User
 
Join Date: Jun 2009
Posts: 1
Smile Re: how to completely disable mode validation

Thanks alot guys!!

I was going crazy with this problem. What finally did the trick (apparently!) was setting

Option "ModeValidation" "NoDFPNativeResolutionCheck, NoVirtualSizeCheck,NoMaxPClkCheck,NoHorizSyncCheck ,NoVertRefreshCheck,NoWidthAlignmentCheck"

along with using the gtf command modeline!!

You guys rock.
chinaski5 is offline   Reply With Quote
Old 06-30-09, 07:07 PM   #11
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: how to completely disable mode validation

Since this seems the right thread to me to add this information:
To allow usage of 1920x1200@85 on my Geforce 8400 (G98), I need the following line in the Device section of xorg.conf (note that this is not an EDID issue, but the driver believes the graphic card will not support the resolution):
Code:
Option "ModeValidation" "NoExtendedGpuCapabilitiesCheck"
Carl Eugen
cehoyos is offline   Reply With Quote
Old 07-14-09, 03:24 AM   #12
hdas
Registered User
 
Join Date: Aug 2007
Posts: 17
Default Re: how to completely disable mode validation

Quote:
Originally Posted by chinaski5 View Post
Option "ModeValidation" "NoDFPNativeResolutionCheck, NoVirtualSizeCheck,NoMaxPClkCheck,NoHorizSyncCheck ,NoVertRefreshCheck,NoWidthAlignmentCheck"
Thanks a lot for this "ModeValidation" option. It fixed my scaling woes . I have a Asus G50VT-X6 notebook with a Seiko internal lcd panel and native resolution 1680x1050. While the native resolution works, the smaller modes like 1280x1024 and 1024x768 etc didn't use to work - the native resolution was the only one available. This fixed it. I fortunately didn't require any gtf stuff, though useful to know. Also, only using the "NoExtendedGpuCapabilitiesCheck" parameter didn't help for me.
hdas is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 02:40 AM
Very slow X startup Jeremy NVIDIA Linux 96 05-23-03 11:11 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 11:46 PM
Nvidia GF4 MX 440 + Mandrake tomchristopher NVIDIA Linux 3 08-18-02 10:42 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 12:34 PM

All times are GMT -5. The time now is 08:06 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.