Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-23-08, 05:01 AM   #1
raphoun
Registered User
 
Join Date: Jun 2007
Location: Orlťans (france)
Posts: 24
Default Beta: 180.18 doesnt install correctly

Hello,

I just try to install this beta version and I got this error during the installation process:
Quote:
ERROR: Unable to open '/usr/lib/xorg/modules/extensions/libglx.so' for reading (no such file or directory)
And after Xorg didn't start.

RaphaŽl
raphoun is offline   Reply With Quote
Old 12-23-08, 05:10 AM   #2
blackiron
Registered User
 
Join Date: Dec 2008
Posts: 17
Default Re: Beta: 180.18 doesnt install correctly

There are not "/dev/nvidia0"and "/dev/nvidiactl" on ubuntu 8.10 for 180.18 ver.
But they are there for 180.16.

Why ?
blackiron is offline   Reply With Quote
Old 12-23-08, 05:12 AM   #3
phaedrusiszen
Registered User
 
Join Date: Dec 2008
Posts: 23
Default Re: Beta: 180.18 doesnt install correctly

Quote:
Originally Posted by blackiron View Post
There are not "/dev/nvidia0"and "/dev/nvidiactl" on ubuntu 8.10 for 180.18 ver.
But they are there for 180.16.

Why ?
Your kernel module is not loading if those device files don't exist.
Try "modprobe nvidia" with super user permissions. Check dmesg after to see if there is any information there.
phaedrusiszen is offline   Reply With Quote
Old 12-23-08, 05:22 AM   #4
PeriQuete
Registered User
 
Join Date: Dec 2008
Posts: 7
Default Re: Beta: 180.18 doesnt install correctly

Quote:
Originally Posted by raphoun View Post
Hello,

I just try to install this beta version and I got this error during the installation process:


And after Xorg didn't start.

RaphaŽl
same problem.
kubuntu 8.04
PeriQuete is offline   Reply With Quote
Old 12-23-08, 09:12 AM   #5
polpodan
Registered User
 
Join Date: Sep 2004
Posts: 6
Default Re: Beta: 180.18 doesnt install correctly

Works fine with Arch Linux. Thanks NVIDIA!
polpodan is offline   Reply With Quote
Old 12-23-08, 10:44 AM   #6
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Beta: 180.18 doesnt install correctly

To all people having problems getting 180.18 installed. Please can you:

a) Install 180.18 again
b) Attempt to start X again
c) Generate an nvidia bug report (see stickies in this forum) and post it here.

Without this information, people can't really help you.

Thanks!
Stephen Warren is offline   Reply With Quote
Old 12-23-08, 11:05 AM   #7
blackiron
Registered User
 
Join Date: Dec 2008
Posts: 17
Default Re: Beta: 180.18 doesnt install correctly

Quote:
Originally Posted by phaedrusiszen View Post
Your kernel module is not loading if those device files don't exist.
Try "modprobe nvidia" with super user permissions. Check dmesg after to see if there is any information there.
I do it !

There is a big difference dmesg log between 180.16 and 180.18.

I cut content about nvidia.

dmesg log from 180.16 about nvidia:

Only these!
Code:
[   29.190601] nvidia: module license 'NVIDIA' taints kernel.
[   29.454024] nvidia 0000:01:00.0: power state changed by ACPI to D0
[   29.454041] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   29.454049] nvidia 0000:01:00.0: setting latency timer to 64
[   29.454495] NVRM: loading NVIDIA UNIX x86 Kernel Module  180.16  Fri Dec 12 12:40:20 PST 2008
But dmesg log from 180.18 about nvidia:
Quote:
[ 25.376197] Bluetooth: RFCOMM ver 1.10
[ 29.264755] nvidia: module license 'NVIDIA' taints kernel.
[ 29.536686] nvidia 0000:01:00.0: power state changed by ACPI to D0
[ 29.536700] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 29.536715] nvidia 0000:01:00.0: setting latency timer to 64
[ 29.536849] NVRM: loading NVIDIA UNIX x86 Kernel Module 173.14.12 Thu Jul 17 18:11:36 PDT 2008
[ 29.539420] NVRM: API mismatch: the client has the version 180.18, but
[ 29.539421] NVRM: this kernel module has the version 173.14.12. Please
[ 29.539422] NVRM: make sure that this kernel module and all NVIDIA driver
[ 29.539423] NVRM: components have the same version.
[ 29.751821] iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
.
.
.
[ 32.016273] wlan0: disassociating by local choice (reason=3)
[ 32.628880] NVRM: API mismatch: the client has the version 180.18, but
[ 32.628882] NVRM: this kernel module has the version 173.14.12. Please
[ 32.628883] NVRM: make sure that this kernel module and all NVIDIA driver
[ 32.628884] NVRM: components have the same version.
[ 35.768149] NVRM: API mismatch: the client has the version 180.18, but
[ 35.768154] NVRM: this kernel module has the version 173.14.12. Please
[ 35.768157] NVRM: make sure that this kernel module and all NVIDIA driver
[ 35.768160] NVRM: components have the same version.
[ 39.105903] mtrr: base(0xd1000000) is not aligned on a size(0xe00000) boundary
.
.
.
Attached Files
File Type: log dmesg_log_from_180.16.log (54.7 KB, 64 views)
File Type: log dmesg_log_from_180.18.log (55.0 KB, 71 views)
blackiron is offline   Reply With Quote
Old 12-23-08, 11:20 AM   #8
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Beta: 180.18 doesnt install correctly

Again, you still have parts of 173.14.12 on your system.

Remove those, else it won't work.

If you installed this via the package manager, use it to remove these leftovers. If you used envy, remove it with envy. If you installed the driver manually, which you should not have done in the first place, use the nvidia .run file to remove it.

Clearly not a fault in the new driver.

Kind regards

Fuchs
NvFuchs is offline   Reply With Quote

Old 12-23-08, 11:21 AM   #9
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: Beta: 180.18 doesnt install correctly

You still have the old (173.14.12) kernel module installed and not the new one.
Dragoran is offline   Reply With Quote
Old 12-23-08, 11:25 AM   #10
artem
Registered User
 
Join Date: Jun 2006
Posts: 711
Default Re: Beta: 180.18 doesnt install correctly

Clearly, NVIDIA should have added this error message to indicate that user is trying to mess up with his system:

ERROR: YOU HAVE REMNANTS OF THE OLD $VERSION DRIVERS IN YOUR SYSTEM
ERROR: REMOVE YOUR OLD DRIVERS OR NEW DRIVERS WILL NOT WORK


:-)

Last edited by artem; 12-23-08 at 11:27 AM. Reason: formatting
artem is offline   Reply With Quote
Old 12-23-08, 12:07 PM   #11
blackiron
Registered User
 
Join Date: Dec 2008
Posts: 17
Default Re: Beta: 180.18 doesnt install correctly

Quote:
Originally Posted by NvFuchs View Post
Again, you still have parts of 173.14.12 on your system.

Remove those, else it won't work.

If you installed this via the package manager, use it to remove these leftovers. If you used envy, remove it with envy. If you installed the driver manually, which you should not have done in the first place, use the nvidia .run file to remove it.

Clearly not a fault in the new driver.

Kind regards

Fuchs
I have uninstalled 173.14.12. The dmesg log showed nothing about nvidia.
But Once I have installed "NVIDIA-Linux-x86-180.18-pkg1.run", dmesg log showed 173.14.12 coming. When I install 180.16 ,nothing comes about 173.14.12.

Quote:
[ 346.123647] nvidia: module license 'NVIDIA' taints kernel.
[ 346.378919] nvidia 0000:01:00.0: power state changed by ACPI to D0
[ 346.378934] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 346.378948] nvidia 0000:01:00.0: setting latency timer to 64
[ 346.379128] NVRM: loading NVIDIA UNIX x86 Kernel Module 180.18 Thu Dec 18 14:29:33 PST 2008
[ 463.747676] nvidia 0000:01:00.0: setting latency timer to 64
[ 463.747966] NVRM: loading NVIDIA UNIX x86 Kernel Module 173.14.12 Thu Jul 17 18:11:36 PDT 2008
Kind regards

blackiron
blackiron is offline   Reply With Quote
Old 12-23-08, 12:14 PM   #12
phaedrusiszen
Registered User
 
Join Date: Dec 2008
Posts: 23
Default Re: Beta: 180.18 doesnt install correctly

Quote:
Originally Posted by blackiron View Post
I have uninstalled 173.14.12. The dmesg log showed nothing about nvidia.
But Once I have installed "NVIDIA-Linux-x86-180.18-pkg1.run", dmesg log showed 173.14.12 coming. When I install 180.16 ,nothing comes about 173.14.12.



Kind regards

blackiron
"updatedb && locate nvidia.ko"
Post all the hits.
phaedrusiszen is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mageia 2 Cannot Install 71.86.15 for Riva TNT/TNT2 kbulgrien NVIDIA Linux 3 06-29-12 08:27 AM
No Guild Wars 2 beta this weekend News Archived News Items 0 05-24-12 08:10 AM
nForce + RedHat 7.3 Success Story rtz NVIDIA Linux 47 02-15-03 02:20 AM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
can't install old det's after 40.41's m!n!0n NVIDIA Windows Graphics Drivers 1 09-16-02 11:58 AM

All times are GMT -5. The time now is 02:28 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.