Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-23-08, 11:30 AM   #1
coz_
Registered User
 
Join Date: Jan 2008
Posts: 13
Default I dont want window maximizing on one monitor

Hello
I have nvidia 177 upgraded from 169.12 driver however, different from the 169.12 driver, my windows now maximize on one monitor instead of across both and full screen dual monitor videos of course dont work either.
Here is what I had with 169.12;
does NOT boot to twinview I set this after logging in if i want dual monitors
Full screen dual monitor videos
windows maximize across both monitors and not on single monitor

Although the window maximizing on one monitor is fine and comes in handy however full screen dual monitor videos are necesary since this system is more mulitmedia for me personally and single monitor videos are real ugly to watch
so I want dynamic twinview... also full screen dual monitor videos etcetc
I have tried Option "NoTwinViewXineramaInfoOrder" "true" however that only works if Option "TwinView" "true" is enabled which is out of the question for my system
so again I want single monitor when I boot , enable twinview via nvidia-settings... full dual screen videos and no max windows on single monitor
what would I use to set this in xorg.conf to get what I had with 169.12??
thanks


coz
coz_ is offline   Reply With Quote
Old 12-23-08, 02:31 PM   #2
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: I dont want window maximizing on one monitor

If you are the coz_ I think you are, then you should be aware of _NET_WM_FULLSCREEN_MONITORS. The Window Manager who is responsible for maximizing should be configurable to allow a full maximize on key press using this hint. As for compiz this would be a nice addition to the extra wm actions plugin, as for other wms you probably have to get in touch with the developers.

The old behavior was a bug, and I am not aware of a easy solution to reproduce it.

Kind regards

Fuchs
NvFuchs is offline   Reply With Quote
Old 12-23-08, 03:13 PM   #3
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: I dont want window maximizing on one monitor

Note: You will need compiz git (or backport the patch from git) to have _NET_WM_FULLSCREEN_MONITORS support.
Dragoran is offline   Reply With Quote
Old 12-23-08, 03:44 PM   #4
Windseeker
Registered User
 
Join Date: Dec 2006
Posts: 38
Default Re: I dont want window maximizing on one monitor

afaik KDE 4.2b2 has support for this.
http://techbase.kde.org/Schedules/KD...Changelog#KWin
Windseeker is offline   Reply With Quote
Old 12-23-08, 06:50 PM   #5
coz_
Registered User
 
Join Date: Jan 2008
Posts: 13
Default Re: I dont want window maximizing on one monitor

Hey guys thanks,
and Fuchs yeah I think I am the coz_ you think i am

there are times when some things just seem to not be apparent!

coz
coz_ is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.17 nvidiaXineramaInfoOverride not working properly hlandgar NVIDIA Linux 11 01-21-13 08:53 AM
Problems with configuring monitors and keeping them disabled with 302.17 Erosmith NVIDIA Linux 2 06-20-12 12:10 AM
First monitor is black when going to virtual console, when using twinView zeBarbu NVIDIA Linux 2 09-07-03 09:35 PM
Sony SDM-S51 monitor and GeForce4 problem hassasin NVIDIA GeForce 7, 8, And 9 Series 4 10-12-02 04:10 PM
Monitor packed in? Head_slinger General Hardware 2 09-16-02 11:27 AM

All times are GMT -5. The time now is 11:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.