Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-31-08, 12:33 PM   #1
Ceniza
Registered User
 
Join Date: Dec 2008
Posts: 7
Default Failed to find a valid SLI configuration

I'm not really sure when it started to happen, but now SLI is not working. When I first got my cards, SLI worked after adding a single line to the xorg.conf file. Now Xorg.0.log shows an error stating that my chipset is not approved for SLI.

I have an ASUS Striker II Extreme, which has an nForce 790i Ultra SLI chipset. I also got two PNY 9800GTX+ cards and connected them with the provided cable. Why wouldn't that be an approved chipset? Once again, it worked before.

I just tried the latest beta driver (180.18) and got the same exact result: no SLI.

Am I missing something obvious here?

As suggested, I attach nvidia-bug-report.
Attached Files
File Type: zip nvidia-bug-report.zip (31.0 KB, 127 views)
Ceniza is offline   Reply With Quote
Old 01-24-09, 06:26 AM   #2
Ceniza
Registered User
 
Join Date: Dec 2008
Posts: 7
Default Re: Failed to find a valid SLI configuration

I'm overwhelmed with all the answers I've received about this issue.
Ceniza is offline   Reply With Quote
Old 01-26-09, 11:52 AM   #3
F.User_4_Life
Registered User
 
Join Date: Jan 2009
Posts: 12
Default Re: Failed to find a valid SLI configuration

ok first off u should post your xorg so we cdan see what line u added. its possible u need to make a completely new xorg and force it to use one of the cards as the master and the other as a slave.

i cant really help u as i am haveing issues getting sli to work in the first place. im useing fedora9 if it matters and made a post about it. nvm that now please post your xorg as it will help guide people as how to help u not only does the bug report help but xorg is important to mainly cause of the function of the file that tell how to to and what to do its important.

please post it please i may eve be able to help. ill look at your bug report and analize it see if theres a difference with it to mine and cdampare make judgement and so on...


F.User_4_Life is offline   Reply With Quote
Old 01-26-09, 12:14 PM   #4
F.User_4_Life
Registered User
 
Join Date: Jan 2009
Posts: 12
Thumbs up Re: Failed to find a valid SLI configuration

here is my xorg and the link below is for my bug report i dont have my second card in i took it out so i still could use 3d renders.

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "Module"
Load "type1"
Load "freetype"
Load "glx"
Load "dbe"
Load "extmod"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


have fun i uploaded the my nvidia bug report at mediafire i like the site..

http://www.mediafire.com/?nyzmszmzemc
F.User_4_Life is offline   Reply With Quote
Old 01-26-09, 01:53 PM   #5
Ceniza
Registered User
 
Join Date: Dec 2008
Posts: 7
Default Re: Failed to find a valid SLI configuration

The contents of xorg.conf are included in the attached file, but I'll paste them here anyway:

Section "ServerLayout"
Identifier "Simple Layout"
Screen 0 "nVidia-Screen" 0 0
InputDevice "Mouse" "CorePointer"
InputDevice "Keyboard" "CoreKeyboard"
EndSection

Section "Files"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/local/share/fonts"
EndSection

Section "Module"
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "freetype"
Load "glx"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard"
Driver "kbd"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl"
EndSection

Section "InputDevice"
Identifier "Mouse"
Driver "mouse"
Option "Protocol" "IMPS/2" # IntelliMouse PS/2
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "P241w"
HorizSync 30.0 - 82.0
VertRefresh 56.0 - 80.0
DisplaySize 506 315 # 96 DPI @ 1900x1200
#Option "DPMS" "true"
EndSection

Section "Device"
Identifier "nVidia-Device"
Driver "nvidia"
#Option "AddARGBGLXVisuals" "true"
Option "NoLogo" "true"
#Option "MultiGPU" "true"
Option "SLI" "true"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "nVidia-Screen"
Device "nVidia-Device"
Monitor "P241w"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
Option "XVideo" "Enable"
EndSection

Section "DRI"
Mode 0666
EndSection
Ceniza is offline   Reply With Quote
Old 01-27-09, 12:13 AM   #6
F.User_4_Life
Registered User
 
Join Date: Jan 2009
Posts: 12
Default Re: Failed to find a valid SLI configuration

Section "Device"
Identifier "nVidia-Device"
Driver "nvidia"
#Option "AddARGBGLXVisuals" "true"<-- "i think this is it delete the # symbol u need this to get 3d renders its to enable opengl and glx and things like that"
Option "NoLogo" "true"
#Option "MultiGPU" "true"<-------------- this u dont need
Option "SLI" "true"<---------- set this to auto so it automatically enables the sli function
BusID "PCI:1:0:0"<------------ not sure i think this is right do this /sbin/lspci | grep -i vga ---copy and paste me as root in terminal for gnome
EndSection

first thing first delete the # on option AddARGBGLXVisuals and restart see if it helps if not then not sure wht to tell you cause that line is screaming out with that # symbol it means to ignore the option as u need it. dont do it to soon wait till a real qualified nvidia guy or lady comes along to correct me ok


also here is a link to a web site that tells u all the nvidia-xconfig commands and options

http://linux.die.net/man/1/nvidia-xconfig

im curious as to your distro it may give others an idea on how to help im a fedora user so i may not be able to help but i hope the command helps


now when u do the cd it will look something like this

[root@sulpher ~]# /sbin/lspci | grep -i vga
02:00.0 VGA compatible controller: nVidia Corporation Unknown device 084d (rev a2)
03:00.0 VGA compatible controller: nVidia Corporation Unknown device 0641 (rev a1)

the

02:00.0 &
03:00.0 are the pci slots so mine would look something like this

Section "Device"
Identifier "nVidia-Device"
Driver "nvidia"
Option "AddARGBGLXVisuals" "true"
Option "NoLogo" "true"
Option "SLI" "auto"
BusID "PCI:2:0:0"
EndSection
F.User_4_Life is offline   Reply With Quote
Old 01-27-09, 11:15 AM   #7
Ceniza
Registered User
 
Join Date: Dec 2008
Posts: 7
Default Re: Failed to find a valid SLI configuration

I tried your suggestion, but I have the same problem.

(**) NVIDIA(0): Option "NoLogo" "true"
(**) NVIDIA(0): Option "SLI" "auto"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "true"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): NVIDIA SLI auto-select rendering option.
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to find a valid SLI configuration.
(EE) NVIDIA(0): Invalid SLI configuration 1 of 1:
(EE) NVIDIA(0): GPUs:
(EE) NVIDIA(0): 1) NVIDIA GPU at PCI:1:0:0
(EE) NVIDIA(0): 2) NVIDIA GPU at PCI:2:0:0
(EE) NVIDIA(0): Errors:
(EE) NVIDIA(0): - Chipset not approved for SLI
(WW) NVIDIA(0): Failed to find a valid SLI configuration for the NVIDIA
(WW) NVIDIA(0): graphics device PCI:1:0:0. Please see Chapter 25:
(WW) NVIDIA(0): Configuring SLI and Multi-GPU FrameRendering in the README
(WW) NVIDIA(0): for troubleshooting suggestions.
(EE) NVIDIA(0): Only one GPU will be used for this X screen.
(II) NVIDIA(0): NVIDIA GPU GeForce 9800 GTX/9800 GTX+ (G92) at PCI:1:0:0
(II) NVIDIA(0): (GPU-0)

It just refuses to accept my nForce 790i Ultra, which makes no sense at all.
Ceniza is offline   Reply With Quote
Old 02-22-09, 02:42 AM   #8
El1iP3S01D
Saleen s7 TT Rocks:-0
 
El1iP3S01D's Avatar
 
Join Date: Nov 2007
Location: nyc, NY
Posts: 34
Default Re: Failed to find a valid SLI configuration

This is how you help the driver find the sli configuration, you type on the Device section

BusID "PCI:2:0:0" and sudo nvidia-xconfig --only-one-x-screen --sli=Auto and voila...
__________________
Patiently, waiting for Death who is close and closer?
El1iP3S01D is offline   Reply With Quote

Old 02-22-09, 12:04 PM   #9
Ceniza
Registered User
 
Join Date: Dec 2008
Posts: 7
Default Re: Failed to find a valid SLI configuration

Quote:
Originally Posted by El1iP3S01D View Post
This is how you help the driver find the sli configuration, you type on the Device section

BusID "PCI:2:0:0" and sudo nvidia-xconfig --only-one-x-screen --sli=Auto and voila...
Same problem.
Ceniza is offline   Reply With Quote
Old 07-04-09, 03:18 AM   #10
Ceniza
Registered User
 
Join Date: Dec 2008
Posts: 7
Default Re: Failed to find a valid SLI configuration

Driver version: 180.60
Kernel: 2.6.30
XOrg: 1.6.1.901

Same problem. The driver refuses to enable SLI because "the nForce 790i Ultra SLI chipset is not approved for SLI".

Once again, it worked when I first got this PC in November 2008, and it still works in Windows.

It looks like all I will be able to do is to post about every 6 months confirming it does not work.
Ceniza is offline   Reply With Quote
Old 09-26-09, 06:48 AM   #11
Ceniza
Registered User
 
Join Date: Dec 2008
Posts: 7
Default Re: Failed to find a valid SLI configuration

Driver version: 185.18.31
Kernel: 2.6.31
XOrg: 1.6.3.901-r2

Now it works!

Gotta wonder why it did not work before.
Ceniza is offline   Reply With Quote
Old 09-26-09, 07:04 AM   #12
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: Failed to find a valid SLI configuration

Quote:
Originally Posted by F.User_4_Life View Post
#Option "AddARGBGLXVisuals" "true"<-- "i think this is it delete the # symbol u need this to
That is not only wrong but the option is enabled by default anyway.
Dragoran is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM

All times are GMT -5. The time now is 08:37 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.