Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-05-09, 04:15 AM   #1
renenel
Registered User
 
Join Date: Jan 2009
Posts: 8
Question Compiz white screen

Hi all,

I'm currently using Linux Mandriva 2007.0 with GeForce 7600 for a couple of years now, and I'm quite satisfied with it. After updating my nVidia driver, it seems like compiz no longer works.

- When starting GNOME without any 3D effects, everything works fine - be there are no 3D effects

- When starting it with AIGLX support - it starts without any effects, plus there are no window decorators. Please note that before updating the driver, AIGLX mode was disabled.

- When starting it with GLX support (that used to work) - it starts, I can see the cursor move around and change according to each position on the screen - but the screen is completely white. I can rotate the cube around, and use different special effects. But still - the screen is completely white. The only way to get around it is to restart the X server and turn off the effects.

I've tried the following:
1. Messing around with xorg.conf, trying different options - nothing worked.
2. Trying to reconfigure the video card via the mandriva control center - only caused my X to crash horribly. Reinstalling the driver got it back to the state seen above.
3. Googling my questions, then googling it some more, and so here I am.

I would appreciate any help!

Thanks in advance,
Renen
renenel is offline   Reply With Quote
Old 01-05-09, 04:43 AM   #2
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: Compiz white screen

http://nvnews.net/vbulletin/showthread.php?t=46678
adamk75 is offline   Reply With Quote
Old 01-05-09, 05:09 AM   #3
renenel
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: Compiz white screen

Hi,

I read it before posting and searched for similar problems, actually I found some and will look at it when I get home. However, I posted it because none of the issues I found were similar to the problem I'm having.

Sorry, I forgot to attach the bug-report.log, I'll do so when I get home.

Thanks,
Renen
renenel is offline   Reply With Quote
Old 01-05-09, 11:23 AM   #4
renenel
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: Compiz white screen

Oh, well, no happy news

I tried some things that helped people in this here forum, but to no avail:

1. Tried adding LIBGL_ALWAYS_INDIRECT=1 but the file /usr/bin/compositing-wm-start doesn't exist on my system.

2. Tied adding the following to my "screen" section in the xorg.conf file:
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "False"

But it didn't change anything.

3. Tried removing xserver-xgl, but it isn't installed...

My log file is attached to the message.

Thanks in advance!
Renen
Attached Files
File Type: gz nvidia-bug-report.log.gz (33.8 KB, 66 views)
renenel is offline   Reply With Quote
Old 01-05-09, 01:00 PM   #5
renenel
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: Compiz white screen

I recently tried adding LIBGL_ALWAYS_INDIRECT=1 to /usr/bin/compiz-start, but it didn't change anything... please give me a hand!
renenel is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Bug Report] Xid error after resume with 307.02, and compiz stops working. John K. NVIDIA Linux 0 05-09-12 03:42 PM
Toshiba Sat 1950 screen setup beaulieu NVIDIA Linux 7 06-13-03 04:17 PM
Redhat 8.0 NVIDIA works - INSTRUCTIONS STEEL1 NVIDIA Linux 267 04-15-03 07:48 PM
TV-out - only white blue screen on TV zefme NVIDIA Linux 13 08-19-02 11:46 PM

All times are GMT -5. The time now is 09:15 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.