Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-08-09, 07:23 PM   #1
interzoneuk
Registered User
 
Join Date: Mar 2005
Posts: 81
Default Poor nvidia performance AMD64X2 4GB RAM - 64 IOMMU to blame ?

Hi.

athlon X2 4600
motherboard : gigabyte GA-M55S-S3
2 X 2GB ram
nvidia 8500 PCI-E
Distro - ubuntu/opensuse amd64

I have recently upgraded my desktop from 1GB ram to 4GB.

Previous i was getting Aperture beyond 4GB messages, I now get

In dmesg it shows:-

Quote:
Checking aperture...
No AGP bridge found
Node 0: aperture @ 20000000 size 32 MB
Aperture pointing to e820 RAM. Ignoring.
Your BIOS doesn't leave a aperture memory hole
Please enable the IOMMU option in the BIOS setup
This costs you 64 MB of RAM
Mapping aperture over 65536 KB of RAM @ 20000000
PCI: MCFG area at f0000000 reserved in E820
The memory used is not available - i.e i lose 64 MB.

I do not get this in 32bit linux using PAE - i can see all my memory.

After reading around forums I tried iommu=memaper=3 - what excatly does this do ? I noticed that Aperture was set to 256MB with this option - and I lost the 256MB..

What should I set my aperture to ? My gfx card is geforce 8500 256mb PCI-E

I also notice that if I reduce my memory to 2 or 3 GB I do not get that message.

Any sugestions ?
interzoneuk is offline   Reply With Quote
Old 01-09-09, 07:48 AM   #2
interzoneuk
Registered User
 
Join Date: Mar 2005
Posts: 81
Default Re: Poor nvidia performance AMD64X2 4GB RAM - 64 IOMMU to blame ?

I have also noticed that setting iommu=memaper=0 only uses 32MB - if this setting is not needed then it should be set to this ?

Is there a way to use all my ram.

Do anyone know what it should be set to.

When using less than 4GB i can see no message regarding Aperture.

Anyone know anything that might help

(slightly confused)
interzoneuk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM

All times are GMT -5. The time now is 06:16 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.