Go Back   nV News Forums > Linux Support Forums > NVIDIA Solaris

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-29-08, 05:29 PM   #1
betchou
Registered User
 
Join Date: Oct 2008
Location: Nice, France
Posts: 4
Unhappy BugReport for 1.77.82 and snv_101b - Failed to initialize the NVIDIA graphics device!

Hye all,

you will see in attachments two bug reports.

- The first one is when I don't try to correct symlinks which are still linking with mesa.
It is related to this bug: http://defect.opensolaris.org/bz/show_bug.cgi?id=363 which seems not to be corrected yet.

- The second report is when symlinks are "corrected". May be partially corrected... I updated the /var/run/opengl symlinks with the following script.

Code:
#!/usr/bin/env bash

find /usr/X11/include/NVIDIA/GL/ -name *.h -exec ln -sf {} /var/run/opengl/include \;

ln -sf /usr/X11/lib/NVIDIA/libGL.so.1 /var/run/opengl/lib/libGL.so.1
ln -sf /usr/X11/lib/NVIDIA/amd64/libGL.so.1 /var/run/opengl/lib/amd64/libGL.so.1

ln -sf /usr/X11/lib/modules/extensions/NVIDIA/libglx.so /var/run/opengl/server/libglx.so
ln -sf /usr/X11/lib/modules/extensions/NVIDIA/amd64/libglx.so /var/run/opengl/server/amd64/libglx.so
In the second case I'm going further, but it still ends with "Failed to initialize the NVIDIA graphics device!"

In those two cases I'm following the basic procedure ...
sh NVIDIA-Solaris-x86-177.82.sh
pfexec nvidia-xconfig
ctr+alt+backspace or pfexec svcadm restart gdm or pfexec init 6

I hope you will be able to help me.

Regards,
betchou
Attached Files
File Type: gz NVIDIA-Solaris-x86-177.82-BugReport.tar.gz (47.3 KB, 139 views)
betchou is offline   Reply With Quote
Old 12-30-08, 05:22 PM   #2
betchou
Registered User
 
Join Date: Oct 2008
Location: Nice, France
Posts: 4
Default Re: BugReport for 1.77.82 and snv_101b - Failed to initialize the NVIDIA graphics dev

As I see here symlinks should be corrected in build 103. There is a release for IPS in January with the build 105. This should be at least better ...
But I already think having corrected symlinks.
betchou is offline   Reply With Quote
Old 01-09-09, 02:59 AM   #3
betchou
Registered User
 
Join Date: Oct 2008
Location: Nice, France
Posts: 4
Default Re: BugReport for 1.77.82 and snv_101b - Failed to initialize the NVIDIA graphics dev

NVIDIA 9300GE Device PCI ID 0x06EA works with 1.80.22 !! Please add it to the Supported NVIDIA GPU for 1.80.22 webpage
betchou is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.