Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-12-09, 12:19 PM   #13
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 180.18 and 180.22 result in low-gfx-mode

I'm afraid all of your log files are still using /etc/X11/xorg.conf.failsafe and the VESA driver, even Xorg.0.log.old. That said, in your bug report I see this:
Quote:
Originally Posted by dmesg
[12648.679327] NVRM: API mismatch: the client has the version 180.22, but
[12648.679329] NVRM: this kernel module has the version 177.82. Please
[12648.679330] NVRM: make sure that this kernel module and all NVIDIA driver
[12648.679331] NVRM: components have the same version.
This is a common problem caused by not uninstalling the Ubuntu driver packages before using the .run installer. Please see Ubuntu's documentation about how to fix that problem.
AaronP is offline   Reply With Quote
Old 01-12-09, 12:51 PM   #14
Duran
Registered User
 
Join Date: Nov 2008
Posts: 28
Default Re: 180.18 and 180.22 result in low-gfx-mode

Quote:
Originally Posted by AaronP View Post
I'm afraid all of your log files are still using /etc/X11/xorg.conf.failsafe and the VESA driver, even Xorg.0.log.old. That said, in your bug report I see this:

This is a common problem caused by not uninstalling the Ubuntu driver packages before using the .run installer. Please see Ubuntu's documentation about how to fix that problem.
Okai, but then how come 180.16 works fine? (and the previous drivers).

About the logs, i deleted *.log in /var/logs... installed 180.22.. which got me into low-gfx mode. I then pressed ctrl+alt+backspace to restart X like you said so..then attached all the log files created in /var/logs.
I'm not sure how I can make the log files use the correct driver instead of VESA?
Duran is offline   Reply With Quote
Old 01-12-09, 01:26 PM   #15
Duran
Registered User
 
Join Date: Nov 2008
Posts: 28
Default Re: 180.18 and 180.22 result in low-gfx-mode

I just did a sudo apt-get remove --purge nvidia-glx* (and even nvidia*) to remove the repository left-overs. Also removed all nvidia kernel stuff.
Tried 180.22 once again but no difference at all...still low-gfx mode.

Also tried commenting out Type1..but all this does is leave that error out of the error report
Duran is offline   Reply With Quote
Old 01-13-09, 02:17 PM   #16
Duran
Registered User
 
Join Date: Nov 2008
Posts: 28
Default Re: 180.18 and 180.22 result in low-gfx-mode

bump
Duran is offline   Reply With Quote
Old 01-15-09, 02:16 PM   #17
KaiserClaudius
Registered User
 
Join Date: Sep 2006
Posts: 12
Default Re: 180.18 and 180.22 result in low-gfx-mode

I have the same problem, also with Ubuntu Intrepid 64-Bit. The latest of the 180.x drivers that works for me is 180.16, both with 180.18 and 180.22 X fails to start.

The attached nvidia-bug-report.sh was generated while 180.22 was installed, but (of course) without X running. If I can provide any additional informations, please let me know.

Kind regards,
Jan
Attached Files
File Type: log nvidia-bug-report.log (137.4 KB, 83 views)
File Type: log nvidia-installer.log (39.2 KB, 84 views)
File Type: log Xorg.0.log (7.2 KB, 95 views)
KaiserClaudius is offline   Reply With Quote
Old 01-15-09, 03:02 PM   #18
TylerMD
Registered User
 
Join Date: Jan 2009
Posts: 1
Lightbulb Re: 180.18 and 180.22 result in low-gfx-mode

Hi, I was having exactly the same problem but I've just managed to solve it. I was running 180.17 beta and I was unable to start X with 180.22. The trick is to completely uninstall the Ubuntu packages with the --purge option, but for that, I had to install them again first. Here is what I did.

* Switched to a terminal: Ctrl + Alt + F1
* Stopped X: sudo /etc/init.d/gdm stop
* Uninstalled 180.17: sudo ./NVIDIA-Linux-x86-180.17-pkg1.run --uninstall
* Installed Ubuntu packages: sudo aptitude install nvidia-glx-180
* Completely removed them: sudo apt-get remove nvidia-glx-180 nvidia-180-kernel-source nvidia-kernel-common nvidia-common nvidia-settings --purge
* Installed 180.22: sudo ./NVIDIA-Linux-x86-180.22-pkg1.run

And everything went flawlessly. I'm running Ubuntu 8.10 Intrepid Ibex 32b on a Dell XPS m1330. 2.6.27-9-generic. I do have DKMS installed. Hope this helps.
TylerMD is offline   Reply With Quote
Old 01-16-09, 03:19 AM   #19
KaiserClaudius
Registered User
 
Join Date: Sep 2006
Posts: 12
Default Re: 180.18 and 180.22 result in low-gfx-mode

@TylerMD
The following nvidia related packages were still installed on my system:

nvidia-173-modaliases
nvidia-177-kernel-source
nvidia-177-modaliases
nvidia-71-modaliases
nvidia-96-modaliases
nvidia-common

But purging them doesn't help for me, the installation of the 180.22 driver (of course the one from Nvidia's website) still results in a not-starting X

Kind regards,
Jan
KaiserClaudius is offline   Reply With Quote
Old 01-18-09, 06:06 PM   #20
Duran
Registered User
 
Join Date: Nov 2008
Posts: 28
Default Re: 180.18 and 180.22 result in low-gfx-mode

bump
Duran is offline   Reply With Quote

Old 01-19-09, 11:47 AM   #21
noxidog
Registered User
 
Join Date: Jan 2009
Posts: 1
Default Re: 180.18 and 180.22 result in low-gfx-mode

I have just successfully concluded a 3 day struggle with this. This is what I did:

#CTRL+ALT+F4 - to switch to another console
#stop the xserver (gdm)
sudo /etc/init.d/gdm stop

#list + remove the old stuff related to nvidia
sudo dpkg -l | grep nvidia
#`apt-get remove` on whatever comes out of the line above.

#install the packages which this depends on.
apt-get install nvidia-glx-180-dev nvidia-180-modaliases nvidia-180-kernel-source nvidia-glx-180

#remove all the kernel objects currently installed.
export k=`uname -r`
sudo rm -f `find /lib/modules/$k -iname nvidia.ko`

#chmod 777 on the file belwo if necessary.
sudo ./NVIDIA-Linux-x86-180.22-pkg1.run

#restart gdm.
sudo /etc/init.d/gdm start

Hope this helps.

Tervel
noxidog is offline   Reply With Quote
Old 01-19-09, 07:03 PM   #22
hazridi
Registered User
 
Join Date: Jan 2009
Posts: 1
Default Re: 180.18 and 180.22 result in low-gfx-mode

This is caused by the dell kernel module system's driver not being removed.

To fix:

sudo rm /lib/module/`uname -r`/updates/dkms/nvidia.ko
sudo depmod -a

restart x and this should clear up the issue.
hazridi is offline   Reply With Quote
Old 01-19-09, 09:20 PM   #23
Dr. Tyrell
Registered User
 
Dr. Tyrell's Avatar
 
Join Date: Aug 2004
Posts: 100
Default Re: 180.18 and 180.22 result in low-gfx-mode

Also, watch out for those higher versions of Xorg and NVidia's ABI incompatibility.
I think it's still not fixed.
So, in /etc/gdm/defaults (or something like that) add -ignoreABI to the server line and restart your X session.

The Doctor
__________________
P7811-FX | Nvidia 9800M GTS 512MB DDR3 | 17" 1920x1200 | Centrino2 P8400 | 4GB DDR3 | 2x320Gb 7200RPM RAID 0 | DVD+-/DL
Dr. Tyrell is offline   Reply With Quote
Old 02-02-09, 05:42 AM   #24
zyrorl
Registered User
 
Join Date: Feb 2009
Posts: 1
Default Re: 180.18 and 180.22 result in low-gfx-mode

Quote:
Originally Posted by noxidog View Post
I have just successfully concluded a 3 day struggle with this. This is what I did:

#CTRL+ALT+F4 - to switch to another console
#stop the xserver (gdm)
sudo /etc/init.d/gdm stop

#list + remove the old stuff related to nvidia
sudo dpkg -l | grep nvidia
#`apt-get remove` on whatever comes out of the line above.

#install the packages which this depends on.
apt-get install nvidia-glx-180-dev nvidia-180-modaliases nvidia-180-kernel-source nvidia-glx-180

#remove all the kernel objects currently installed.
export k=`uname -r`
sudo rm -f `find /lib/modules/$k -iname nvidia.ko`

#chmod 777 on the file belwo if necessary.
sudo ./NVIDIA-Linux-x86-180.22-pkg1.run

#restart gdm.
sudo /etc/init.d/gdm start

Hope this helps.

Tervel
I registered just to thank you for your help!

I tried this after looking around for all kinds of guides and this was the only one that worked!

Once again thank you kind sir!
zyrorl is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:05 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.