Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-12-09, 02:38 PM   #1
jackson312
Registered User
 
Join Date: Jul 2006
Posts: 8
Default KDM problem after upgrading to 180.22

After upgrading to 180.22, KDM fails to start. The build of the driver was successful as is X starting. In runlevel 3, I can start x into Windowmaker. Below is the KDM.log with an entry before the upgrade and after, note the "dlsym strcpy errornull)" message which was not present before. I have attached the Xorg.0.log and the nvidia-installer.log.

Does anyone know how to fix this and what the installer is doing?

I am running Slackware 12.2

Thanks,

Jackson

************************************************** ******************************
Note that your system uses syslog. All of kdm's internally generated messages
(i.e., not from libraries and external programs/scripts it uses) go to the
daemon.* syslog facility; check your syslog configuration to find out to which
file(s) it is logged.
************************************************** ******************************



X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Slackware 12.1 Slackware Linux Project
Current Operating System: Linux INDYZONE 2.6.27.10-smp #1 SMP Thu Dec 18 18:37:06 PST 2008 i686
Build Date: 30 June 2008 11:35:29PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 12 10:29:46 2009
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module "ramdac" already built-in
QImage::convertDepth: Image is a null image
QImage::smoothScale: Image is a null image
FreeFontPath: FPE "/usr/share/fonts/misc" refcount is 2, should be 1; fixing.
QImage::convertDepth: Image is a null image
QImage::smoothScale: Image is a null image
FreeFontPath: FPE "/usr/share/fonts/misc" refcount is 2, should be 1; fixing.


X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Slackware 12.1 Slackware Linux Project
Current Operating System: Linux INDYZONE 2.6.28-smp #0 SMP Mon Jan 5 16:34:14 PST 2009 i686
Build Date: 30 June 2008 11:35:29PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jan 12 11:28:48 2009
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module "ramdac" already built-in
dlsym strcpy errornull)
FreeFontPath: FPE "/usr/share/fonts/misc" refcount is 2, should be 1; fixing.
Attached Files
File Type: log Xorg.0.log (25.3 KB, 99 views)
File Type: log nvidia-installer.log (50.6 KB, 81 views)
jackson312 is offline   Reply With Quote
Old 01-21-09, 12:59 PM   #2
walmartshopper
Registered User
 
Join Date: Dec 2008
Posts: 23
Default Re: KDM problem after upgrading to 180.22

I have the same exact problem. I have another thread going over at linuxquestions.org.

From what I can tell so far, people using the default kernel are not having problems. There's something about the custom kernel config that seems to be causing it, but I have no idea which option it could be.
walmartshopper is offline   Reply With Quote
Old 01-21-09, 03:45 PM   #3
walmartshopper
Registered User
 
Join Date: Dec 2008
Posts: 23
Default Re: KDM problem after upgrading to 180.22

Well, maybe not. I tried on the stock kernel and got the same results.
walmartshopper is offline   Reply With Quote
Old 01-21-09, 03:57 PM   #4
xorbe
Unbuffered User
 
Join Date: Jun 2005
Posts: 388
Default Re: KDM problem after upgrading to 180.22

Yeah, on my 64-bit machine, sometimes KDM fails to start with 180.22 -- also sometimes it starts, but then the 3D doesn't really work, and there are graphical oddities. And occasionally, it works fine. I reverted to 180.18 again.

edit: I updated mdv cooker rpms, and added nopat, and 180.22 works now. kdm was sucking down all ram and grinding the hdd and crashing, but only with 180.22 on 2.6.28, weird.
xorbe is offline   Reply With Quote
Old 01-21-09, 04:14 PM   #5
Sean_W
Registered User
 
Sean_W's Avatar
 
Join Date: Jun 2007
Posts: 2,423
Default Re: KDM problem after upgrading to 180.22

Pretty sure thats the X86 PAT Support option enabled in the kernel, KDM want load sometimes, when the option is off it's fine.
Sean_W is offline   Reply With Quote
Old 01-21-09, 08:15 PM   #6
jackson312
Registered User
 
Join Date: Jul 2006
Posts: 8
Cool Re: KDM problem after upgrading to 180.22

I don't have X86 PAT support turned on in my kernel. I do have MTTR and MTTR cleanup support enabled which is a default setting.
jackson312 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 10:17 AM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 04:14 PM
Ti4200 and Linux Install Problem ultrajava NVIDIA Linux 5 09-28-02 09:13 AM
funny problem with 2960 and GF4 konsti NVIDIA Linux 3 09-03-02 08:08 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 11:58 AM

All times are GMT -5. The time now is 12:05 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.