Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-12-09, 09:31 PM   #1
DiscipleDOC
 
DiscipleDOC's Avatar
 
Join Date: Dec 2002
Location: Alabama, Planet Earth
Posts: 5,993
Default Low resolution on my M1730 with 180.22

I have a M1730 and I installed Kubuntu 8.10 on it. I have NVIDIA 180.22. The display is using a GeForce 8700M GT. I am not getting 1920x1200 out of my display, and the resolution sucks. My xorg.conf is attached.

Does anyone see anything that should be changed?

Thanks for the help.

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "DELL XPS M1730"
    ModelName      "LCD Panel 1920x1200"
    HorizSync       31.5 - 90.0
    VertRefresh     59.9 - 60.1
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "19201200_60"
    EndSubSection
EndSection

Last edited by DiscipleDOC; 01-18-11 at 10:49 PM.
DiscipleDOC is offline   Reply With Quote
Old 01-13-09, 06:03 AM   #2
wiresquire
Registered User
 
Join Date: Mar 2008
Posts: 81
Default Re: Low resolution on my M1730 with 180.22

I have the same machine, and the xorg.conf that the drivers generated when installed was a lot different. You may want to run the nvidia-settings to generate the xorg.conf again.

Below is mine (generated by 177.82) just in case:
Code:
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Generic Keyboard" "CoreKeyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "Synaptics Touchpad"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "kbd"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us"
EndSection

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "mouse"
    Option         "CorePointer"
EndSection

Section "InputDevice"
    Identifier     "Synaptics Touchpad"
    Driver         "synaptics"
    Option         "SendCoreEvents" "true"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "HorizEdgeScroll" "0"
EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
    ModeLine       "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
    ModeLine       "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
    ModeLine       "1280x768@60" 80.1 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
    ModeLine       "1280x720@60" 74.5 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
    ModeLine       "1280x800@60" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    ModeLine       "1440x900@60" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
    ModeLine       "1600x1024@60" 136.4 1600 1704 1872 2144 1024 1025 1028 1060 -hsync +vsync
    ModeLine       "1680x1050@60" 147.1 1680 1784 1968 2256 1050 1051 1054 1087 -hsync +vsync
    ModeLine       "1920x1200@60" 193.2 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
    Option         "DPMS" "true"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Seiko"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver         "nv"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8700M GT"
    BusID          "PCI:3:0:0"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1920x1200@60" "1680x1050@60" "1600x1024@60" "1440x900@60" "1280x800@60" "1280x720@60" "1280x768@60" "800x600@60" "800x600@56"
    EndSubSection
EndSection

Section "Screen"

#added bunch of stuff here:
#    Option         "NvAGP" "0"
#    Option         "CoolBits" "2"
#    Option         "BackingStore" "True"
#    Option         "RenderAccel" "True"
#    Option         "NoFlip" "False"
#    Option         "NoRenderExtension" "False"
#    Option         "MultisampleCompatibility" "True"
#    Option         "OnDemandVBlankInterrupts" "True"
#    Option         "AddARGBGLXVisuals" "True"
#    Option         "RandRRotation" "True"
#    Option         "UseCompositeWrapper" "True"
#    Option         "SLi" "AA"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1920x1200 +0+0; 1680x1050@60 +0+0; 1600x1024@60 +0+0; 1440x900@60 +0+0; 1280x800@60 +0+0; 1280x720@60 +0+0; 1280x768@60 +0+0; 800x600@60 +0+0"
    Option         "OnDemandVBlankInterrupts" "True"
#    Option         "RandRRotation" "True" #incompatible with SLI
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
The 1920x1200 looks good

HTH
ws
wiresquire is offline   Reply With Quote
Old 01-13-09, 10:03 AM   #3
DiscipleDOC
 
DiscipleDOC's Avatar
 
Join Date: Dec 2002
Location: Alabama, Planet Earth
Posts: 5,993
Default Re: Low resolution on my M1730 with 180.22

Wiresquire, I will give your config a try when I get home.

Thanks.
DiscipleDOC is offline   Reply With Quote
Old 01-13-09, 03:28 PM   #4
wiresquire
Registered User
 
Join Date: Mar 2008
Posts: 81
Default Re: Low resolution on my M1730 with 180.22

BTW - you should check that the Bus id is the same for your machine.
Run lspci from the terminal and make sure that where it says 03:00.0 in my xorg, that you replace it with whatever lspci says for your nVidia card.

Good luck
ws
wiresquire is offline   Reply With Quote
Old 05-16-09, 01:06 PM   #5
Kruschev
Registered User
 
Join Date: May 2009
Posts: 6
Default Re: Low resolution on my M1730 with 180.22

I am also having this problem. With the 177.xxx driver all seems to be fine, but when I switch to the 180.xxx using EnvyNG, the highest resolution available is 1400x1050. I'm using Ubuntu 9.04. It'd be great to find the solution, please help me!!
Kruschev is offline   Reply With Quote
Old 05-18-09, 11:09 AM   #6
Kruschev
Registered User
 
Join Date: May 2009
Posts: 6
Default Re: Low resolution on my M1730 with 180.22

anyone? note that I have tried adding more resolutions to the xorg.conf file, but it makes no difference. what else can one do to tell X to use more resolutions? note that I am getting accelerated graphics, the glxgears framerate is good, but the resolution is awful.
Kruschev is offline   Reply With Quote
Old 05-18-09, 11:39 AM   #7
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Low resolution on my M1730 with 180.22

Please see the forum sticky posts about how to report a problem, especially the one about how to generate a verbose bug report with a mode validation log.
AaronP is offline   Reply With Quote
Old 05-19-09, 11:09 AM   #8
Kruschev
Registered User
 
Join Date: May 2009
Posts: 6
Default Re: Low resolution on my M1730 with 180.22

Okay I hope this is correct, here's what I did:

1) enable driver 180.44-0ubuntu1 with envyng 2.0
2) reboot
3) max res in nvidia x server settings is 1400x1050, although on reboot it defaulted to 1024x768.
4) run "sudo nvidia-bug-report.sh"
5) revert to driver 173.14.16-0ubuntu1 using envyng
6) reboot, the resolution is back to 1920x1200
7) make a new bug report. both reports are in the attached zip file.

Thanks in advance, it'd be great to sort it. My main motivation is that unreal tournament 2004 crashes occasionally, maybe this helps? also, the compiz is a bit jerky.
Attached Files
File Type: gz nvidia-bug-report.tar.gz (60.5 KB, 98 views)
Kruschev is offline   Reply With Quote

Old 05-19-09, 01:09 PM   #9
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Low resolution on my M1730 with 180.22

Your bug report is missing the verbose mode validation log. Did you follow the steps in the sticky posts regarding setting the log verbosity level?
AaronP is offline   Reply With Quote
Old 05-20-09, 03:23 AM   #10
Kruschev
Registered User
 
Join Date: May 2009
Posts: 6
Default Re: Low resolution on my M1730 with 180.22

I (and google) couldn't find it. I even looked through the bug report shell script and couldn't find any mention of a verbosity switch, either. What's the switch, or the relevant post, please?
Kruschev is offline   Reply With Quote
Old 05-20-09, 09:56 AM   #11
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Low resolution on my M1730 with 180.22

http://www.nvnews.net/vbulletin/showthread.php?t=46678

Quote:
Originally Posted by If you have a problem, PLEASE read this first
To make sure this log file includes as much relevant information as possible, please start the X server with `startx -- -logverbose 6` and run `nvidia-bug-report.sh` after the problem has occurred.
You can also run `nvidia-xconfig --mode-debug` to enable verbose mode logging.
AaronP is offline   Reply With Quote
Old 05-21-09, 03:39 PM   #12
Kruschev
Registered User
 
Join Date: May 2009
Posts: 6
Default Re: Low resolution on my M1730 with 180.22

sorry i should have worked that out. i followed the same steps as in my previous post, but with the verbose X mode. the logs are attached. thanks!
Attached Files
File Type: gz verbose.tar.gz (80.7 KB, 84 views)
Kruschev is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 03:22 PM
Opinions on 1280x1024 resolution skipparoo NVIDIA GeForce 7, 8, And 9 Series 103 06-22-12 11:38 PM
Unable to get other display resolution jcdole NVIDIA Linux 0 05-11-12 04:25 AM
What resolution do you all run Unreal2003 retail version at with all details on max.? imtim83 Gaming Central 9 10-04-02 10:17 AM
30.82 and 40.41 resolution + monitor OSD. Max3D NVIDIA Windows Graphics Drivers 2 09-05-02 02:15 AM

All times are GMT -5. The time now is 11:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.