Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-06-09, 04:12 PM   #1
avoncampe
Registered User
 
Join Date: Dec 2006
Posts: 12
Default glx module and XRes extension

I've been having some general GUI instabilities running Gnome under CentOS 5.2 and I have never been able to track down the root cause. Recently, I found out about xrestop and decided to try it. Unfortunately, on most systems, xrestop was failing with the following error message:

Code:
xrestop: XResQueryExtension failed. Display Missing XRes extension ?
On the systems were xrestop was failing, the following lines were in the xorg.conf file:

Code:
Section "Module"
   Load           "glx"
EndSection
After commenting out the loading of the glx module and restarting the X server, I was able to run xrestop. Then I decided to upgrade to the latest NVIDIA driver, and when I installed the driver, the xorg.conf file was modified to load the glx module again. I also noticed the following difference in the number of extensions loaded in the output of xdpyinfo with (15) and without (32) the glx module loaded:

Code:
number of extensions:    15       |    number of extensions:    32
                                  >        BIG-REQUESTS
    Composite                              Composite
    DAMAGE                                 DAMAGE
                                  >        DOUBLE-BUFFER
                                  >        DPMS
                                  >        Extended-Visual-Information
    GLX                                    GLX
                                  >        MIT-SCREEN-SAVER
    MIT-SHM                                MIT-SHM
                                  >        MIT-SUNDRY-NONSTANDARD
    NV-CONTROL                             NV-CONTROL
    NV-GLX                                 NV-GLX
    RANDR                                  RANDR
                                  >        RECORD
    RENDER                                 RENDER
    SECURITY                               SECURITY
                                  >        SHAPE
                                  >        SYNC
                                  >        TOG-CUP
                                  >        X-Resource
    XC-APPGROUP                            XC-APPGROUP
                                  >        XC-MISC
    XFIXES                                 XFIXES
    XFree86-Bigfont                        XFree86-Bigfont
                                  >        XFree86-DGA
                                  >        XFree86-Misc
                                  >        XFree86-VidModeExtension
    XInputExtension                        XInputExtension
    XKEYBOARD                              XKEYBOARD
    XTEST                                  XTEST
                                  >        XVideo
                                  >        XVideo-MotionCompensation
So my questions are:
  1. Why is the NVIDIA installer adding the Load "glx" to the xorg.conf file and is there a way to tell the installer not to do so?
  2. What is this glx module?
  3. Why does loading the glx module cause xrestop to fail (i.e., why is the X-Resource extension not loaded)?
  4. Why are there less extensions available when the glx module is loaded in the xorg.conf file (15 vs. 32)?
  5. Is the GLX extension related to the glx module? If so, why is it loaded in both cases?

I don't usually monitor these forums, but one of the recent threads mentioned disabling the glx module to avoid a memory leak. I'm hoping that disabling it will also fix my various instabilities.

Thanks,
Alfred
avoncampe is offline   Reply With Quote
Old 01-07-09, 03:29 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: glx module and XRes extension

Without GLX you don't have any 3d support.
Thunderbird is offline   Reply With Quote
Old 01-07-09, 09:12 AM   #3
avoncampe
Registered User
 
Join Date: Dec 2006
Posts: 12
Default Re: glx module and XRes extension

Quote:
Originally Posted by Thunderbird View Post
Without GLX you don't have any 3d support.
I think I can live with that. These are desktops used by SW developers and we are not using any 3D applications. However, I still want to know why loading this module causes 17 X Server extensions not to load (therefore making xrestop fail). And more importantly, if loading the glx module is actually causing our instabilities (we won't know for another week or so while we test with the new configuration), how can I debug this (without xrestop) and provide feedback so that the underlying bug can be addressed?

Thanks,
Alfred
avoncampe is offline   Reply With Quote
Old 01-07-09, 09:24 AM   #4
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: glx module and XRes extension

You need to go about the official way of reporting issues as noted in the sticky posts. Attach a bug report. If you don't know what a bug report is, please read the sticky posts. Sorry if this sounds offensive, but it's what every new poster has to be told to do.
mooninite is offline   Reply With Quote
Old 01-07-09, 10:07 AM   #5
avoncampe
Registered User
 
Join Date: Dec 2006
Posts: 12
Default Re: glx module and XRes extension

Quote:
Originally Posted by mooninite View Post
You need to go about the official way of reporting issues as noted in the sticky posts. Attach a bug report. If you don't know what a bug report is, please read the sticky posts. Sorry if this sounds offensive, but it's what every new poster has to be told to do.
Sorry about that. I should have read all the sticky posts. Attached are two bug reports, one with the default xorg.conf file and the other with the 'Load "glx"' line commented out. As can be seen from the difference in the bug reports, the X-Resource extension (plus a bunch of others) only get loaded when the 'Load "glx"' line is commented out. However, it appears that the glx module is loaded in both cases.

Alfred
Attached Files
File Type: log nvidia-bug-report-glx.log (118.9 KB, 93 views)
File Type: log nvidia-bug-report-noglx.log (122.1 KB, 87 views)
avoncampe is offline   Reply With Quote
Old 01-13-09, 11:05 PM   #6
avoncampe
Registered User
 
Join Date: Dec 2006
Posts: 12
Default Re: glx module and XRes extension

I'm still trying to figure out what's causing this issue. The difference in the two bug reports really shows the problem. It doesn't make any sense to me why these extensions don't get loaded, so I would appreciate any insights.

Thanks,
Alfred
avoncampe is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:19 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.