Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-10-03, 05:29 AM   #1
vince
Registered User
 
Join Date: Apr 2003
Posts: 3
Default Hard lockups under SMP

Apparently I'm not alone in this.

My Asus V8420 DT ( = GeForce4 Ti 4200) will hard lock my system
(not just X, the entire system) when I attempt to start X while running under an SMP kernel and have my Iiyama 4831D connected to the DVI port. It will work when the monitor is connected to VGA, and also _with_ DVI when running a UP kernel.

The system runs Redhat 8.0 with the latest stock Redhat 8.0 SMP kernel: 2.4.18-27.8.0smp.

$ cat /proc/driver/nvidia/cards/0
Model: GeForce4 Ti 4200
IRQ: 10
Video BIOS: 04.25.00.30.00
Card Type: AGP

$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4349 Thu Mar 27 19:00:02 PST 2003

(the above two were collected while running X under a UP kernel).

The motherboard is a MSI 694D Pro; with dual Pentium III (coppermine) 800Mhz processors.

I've also noticed that the card appears to run at 2xAGP, where the motherboard

Attached are my XF86Config and XFree86.0.log of the last attempt I made.
vince is offline   Reply With Quote
Old 04-10-03, 05:31 AM   #2
vince
Registered User
 
Join Date: Apr 2003
Posts: 3
Default

err. I'm a little new at this forums thing. Apparently, my files didn't get attached....
Attached Files
File Type: log xfree86.0.log (24.6 KB, 103 views)
vince is offline   Reply With Quote
Old 04-10-03, 05:32 AM   #3
vince
Registered User
 
Join Date: Apr 2003
Posts: 3
Default

And the XF86Config.
Attached Files
File Type: txt xf86config.txt (4.0 KB, 103 views)
vince is offline   Reply With Quote
Old 04-10-03, 11:00 AM   #4
eric42
Registered User
 
Join Date: Jan 2003
Posts: 13
Default

I can't help but I can confirm the problem.

I've had very bad lockup problem with both 4XXX drivers. No log files record the lockup, but it happens very often under SMP kernel (usually every day, X crashes once an hour).

I'm using
Dual 2.2 Xeons
Dell Precision 530
Quadro 4 750
2.4.18-3smp (up fixes the problem)
Using 3123 drivers fixes the problem. (Uptime of two weeks without a crash/lockup, either X or system, no 3D though.....)

Whatever the NVidia guys did with the 4XXX drivers, they broke the SMP compatibility.

I've tried diabling AGP and all the power managment stuff, but the system won't stabilize under 4XXX drivers.

NVidia? Are you listening? People have been reporting SMP lockups since 4191 was released........ Everything works fine until the system locks up.

Eric
eric42 is offline   Reply With Quote
Old 04-10-03, 11:54 AM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

OK... let me play dumb here for a minute.

Why don't you have 3D with 3123?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 04-10-03, 02:37 PM   #6
kahuna0k
Registered User
 
Join Date: Mar 2003
Posts: 26
Default

Running 4349 fixes the hard lockups in SMP for me, now runnning with a problem (other than TV out overscan not working, see the overscan thread). Uptime of 7 days (last reset to check TVout in Windows).
kahuna0k is offline   Reply With Quote
Old 04-10-03, 02:51 PM   #7
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

This is a known problem - SMP+DVI hangs. See the errata on ftp://download.nvidia.com/XFree86/Linux-x86/1.0-4349

Current workarounds are to use UP+DVI, or SMP+Analog.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-10-03, 02:54 PM   #8
eric42
Registered User
 
Join Date: Jan 2003
Posts: 13
Default

Under 4191 I had a working OpenGL install. (TuxRacer ran beautifully, GLX gears of 6000 fps.) I installed 3123 and glx gears won't even run. (Missing/bad glx, but it's still in the XF86Config.

kahuna: Did you have the lockups under 4191? What motherboard/system/graphics card do you have?

Eric

PS I'm not using DVI or TV out, just plain old vanilla VGA. (Cathode Ray Tube and all!)
eric42 is offline   Reply With Quote

Old 04-10-03, 03:23 PM   #9
kahuna0k
Registered User
 
Join Date: Mar 2003
Posts: 26
Default

I have the lockups ONLY under 4191, under 3123 it works perfectly, and now under 4349 it also works perfectly. 4191 also gave corrupted 2D after some use. I have a Tyan Tiger MP S2460 and a Abit Siluro GeForce4 Ti 4400. I can use both CRT and TV, but TV overscan doesn't work (any clue Andy?)
kahuna0k is offline   Reply With Quote
Old 04-10-03, 03:26 PM   #10
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

From the 1.0-4349 errata:

o Overscan is currently only available on GeForce4 or newer GPUs
with either NVIDIA or Conexant TV encoders.

You can find the errata at ftp://download.nvidia.com/XFree86/Li...a-1.0-4349.txt

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 04-11-03, 09:39 AM   #11
donuts
Registered User
 
Join Date: Apr 2003
Posts: 8
Exclamation Re: Overscan (Andy)

Andy,

Please see the "overscan" thread, where it becomes clear that overscan does not work for _anyone_, regardless of what type of GPU/TV encoder they have. For example I have GeForce4 MX440 with the NVidia (NV17) TV Encoder, and the "TVOverScan" option does nothing in any resolution. I have written about it to NVidia support, but ofcourse got no reply.
donuts is offline   Reply With Quote
Old 04-11-03, 02:06 PM   #12
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

Quote:
I have written about it to NVidia support, but ofcourse got no reply.
When did you write?

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lockups with 302.07 x86_64 8800GT marcnarc NVIDIA Linux 6 05-07-12 09:24 AM
Hard lockups - AGP not guilty milo NVIDIA Linux 11 11-12-02 09:20 AM
GL lockups with ti4200, i845E and 2.4.20-pre7-ac3 baffle NVIDIA Linux 3 10-06-02 07:39 PM
Reproducable Hard Lockup - RH 8.0 & 3123 brand NVIDIA Linux 6 10-05-02 03:48 PM
Gnome2 lockups due to bug in X driver hobbes NVIDIA Linux 11 07-29-02 04:38 PM

All times are GMT -5. The time now is 07:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.