Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-01-03, 06:36 AM   #13
i_of_k5
Registered User
 
Join Date: Jun 2003
Posts: 4
Default

Hi guys. Same problem here. Spent last night trying to get around it, in vain :(

Could it be a BIOS incompatibility? I've heard GF3s from certain vendors have non-standard BIOS that nvidia drivers have problems with. But I have GF4 (ti 4200, from chaintech).

Did anyone have success with this hardware and any version of nvidia drivers? I'm using gentoo by the way.
i_of_k5 is offline   Reply With Quote
Old 06-01-03, 06:44 PM   #14
aliali
Registered User
 
aliali's Avatar
 
Join Date: May 2003
Location: Tasmania Australia
Posts: 11
Default

Some more things to try. Try loading only agpgart. If no go try nvagp. See the Nvidia readme for how to do it. Also make sure you have the kernel source installed and ( if you use multiple kernels) that /usr/src/linux points to the source of the kernel that you are using, or use the sysinclude option,
"make install SYSINCLUDE=/path/to/kernel/headers".
Have a look in /lib/modules/kernel version/kernel/drivers/video there should be a file called nvidia.0. If you have NVdriver that is the old Linux nvidia driver. Also I used to have an entry in /etc/modules.conf
"alias char-major-195 nvidia". This has changed with Mandrake 9.1 probably because of devfs to
"alias /dev/nvidia* nvidia". Note the star after /dev/nvidia this is needed.
Try booting to a console and as root doing a "lsmod" there should be an entry
nvidia. if its not there the nvidia module is not being loaded so try the /etc/modules.conf entry.
HJope this helps as I am starting to run out of ideas.
aliali is offline   Reply With Quote
Old 06-01-03, 07:25 PM   #15
i_of_k5
Registered User
 
Join Date: Jun 2003
Posts: 4
Default Problem solved for me.

Installed the latest version of the drivers, and DVI works! Crisp Clean Characters! Stupid me...
i_of_k5 is offline   Reply With Quote
Old 06-01-03, 07:42 PM   #16
aliali
Registered User
 
aliali's Avatar
 
Join Date: May 2003
Location: Tasmania Australia
Posts: 11
Default

Did you use the new binary driver or get the source one.
aliali is offline   Reply With Quote
Old 06-02-03, 02:00 AM   #17
moali
Registered User
 
Join Date: Oct 2002
Location: Austria
Posts: 31
Default

There is no source available. They're _all_ precompiled binaries. (closed source)
The only thing that is compiled when you use .tgz or the nvidia-installer(?) is the interface for the kernel-module.

The only difference between the various variants is the installation-procedure.

moali

Last edited by moali; 06-02-03 at 02:08 AM.
moali is offline   Reply With Quote
Old 06-02-03, 04:20 AM   #18
Emphroon
Registered User
 
Join Date: May 2003
Posts: 13
Default

Hi DB7654321,

This is a known issue with Epox 8RDA+. See my postings at

http://www.nvnews.net/vbulletin/show...threadid=11516

and

http://www.nvnews.net/vbulletin/show...threadid=11145

It seems that the new beta BIOS for Epox 8RDA+ solves the issue. I did not test this myself. See thread

http://www.nvnews.net/vbulletin/show...threadid=11558

Regards

Peter.
Emphroon is offline   Reply With Quote
Old 06-02-03, 03:46 PM   #19
DB7654321
Registered User
 
Join Date: May 2003
Posts: 6
Default

Emphroon: That sounds promising. I'll wait awhile to see if a new Epox BIOS is officially released. Hopefully 3D accell will be functioning in Linux soon.
DB7654321 is offline   Reply With Quote
Old 06-02-03, 03:56 PM   #20
Emphroon
Registered User
 
Join Date: May 2003
Posts: 13
Default

Well, you can already try to disable the IRQ's 10, 11 and 12 in your BIOS. You'll have your 3D acceleration then, but it is a workaround. All your devices will be put to IRQ5. I am using this setting for a month now, without any problem. The Linux kernel is a well-designed piece of software, very well capable of IRQ sharing.

P.
Emphroon is offline   Reply With Quote

Old 06-02-03, 07:57 PM   #21
DB7654321
Registered User
 
Join Date: May 2003
Posts: 6
Default

Quote:
Originally posted by Emphroon
Well, you can already try to disable the IRQ's 10, 11 and 12 in your BIOS. You'll have your 3D acceleration then, but it is a workaround. All your devices will be put to IRQ5. I am using this setting for a month now, without any problem. The Linux kernel is a well-designed piece of software, very well capable of IRQ sharing.

P.
This fixed it for me...To a degree. X started and things functioned correctly, however, I didn't get the speed boost I was expecting. glxgears only showed 3000FPS, which, IIRC, isn't that great. After a few minutes, the system completely locked. Oh well. It seems as though success with the Nvidia drivers is highly hardware dependent and mine isn't cooperating. I'll continue dualbooting Win2K to do my gaming, I guess. Thanks for all the help!
DB7654321 is offline   Reply With Quote
Old 06-03-03, 06:51 AM   #22
Psychobudgie
Registered User
 
Join Date: May 2003
Posts: 21
Default

In another thread BGMilne suggested the following

Boot with noapic and acpi=off, ie at the lilo screen, hit ESC, and type:

linux noapic acpi=off

You can also open drakboot and set these which will make it the default

I had been suffering from the black screen lock up for 2 weeks, this fixed it and my system is now back to fully working again.

System is Jetway V400DB (KT400), GF4 MX440 64mb, 512mb DDR 2700, Athlon 2000+XP

Regards

Psychobudgie
Psychobudgie is offline   Reply With Quote
Old 06-03-03, 10:27 AM   #23
Campos
Registered User
 
Join Date: May 2003
Posts: 5
Default

Hey Psychobudgie

i'll build a statue in your honour!!!

After 6 months of rage, tears and countless hours throw away, i've simply
follow your little tip and...
oh joy!!!!!!!!
NO MORE BLACK SCREENS
AH AH AH AH NO MORE BLACK SCREENS

Thank you!!
António
Campos is offline   Reply With Quote
Old 06-03-03, 11:51 AM   #24
TRON21Net
Registered User
 
Join Date: Mar 2003
Location: Nashville, TN, USA
Posts: 26
Default

Guys I have to say this business turning off APCI has saved a lot of people from exploiding! This is the best advanced anyone could ever have, I'd say APCI should be disabled always. It even messed up my Windows OSs when having it on, but after disabling it and reinstall my devices all my problems went away.
__________________
--TRON
TRON21Net is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
NVIDIA 2960 Drivers & RH 7.3 W/2.4.18-5 XASCompuGuy NVIDIA Linux 6 08-02-02 11:53 AM

All times are GMT -5. The time now is 02:29 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.