Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-21-09, 12:14 PM   #1
oldguy
Registered User
 
Join Date: Dec 2007
Posts: 39
Question customEDID ?

I'm trying to use a customEDID to drive my Samsung HDTV through a DVI to HDMI converter box and I have a few questions about using customEDID.

I've seen examples with customEDID in both DEVICE and SCREEN sections. Which is correct?

I've not been able to get my Samsung customEDID to be invoked through the converter box. The driver seems to be scanning the converter box and seeing an MFT device and ignoring my Samsung customEDID. Does the driver perhaps see a different device code and ignore the customEDID as non-matching? If so, is there a way to override it, or do I need to merge the device header MFT EDID with the data content of the Samsung EDID?

Thanks!
oldguy is offline   Reply With Quote
Old 01-21-09, 12:53 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: customEDID ?

It doesn't matter. Options from the device and screen sections are combined when the config file is parsed.

As for CustomEDID, check Xorg.0.log to see which display device your convert box shows up as. You may need to specify it in the CustomEDID option. E.g. if it shows up as DFP-1, add
Code:
Option "CustomEDID" "DFP-1:/path/to/some/edid.file"
AaronP is offline   Reply With Quote
Old 01-21-09, 06:22 PM   #3
oldguy
Registered User
 
Join Date: Dec 2007
Posts: 39
Default Re: customEDID ?

Quote:
Originally Posted by AaronP View Post
As for CustomEDID, check Xorg.0.log to see which display device your convert box shows up as. You may need to specify it in the CustomEDID option. E.g. if it shows up as DFP-1, add
Code:
Option "CustomEDID" "DFP-1:/path/to/some/edid.file"
Yeah I've done that, but it still seems to ignore my custom file. Here's an excerpt from Xorg.0.log. DFP-0 is supposed to use my customEDID, but it doesn't.

?????

Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 6600 GT at PCI:1:0:0:
(--) NVIDIA(0): NEC FE950+ (CRT-0)
(--) NVIDIA(0): MST (DFP-0)
(--) NVIDIA(0): NEC FE950+ (CRT-0): 400.0 MHz maximum pixel clock
(--) NVIDIA(0): MST (DFP-0): 155.0 MHz maximum pixel clock
(--) NVIDIA(0): MST (DFP-0): Internal Single Link TMDS
(II) NVIDIA(0): Assigned Display Device: CRT-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1400x1050"
(II) NVIDIA(0): "1280x1024"
(II) NVIDIA(0): Virtual screen size determined to be 1400 x 1050
(--) NVIDIA(0): DPI set to (96, 95); computed from "UseEdidDpi" X config
(--) NVIDIA(0): option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(**) NVIDIA(1): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(1): RGB weight 888
(==) NVIDIA(1): Default visual is TrueColor
(==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(1): Option "ConnectedMonitor" "DFP-0"
(**) NVIDIA(1): Option "CustomEDID" "DFP-0: /etc/X11/Samsung_edid.bin"
(**) NVIDIA(1): Enabling RENDER acceleration
(II) NVIDIA(1): NVIDIA GPU GeForce 6600 GT (NV43) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(1): Memory: 131072 kBytes
(--) NVIDIA(1): VideoBIOS: 05.43.02.16.00
(II) NVIDIA(1): Detected PCI Express Link width: 16X
(--) NVIDIA(1): Interlaced video modes are supported on this GPU
(--) NVIDIA(1): Connected display device(s) on GeForce 6600 GT at PCI:1:0:0:
(--) NVIDIA(1): NEC FE950+ (CRT-0)
(--) NVIDIA(1): MST (DFP-0)
(--) NVIDIA(1): NEC FE950+ (CRT-0): 400.0 MHz maximum pixel clock
(--) NVIDIA(1): MST (DFP-0): 155.0 MHz maximum pixel clock
(--) NVIDIA(1): MST (DFP-0): Internal Single Link TMDS
(II) NVIDIA(1): Assigned Display Device: DFP-0
(WW) NVIDIA(1): No valid modes for "1920x1080"; removing.
(WW) NVIDIA(1): No valid modes for "1366x768"; removing.
(WW) NVIDIA(1): No valid modes for "852x480"; removing.
(WW) NVIDIA(1):
(WW) NVIDIA(1): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(1): "nvidia-auto-select".
(WW) NVIDIA(1):
oldguy is offline   Reply With Quote
Old 01-21-09, 06:54 PM   #4
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: customEDID ?

I think you'll need to set the path/to/edidfile!!
And where's the path to edid file??? I don't know.
My samsung T200 doesn't work properly here!
It won't power sleep down after a few minutes of inactivity

black screen but it won't power off
marchetto is offline   Reply With Quote
Old 01-21-09, 08:29 PM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: customEDID ?

Please post a bug report so I can see your config file. Since you have multiple X screens, try putting the CustomEDID option in the other screen section (or in both sections).
AaronP is offline   Reply With Quote
Old 01-22-09, 07:19 AM   #6
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: customEDID ?

Quote:
Originally Posted by oldguy View Post
Code:
(**) NVIDIA(1): Option "CustomEDID" "DFP-0: /etc/X11/Samsung_edid.bin"
There is a white space in between "DFP-0:" and "/etc/X11/Samsung_edid.bin".
However, I don't know if this makes a difference ...

regards

Bernhard
JaXXoN is offline   Reply With Quote
Old 01-22-09, 09:42 AM   #7
oldguy
Registered User
 
Join Date: Dec 2007
Posts: 39
Default Re: customEDID ?

Quote:
Originally Posted by AaronP View Post
Please post a bug report so I can see your config file. Since you have multiple X screens, try putting the CustomEDID option in the other screen section (or in both sections).
I'm not at home to do this right now, but here is a previous post of my config as well as the resultant effective config dumped form nvidia tools after load.

http://www.nvnews.net/vbulletin/showthread.php?t=125693
01-19-09, 07:59 PM

I've also tried intentionally providing an incorrect file name for the customEDID to see it generate an error, thinking this would re-assure me that it was reading the file correctly. Strangely, no error was generated. It's as if the customEDID option is not actually being processed.
oldguy is offline   Reply With Quote
Old 01-22-09, 09:46 AM   #8
oldguy
Registered User
 
Join Date: Dec 2007
Posts: 39
Default Re: customEDID ?

Quote:
Originally Posted by JaXXoN View Post
There is a white space in between "DFP-0:" and "/etc/X11/Samsung_edid.bin".
However, I don't know if this makes a difference ...
Yeah thanks! I actually tried it both with and without the space with no difference.
oldguy is offline   Reply With Quote

Old 01-22-09, 05:38 PM   #9
oldguy
Registered User
 
Join Date: Dec 2007
Posts: 39
Smile Re: customEDID ?

Quote:
Originally Posted by AaronP View Post
Since you have multiple X screens, try putting the CustomEDID option in the other screen section (or in both sections).
BINGO!

Moving the Option customEDID to the "first" screen section, (even though it applies to the second screen), worked.

I haven't finished checking it out fully yet, but it now shows the correct device and resolution in the nvidia-tools.

THANK YOU!

oldguy is offline   Reply With Quote
Old 01-23-09, 08:45 AM   #10
orduek
Registered User
 
Join Date: Jan 2009
Posts: 21
Default Re: customEDID ?

How did you build your custom EDID?
I only found windows software that do that, any linux one?
orduek is offline   Reply With Quote
Old 01-23-09, 12:32 PM   #11
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: customEDID ?

here's
I didn't understand anything about the edid settings in xorg.conf.
Attached Files
File Type: zip nvidia.zip (31.9 KB, 383 views)
marchetto is offline   Reply With Quote
Old 01-23-09, 01:33 PM   #12
oldguy
Registered User
 
Join Date: Dec 2007
Posts: 39
Default Re: customEDID ?

Quote:
Originally Posted by orduek View Post
How did you build your custom EDID?
I only found windows software that do that, any linux one?
In my case, I didn't "build" it I "captured" it.

I initially did a direct hookup to my device (Samsung 1080P TV) that was working but not through my desired connection boxes. Then I "captured" the functional EDID with:

Applications -> System Tools -> Nvidia Xserver Settings
GPU 0 -> <display> [Acquire EDID]

Now I re-apply this captured EDID via "Option customEDID"
oldguy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.