Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-21-09, 05:12 PM   #1
rdk
Registered User
 
Join Date: Apr 2005
Posts: 5
Default FC10, nvidia driver 180.22, no screens nor devices detected

Hi!

I've got an HP quad-core box and have installed an Nvidia 9400GT graphics card.

I'm running FC10 kernel 2.6.27.9-159.fc10.x86-64

I've downloaded the 64-bit 180.22 drivers and ran the install but X still wont start. I keep getting No devices detected and no screens found.

The driver install worked fine. If I lsmod , the nvidia driver is loaded.

I saw the relevant post about a slimmed down xorg.conf. My xorg.conf simply has Driver nvidia and I've toyed with adding a BusID statement to it.

Under /proc/driver/nvidia/cards/ I have a 0 and 1; 0 is apparently a GeForce 8200 while 1 is my new GeForce 9400GT. Both cards show ??? for Video Bios. Dont know if thats relevant.

I have Makedev 3.24-1 and xorg server 1.5.3-6.

Any other suggestions to get the nvidia driver to work? My machine is hosed now and X wont work anymore.

Thanks,

Bobby
rdk is offline   Reply With Quote
Old 01-21-09, 05:23 PM   #2
rdk
Registered User
 
Join Date: Apr 2005
Posts: 5
Default Solved: Re: FC10, nvidia driver 180.22, no screens nor devices detected

Hi!

I solved the problem. The problem was that I was specifying the BusID incorrectly.

The BusID statement should have all colons, no periods.

If you look /proc/driver/nvidia/cards, they will show Bus locations like: 03.00.0

But, the xorg.conf file wants to see "PCI:03:00:0". No error message indicating an incorrect BusID was ever given. Yuck on how much time I wasted on this.

Bobby
rdk is offline   Reply With Quote
Old 01-21-09, 05:26 PM   #3
nomadewolf
Registered User
 
Join Date: Jan 2009
Posts: 7
Default Re: FC10, nvidia driver 180.22, no screens nor devices detected

i have a similar problem
my card is an 8600M GS and when i install that same driver version, my screen doesn't get detected and i can't use resolutions higher than 800x600.
I also use 64 bit linux
nomadewolf is offline   Reply With Quote
Old 01-21-09, 05:34 PM   #4
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: FC10, nvidia driver 180.22, no screens nor devices detected

Quote:
Originally Posted by nomadewolf View Post
i have a similar problem
my card is an 8600M GS and when i install that same driver version, my screen doesn't get detected and i can't use resolutions higher than 800x600.
I also use 64 bit linux
Have a look here

http://forums.fedoraforum.org/showth...=204752&page=8

Post #149 and possible solution on post #155
__________________
leigh123linux
leigh123linux is offline   Reply With Quote
Old 01-21-09, 05:46 PM   #5
nomadewolf
Registered User
 
Join Date: Jan 2009
Posts: 7
Default Re: FC10, nvidia driver 180.22, no screens nor devices detected

Quote:
Originally Posted by leigh123@linux View Post
Have a look here

http://forums.fedoraforum.org/showth...=204752&page=8

Post #149 and possible solution on post #155
Thanks, but i'm using SuSE, yum is not recognised...
nomadewolf is offline   Reply With Quote
Old 01-22-09, 05:33 AM   #6
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: FC10, nvidia driver 180.22, no screens nor devices detected

Quote:
Originally Posted by nomadewolf View Post
Thanks, but i'm using SuSE, yum is not recognised...

The actual fix will work for any linux disto

http://forums.fedoraforum.org/showpo...&postcount=155

add vmalloc=256MB to the kernel option line in /boot/grub/grub.conf or /boot/grub/menu.lst
__________________
leigh123linux
leigh123linux is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 10:03 AM
NVIDIA Driver Installation flores.facundo NVIDIA Linux 2 06-24-12 08:37 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM

All times are GMT -5. The time now is 04:31 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.