Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-01-09, 10:43 PM   #1
rajeshksv37
Registered User
 
Join Date: May 2008
Posts: 6
Red face opensuse 11.1 nvidia problem- very slow performance

Hey guys,

I recently switched to suse 11.1 .Its running very slow on my lap.But Suse 11.0 worked fine .My lap config is Dell Vostro 1500, 2 GB RAM,1.6 GHZ Core 2 Duo,8400 NVIDIA 128MB Graphic card.So ,thers no prob wid my lap config..

I installed 180.22 Nvidia driver and also installed latest version of compiz.But still its very slow.Sometimes when I switch between windows I have to hover with mouse so that all content appears.Even when I disbale my desktop effects its still running slow ..Running slow means even while i am typing ,cursor dont move properly.It takes 1-2 sec to move...such worse is the situation...ofcourse this happens even when very few applications are running.I browsed thr different sites and found different solutions and bugged with them..Can any1 tell me in breif wt 2 do ???

Thanks in advance...
rajeshksv37 is offline   Reply With Quote
Old 02-02-09, 07:00 AM   #2
DeiF
Registered User
 
Join Date: Oct 2008
Posts: 114
Default Re: opensuse 11.1 nvidia problem- very slow performance

I have a similar laptop (same RAM, proc and graphics card) with openSuSE 11.1 and it's running perfectly here.

Could you attach an "nvidia-bug-report.log" as described here? That way we can look at xorg.conf options and other things to identify the problem.
DeiF is offline   Reply With Quote
Old 02-03-09, 11:54 AM   #3
rajeshksv37
Registered User
 
Join Date: May 2008
Posts: 6
Default Re: opensuse 11.1 nvidia problem- very slow performance

Actually I had two kernels

openSUSE 11.1 - 2.6.27.7-9 (default)
Failsafe -- openSUSE 11.1 - 2.6.27.7-9 (default)
openSUSE 11.1 - 2.6.27.7-9 (pae)
Failsafe -- openSUSE 11.1 - 2.6.27.7-9 (pae)

Wts d difference between default and pae??


For the first one(default) xserver is not at all working ,for second one(pae) Xserver is working but its very slow as mentioned.I am attaching the log of Nvidia .(I was working in second one(pae) while attaching this)..
Btw which version of Nvidia are u using?? 180.22 ?? Have u updated any packages ??

I am very lucky that I found a friend whoz having same config but with no problems

Can you mail me at RAJESHKSV37@yahoo.co.in (if you dont mind) bcz I have few more problems also in suse ofcourse not regarding Nvidia...

Thanks in Advance...
Attached Files
File Type: log nvidia-installer.log (52.7 KB, 100 views)
rajeshksv37 is offline   Reply With Quote
Old 02-03-09, 12:04 PM   #4
rajeshksv37
Registered User
 
Join Date: May 2008
Posts: 6
Default Re: opensuse 11.1 nvidia problem- very slow performance

Oops very sorry,i forgot to add bug report..Its here..I ran this script when I was running in pae kernel..
In tht pae kernel ,I am facing lot of problems..I was not able to mount CD drive also

I am getting this error

DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken

Plz help me..I am totally hopeless
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (34.3 KB, 87 views)
rajeshksv37 is offline   Reply With Quote
Old 02-04-09, 06:34 AM   #5
DeiF
Registered User
 
Join Date: Oct 2008
Posts: 114
Default Re: opensuse 11.1 nvidia problem- very slow performance

I'm using 180.25, but it made no difference with previous versions. All has been working OK except VDPAU which got broken lately on my laptop.

This is what I know about PAE:
http://en.wikipedia.org/wiki/Physical_Address_Extension
You probably tried to install the 32-bit driver, and then the package manager had to install also a 32-bit kernel to make it work, which in your case, since your CPU supports PAE, got installed.
In short: you have a 32-bit kernel with support for >4GB RAM, and a 32-bit NVIDIA driver.
I don't know if that makes a difference. I have a full 64-bit system so I can't tell. Maybe you have a mix of 32 and 64 bit libraries?


If you are running KDE4, go to SuSE menu -> system preferences -> desktop -> advanced options, and make sure the composition type is set as OpenGL. Also disable "Use VSync" to save power.

If you are running Gnome then no idea.


About the CD... there was a bug related to it, but AFAIK got fixed since 21 jan. If you still see it, you have to report it to Novell bugzilla. Maybe it's a new bug. You can also use the official forums and then ask there.
DeiF is offline   Reply With Quote
Old 02-04-09, 08:01 AM   #6
clarious
Registered User
 
Join Date: Jan 2009
Posts: 39
Default Re: opensuse 11.1 nvidia problem- very slow performance

Quote:
Originally Posted by rajeshksv37 View Post
Hey guys,

I recently switched to suse 11.1 .Its running very slow on my lap.But Suse 11.0 worked fine .My lap config is Dell Vostro 1500, 2 GB RAM,1.6 GHZ Core 2 Duo,8400 NVIDIA 128MB Graphic card.So ,thers no prob wid my lap config..

I installed 180.22 Nvidia driver and also installed latest version of compiz.But still its very slow.Sometimes when I switch between windows I have to hover with mouse so that all content appears.Even when I disbale my desktop effects its still running slow ..Running slow means even while i am typing ,cursor dont move properly.It takes 1-2 sec to move...such worse is the situation...ofcourse this happens even when very few applications are running.I browsed thr different sites and found different solutions and bugged with them..Can any1 tell me in breif wt 2 do ???

Thanks in advance...
Maybe you should enable loose binding, this may cause some garbage to be displayed in a new windows so you may want to enable indirect rendering too.
clarious is offline   Reply With Quote
Old 02-04-09, 06:14 PM   #7
rajeshksv37
Registered User
 
Join Date: May 2008
Posts: 6
Default Re: opensuse 11.1 nvidia problem- very slow performance

Finally I got bugged up with 32-bit suse 11.1 and installed 64-bit 11.1 (as you told urs 64 bit is working fine) :P

Even for me ,Its better compared to 32 bit one but still running slow...Temme if you had added any lines to xorg.conf or changed any configurations after installing nvidia ..I hadnt made any changes after installed Nvidia..In many sites they suggested to add few lines in xorg.conf ..I donno if its needed....(Even now I had to disable all desktop effects in order to work ) Or should I have to upgrade to 180.25?(i am presently using 180.22)

I am attaching the log ..plz help me
Attached Files
File Type: log nvidia-bug-report.log (118.2 KB, 82 views)
rajeshksv37 is offline   Reply With Quote
Old 02-05-09, 06:41 AM   #8
rainerklier
Registered User
 
Join Date: Oct 2003
Posts: 45
Exclamation Re: opensuse 11.1 nvidia problem- very slow performance

i also have a dell notebook with nvidia-gfx-card with opensuse11.1 x86_64, and it works perfectly!

i use the nvidia-driver from ftp://download.nvidia.com/XFree86/Linux-x86_64/180.27/

make the following as root:
  1. deinstall all rpm-based nvidia-drivers with yast
  2. install kernel-source & kernel-syms packages
  3. download ftp://download.nvidia.com/XFree86/Li...80.27-pkg2.run to /tmp
  4. Code:
    cd /usr/src/linux-obj/x86_64/default
  5. Code:
    cp .config Module.symvers /usr/src/linux/
  6. Code:
    cd /usr/src/linux
  7. Code:
    make prepare
  8. Code:
    make modules_prepare
  9. close KDE/gnome and change to runlevel 3:
    Code:
    init 3
  10. Code:
    cd /tmp
  11. Code:
    chmod +x NVIDIA-Linux-x86_64-180.27-pkg2.run
  12. Code:
    ./NVIDIA-Linux-x86_64-180.27-pkg2.run --extract-only
  13. Code:
    cd /tmp/NVIDIA-Linux-x86_64-180.27-pkg2
  14. Code:
    ./nvidia-installer -N -a
  15. follow instructions & answer questions
  16. Code:
    SaX2 -r -m 0=nvidia
  17. setup everything in SaX2 and test & save.
  18. Code:
    cd /etc/X11
  19. Code:
    cp xorg.conf xorg.conf.nvidia.backup
  20. edit /etc/X11/xorg.conf
  21. change your device section to look like this:
    Code:
    Section "Device"
    ....
        BoardName      "Geforce 8400"
        Option         "RenderAccel" "true"
        Option         "HWcursor" "true"
        Option         "Coolbits"   "1"
        Option         "AddARGBGLXVisuals" "true"
        Option         "FlatPanelProperties" "Scaling = Centered"
        Option         "UseCompositeWrapper" "true"
        Option         "XAANoOffscreenPixmaps" "true"
        Option         "AddARGBVisuals" "True"
        Option         "DamageEvents" "True"
        Option         "UseEvents" "False"
        Option         "NvAGP" "0"
        Option         "OnDemandVBlankInterrupts" "true"
    ....
        VendorName     "NVidia"
    EndSection
  22. change to runlevel 5 again:
    Code:
    init 5

with this setup it should be fast.
at least in KDE without compiz.
for performant compiz usage, more things are necessary.
rainerklier is offline   Reply With Quote

Old 02-05-09, 11:53 AM   #9
rajeshksv37
Registered User
 
Join Date: May 2008
Posts: 6
Smile Re: opensuse 11.1 nvidia problem- very slow performance

Thank you very much dude for your detailed tutorial...I found it very convenient to enable Nvidia..Are you working on Gnome or KDE ??As you specified,inorder to run compiz we need to do more things..Can you tell me what to do??The old one 180.22 Nvidia driver also worked fine in absence of compiz.But when I enabled compiz system became very slow even I installed latest verion of compiz..

So plz temme what should I do inorder for compiz to run properly in GNOME..

Thanks once again
rajeshksv37 is offline   Reply With Quote
Old 02-05-09, 03:13 PM   #10
rainerklier
Registered User
 
Join Date: Oct 2003
Posts: 45
Exclamation Re: opensuse 11.1 nvidia problem- very slow performance

Quote:
Originally Posted by rajeshksv37 View Post
Thank you very much dude for your detailed tutorial...I found it very convenient to enable Nvidia..Are you working on Gnome or KDE ??
i prefer KDE3.

Quote:
Originally Posted by rajeshksv37 View Post
As you specified,inorder to run compiz we need to do more things..Can you tell me what to do??
i can tell you how i do it.
as i do not know gnome very well, this might be not a very good solution for gnome. AFAIK in gnome compiz gets started somehow automatically.

Quote:
Originally Posted by rajeshksv37 View Post
So plz temme what should I do inorder for compiz to run properly in GNOME..
ok, i use a solution which should work with every desktop.
do the following as root:
  1. create a file called compizKDE3.desktop or compizGnome.desktop in folder /usr/share/xsessions/
    this file should be a modified copy of kde.desktop or gnome.desktop and contain the following:
    Code:
    [Desktop Entry]
    Encoding=UTF-8
    Type=XSession
    Exec=/usr/local/bin/startcompizKDE3.sh
    Name=KDE3 with compiz
    Comment=Start an KDE3 Session with compiz
  2. then create a file /usr/local/bin/startcompizKDE3.sh or for gnome /usr/local/bin/startcompizGnome.sh
    this should contain the following:
    Code:
    #!/bin/sh
    
    killall --quiet compiz
    killall --quiet compiz-manager
    killall --quiet kde-window-decorator
    killall --quiet emerald
    
    DISPLAY=:0.0 compiz-manager >~/.compiz-manager.log 2>&1 &
    # the following line has to be different for gnome.
    # it should contain the command to start gnome like specified in /usr/share/xsessions/gnome.desktop
    DISPLAY=:0.0 /opt/kde3/bin/startkde
  3. make /usr/local/bin/startcompizKDE3.sh executeable with:
    Code:
    chmod +x  /usr/local/bin/startcompizKDE3.sh
  4. in the directory /home/<yourusername>/.config/compiz create a file called compiz-manager.
  5. it should contain the following:
    Code:
    COMPIZ_OPTIONS="--no-libgl-fallback --ignore-desktop-hints --indirect-rendering --replace"
    you can try it without "--indirect-rendering". on my system i have some strange redraw bugs with direct-rendering, so i have to use indirect-rendering.
  6. that's it.

next time you start a desktop-session, choose the new created session "KDE3 (or gnome) with compiz".
this will start the script /usr/local/bin/startcompizKDE3.sh which will start compiz with compiz-manager/fusion-icon and after that starts your desktop (kde or gnome).
i do it this way for many years now and it works great.
the benefit is, that you can choose to use compiz or not every time you start a new session. so sometimes you use normal gnome/kde, and sometimes you use compiz.
no fix autostarting of compiz.
only if you choose the compiz-session-type.

Quote:
Originally Posted by rajeshksv37 View Post
Thanks once again
you are welcome.
i hope i could help.
rainerklier is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 04:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.