Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-02-09, 02:32 AM   #1
vh-bil
Registered User
 
Join Date: Apr 2008
Posts: 10
Default 180.22 will not work for me, but 177.80 will... Why?

I tried upgrading to the 180.22 driver but I get the error when trying to start x

Code:
Error: API miusmatch: 
The NVIDIA kernel module has version 96.43.03 but this NVIDIA driver component
has version 180.22. Please make sure that the kernel module and all NVIDIA
driver components have the same version.
I installed 177.80 just before I installed 180.22 and 177.22 worked. I also installed 170.22 just after 180.22 failed and 177.80 worked again. How do I get 180.22 to work?

SYSTEM:
OS: Ubuntu Hardy
nForce 790i Ultra SLI
Intel QX9770
nVidia 9800 GX2
4Gig Corsair 1600MHz
vh-bil is offline   Reply With Quote
Old 02-02-09, 04:40 AM   #2
maninalift
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: 180.22 will not work for me, but 177.80 will... Why?

I have a very similar problem, and one that has dogged me since 177.82.

See here for the last time I posted on this forum about the problem (eventually resolved).

SINCE the events described in that post:
When I updated from 180.18 to 180.22 I got the API mismatch error (kernel module=177.82). This time simply reinstalling 177.82, then reinstalling 180.22 fixed the problem. When I then updated to 180.27 I got the same message (kernel module=177.82), but this time simply reinstalling 177.82 then 180.27 did not fix the issue.

I am currently running 177.82, which works.

Why is it that every time I install a new driver my kernel module seems to revert to 177.82?

I have tried deleting all of the nvidia files I can find (particularly those in the kernel modules directories).

I also have some graphical glitches, I don't know whether this is related to the remnant of 177.82 which seems to be hanging around.

Thanks for your attention and your help.
maninalift is offline   Reply With Quote
Old 02-02-09, 07:34 AM   #3
vh-bil
Registered User
 
Join Date: Apr 2008
Posts: 10
Default Re: 180.22 will not work for me, but 177.80 will... Why?

Quote:
Originally Posted by maninalift View Post
I have a very similar problem, and one that has dogged me since 177.82.

See here for the last time I posted on this forum about the problem (eventually resolved).
Thank you for your reply.

After reading your post that you linked, I worked out I had to remove the nVidia packages from the "Synaptic Package Manager" (Ubuntu).

I then uninstalled 177.80 then installed 180.22.

All is working well. Thanks again...
vh-bil is offline   Reply With Quote
Old 02-02-09, 07:46 AM   #4
maninalift
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: 180.22 will not work for me, but 177.80 will... Why?

Pleased it helped, I'm sorry that I didn't address you directly I might have made it easier for you.

As For _my_ problem, if anyone can help, I'd appreciate it.
maninalift is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiseat X with two cards: used to work, now segfaulting Artefact2 NVIDIA Linux 10 06-26-12 06:22 PM
Ask Stack: What is the best way to divide work between developers? News Archived News Items 0 06-10-12 03:10 AM
295.40 Does not Work Had to downgrade to 295.33 Archmbc NVIDIA Linux 4 05-03-12 03:38 PM
Need help to get the X to work on my Acer TravelMate 630 knchee NVIDIA Linux 16 09-19-02 11:16 PM

All times are GMT -5. The time now is 01:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.