Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-02-09, 09:51 AM   #1
Rashef
Registered User
 
Join Date: Feb 2009
Posts: 3
Default nforce 630i + GeForce 7050 + Ubuntu 8.10

Hi,

I'm looking for help 'cauze I'm not able to have NDIVIA driver working properly on a Packard Bell IMEDIA D2144C (with nForce 630i and GeForce 7050).

I installed Ubuntu 8.10 and X starts correctly at low res (800x600) so I tried different ways.

1) Built-in driver installer. It lists 173 and 177 driver and it let me activate one of them. After the reboot the system adviced me that it was unable to load NVIDIA module so I had to start X at low graphical mode.

2) I tried
Code:
sudo dpkg-reconfigure xserver-xorg
followed by
Code:
sudo nvidia-xconfig
. The same error.

3) I tried to boot with different acpi configuration (pci=noacpi, acpi=off, pci=biosirq), but... no way!

4) I downloaded the BIN installer from Nvidia site. It tried to compile the module from scratch, but at the end of the process it advice me that the module cannot be loaded due to undefined error (maybe a different version of gcc).

Now, I've read dozens of thread about similar errors. Sometimes user was able to solve setting a limit to memory at <2 GB into BIOS. My BIOS doesn't allow to do that.

How can I have my linux box working with 3d???

Thanks in advance!!!
Attached Files
File Type: log nvidia-bug-report.log (120.9 KB, 170 views)
Rashef is offline   Reply With Quote
Old 02-02-09, 01:05 PM   #2
Dizzle7677
Registered User
 
Dizzle7677's Avatar
 
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: nforce 630i + GeForce 7050 + Ubuntu 8.10

This way works for me. Adjust to your needs.
1) Purge the nvidia drivers you currently have installed in Synaptic. 177...173..etc
2) D/L the 180.27 drivers and nvidia-xconfig(extract xconfig to a directory)
3) Drop to a shell (tty1) and kill gdm (sudo /etc/init.d/gdm stop)
4) build nvidia-xconfig [make-make install]
5) sudo sh [NVIDIA DRIVER - full name] no precompiled kernel thingymabob....
6) restart gdm (sudo /etc/init.d/gdm start)
7) success/error?
make sure you have build-essential installed. Also it's a good idea to install compiz settings manager and fusion-icon (in the startup also) to switch between metacity/compiz.
__________________
Elephants can fly but they have no reason to.
------------------------------------------
Phenom II X3 720 @ 3.5Ghz | Asus M4A785-M | 2 Gig Crucial DDR2 @ 960 Mhz | GeForce GT 440 1024 MB | Linux 3.6.1 / Ubuntu 12.04 / W.I.N.E v1.5.14
Dizzle7677 is offline   Reply With Quote
Old 02-05-09, 04:02 AM   #3
Rashef
Registered User
 
Join Date: Feb 2009
Posts: 3
Default Re: nforce 630i + GeForce 7050 + Ubuntu 8.10

Quote:
Originally Posted by Dizzle7677 View Post
This way works for me. Adjust to your needs.
1) Purge the nvidia drivers you currently have installed in Synaptic. 177...173..etc
Done...

Quote:
2) D/L the 180.27 drivers and nvidia-xconfig(extract xconfig to a directory)
Done...

Quote:
3) Drop to a shell (tty1) and kill gdm (sudo /etc/init.d/gdm stop)
Done...

Quote:
4) build nvidia-xconfig [make-make install]
make sure you have build-essential installed.
Done... Also m4 is needed... :-)

Quote:
5) sudo sh [NVIDIA DRIVER - full name] no precompiled kernel thingymabob....
I get the same error. Unable to load nvidia.ko module due to an error. It advices me that it could depend on different version of gcc. for me!
Rashef is offline   Reply With Quote
Old 02-05-09, 05:22 AM   #4
Rashef
Registered User
 
Join Date: Feb 2009
Posts: 3
Default Re: nforce 630i + GeForce 7050 + Ubuntu 8.10

I also tried this way with no success: http://ubuntuforums.org/showthread.php?t=1035873
I always get something like that:
Quote:
NVRM: This PCI I/O region assigned to your NVIDIA device is
invalid:
[ 483.615368] NVRM: BAR1 is 0M @ 0x00000000 (PCI:0000:10.0)
[ 483.615369] NVRM: The system BIOS may have misconfigured your graphics
card.
[ 483.615752] nvidia: probe of 0000:00:10.0 failed with error -1
[ 483.615843] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 483.615845] NVRM: None of the NVIDIA graphics adapters were initialized!
Rashef is offline   Reply With Quote
Old 02-05-09, 12:23 PM   #5
Dizzle7677
Registered User
 
Dizzle7677's Avatar
 
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: nforce 630i + GeForce 7050 + Ubuntu 8.10

Quote:
Originally Posted by Rashef View Post
I get the same error. Unable to load nvidia.ko module due to an error. It advices me that it could depend on different version of gcc.
Try this - sudo sh NVIDIA-blahblah -k $(uname -r)

See post:http://www.nvnews.net/vbulletin/showthread.php?t=49951
__________________
Elephants can fly but they have no reason to.
------------------------------------------
Phenom II X3 720 @ 3.5Ghz | Asus M4A785-M | 2 Gig Crucial DDR2 @ 960 Mhz | GeForce GT 440 1024 MB | Linux 3.6.1 / Ubuntu 12.04 / W.I.N.E v1.5.14
Dizzle7677 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 05:13 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.