Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-10-09, 11:42 AM   #1
wesw
Registered User
 
Join Date: Feb 2009
Location: Ohio, US
Posts: 3
Send a message via AIM to wesw
Default [SOLVED] 180.?? / 9800 GTX On Kubuntu/Jaunty - Unusable

So, I just put together a new system, including an EVGA GeForce 9800 GTX / 512MB. I noticed problems right away when I let Ubuntu download and install the proprietary drivers. The card is detected and Jockey suggests using the 180 series driver. I am not sure which one (180.22? 180.27? 180.29?) it downloads and installs since I wasn't paying a lot of attention. After downloading and installing, the next time I logged into X (KDE 4.2), everything seems fine, until I try to launch *any* application... No matter whether it's just Konsole, Konqueror, Firefox, anything... Anything I try to launch locks up KWin / X and there is nothing I can do except restart Xorg. Although the screen is locked, the mouse cursor will work, but none of the windows or the taskbar are responsive. I can CTRL-ALT-F1 to get back to the console and restart KDM, which lets me log back in, but then, what's the point? No program will launch without locking up the system again. Using the built-in OSS driver 'nv', the system works, but there is no eye-candy, and what's the point of having a decent video card, if you can't push it a little bit. I'm not sure what all information You guys need, so here are some random tidbits.

1. I first thought that maybe it was a driver issue, so I tried many different variations. First, as I describe above, letting Ubuntu handle it led to locking up. So, I tried to download and use EnvyNG and it downloaded the driver / installed without complaints and then I experienced the exact same problem. No apps launch w/o locking up the system. After removing EnvyNG and all of its remnants, I went ahead and tried to install manually. After installing the latest driver manually (180.29), I am still in the same position, no matter what app I launch, the system freezes.

2. It doesn't appear to have any useful information in either Xorg.0.log or .xsession-errors. I've checked them both and google'd quite a bit of each of the messages that look suspicious, but this has proven fruitless.

3. I am running an up-to-date jaunty system which seems to work just fine, with the exception of video. The system is running the following kernel -
Code:
Linux wesw-desktop 2.6.28-7-generic #19-Ubuntu SMP Fri Feb 6 08:30:00 UTC 2009 x86_64 GNU/Linux
4. The CPU is - AMD Phenom(tm) 9850 Quad-Core Processor, running in a MSI K9A2 Platinum motherboard. There is 4 GB of RAM.

5. I thought maybe it was a KDE problem, so I decided to try it in Gnome. I 'apt-get install'd all the necessary packages and logged into a GNOME session, only to have it hang before any panels appeared.

I do not have any options set in my xorg.conf, I let nvidia-xconfig create it for me, so I am hoping that there is a magic combination of nvidia-settings / xorg.conf options that someone can point me to that will fix this. I have read up on a few places different options that are available, but each time I read, it seems that the options are meant to help people with different GPUs or people using older drivers (173.??.??). Attached is the nvidia log file generated from the shell script that comes with the driver.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (31.3 KB, 76 views)

Last edited by wesw; 02-10-09 at 02:13 PM. Reason: problem solved!
wesw is offline   Reply With Quote
Old 02-10-09, 12:20 PM   #2
DeeZiD
Registered User
 
Join Date: Feb 2007
Posts: 13
Default Re: 180.?? / 9800 GTX On Kubuntu/Jaunty - Unusable

This must be a problem in Jaunty's Xorg.
I've noticed this behaviour, too.

Xorg 1.6RC
NVIDIA 180.27 and 180.29


Dennis
DeeZiD is offline   Reply With Quote
Old 02-10-09, 12:53 PM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 180.?? / 9800 GTX On Kubuntu/Jaunty - Unusable

Exactly which Ubuntu package did you install? The Ubuntu developers patched the X server in xorg-server-1.5.99.902-0ubuntu2 in a way that breaks OpenGL, and then fixed it again by reverting the patch in 1.5.99.902-0ubuntu5. See Launchpad bug #326344.

Edit: I just noticed that Ubuntu's patched X server reports its version number in the log file. Good for them!
Quote:
Originally Posted by Xorg.0.log
xorg-server 2:1.5.99.902-0ubuntu4 (buildd@crested.buildd)
This is one of the broken versions. Please upgrade to 1.5.99.902-0ubuntu5.

Last edited by AaronP; 02-10-09 at 12:55 PM. Reason: Noticed that the Ubuntu version number is in the log file
AaronP is offline   Reply With Quote
Old 02-10-09, 02:12 PM   #4
wesw
Registered User
 
Join Date: Feb 2009
Location: Ohio, US
Posts: 3
Send a message via AIM to wesw
Default Re: 180.?? / 9800 GTX On Kubuntu/Jaunty - Unusable

Quote:
This is one of the broken versions. Please upgrade to 1.5.99.902-0ubuntu5.
Awesome, you were right, this was definitely my problem. A couple of notes though. I upgraded the xorg core package and the problem went away, however, OpenGL did not work. I googled a bit and figured out that it was a side-effect of not having the driver installed in a "ubuntu-y" way. So, I switched back to NV, ran the NVIDIA shell script with --uninstall, rebooted and then went ahead and let Ubuntu's Jockey install the driver it wanted. According to dmesg, it is using 180.27, which isn't the newest, but now everything is working great! Thanks for the help!
wesw is offline   Reply With Quote
Old 03-11-09, 10:18 AM   #5
wesw
Registered User
 
Join Date: Feb 2009
Location: Ohio, US
Posts: 3
Send a message via AIM to wesw
Default Re: 180.?? / 9800 GTX On Kubuntu/Jaunty - Unusable

So, an apt-get update / apt-get upgrade at some point put me back in this same position. I've filed a bug upstream because I'd really rather use KDE over Gnome, but Gnome is working in the meantime. Here is the launchpad, in case anyone comes across the same problem -

https://bugs.launchpad.net/ubuntu/+s...ce/+bug/341119
wesw is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 02:50 PM
NVIDIA launches GeForce GTX 670, Zotac's AMP! Reviewed (PCGamer) News GeForce GTX 670 Reviews 0 05-10-12 11:11 AM
GALAXY Launches the GeForce GTX 670 and GTX 670 GC! News Archived News Items 0 05-10-12 10:28 AM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 10:28 AM
NVIDIA Unleashes the GeForce GTX 670 Graphics Card ' Performance Perfected (WCCFTECH) News GeForce GTX 670 Reviews 0 05-10-12 09:40 AM

All times are GMT -5. The time now is 10:26 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.