Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-02-09, 11:52 PM   #37
ahl
Registered User
 
Join Date: Feb 2009
Posts: 7
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

If anyone else is using P6T Deluxe there is a brand new BIOS available that fixes some GPU issues. Unfortunately it did not fix this issue. However my glxgears score doubled.

And now I'm getting confusing results from my leaktest program. I now have to use double buffering or call glFlush() every frame before it gives correct results on this computer. I'm confused.
ahl is offline   Reply With Quote
Old 03-03-09, 11:35 AM   #38
firewalker
Registered User
 
Join Date: Mar 2005
Location: Ellas
Posts: 32
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

Hi,

If you kill gnome-screensaver can you reproduce the error ?
firewalker is offline   Reply With Quote
Old 03-03-09, 12:51 PM   #39
miseiler
Registered User
 
Join Date: Aug 2008
Posts: 25
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

I don't use gnome. Or any DE.
miseiler is offline   Reply With Quote
Old 03-03-09, 01:13 PM   #40
Tonglebeqk
Registered User
 
Join Date: Jun 2008
Posts: 30
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

Quote:
Originally Posted by ahl View Post
This problem is quite serious. I can't believe it hasn't been fixed yet. A simple glClear() will trigger the leak. Alternatively if you enable double buffering SwapBuffers() will do the same.

I was bored waiting for fix so I wrote a simple test program which can be used to test whether your OpenGL implementation is leaking or not. It continuously prints memory usage on console and exits if it rises above 200MB.

Edit #1: If using Ubuntu Hardy "sudo apt-get install gcc libglut3-dev" should install the necessary dependencies
Edit #2: This program puts little stress on your hardware
Edit #3: Uploaded v2 that does glFlush()
Wow, if that leaktest is legit, I went from 0 to 200M within 10 seconds (GTX 260)
Tonglebeqk is offline   Reply With Quote
Old 03-03-09, 01:15 PM   #41
miseiler
Registered User
 
Join Date: Aug 2008
Posts: 25
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

Quote:
Originally Posted by Tonglebeqk View Post
Wow, if that leaktest is legit, I went from 0 to 200M within 10 seconds (GTX 260)
You should try 32-bit glxgears...10 seconds is the time it takes to choke at 4G!
miseiler is offline   Reply With Quote
Old 03-03-09, 01:19 PM   #42
firewalker
Registered User
 
Join Date: Mar 2005
Location: Ellas
Posts: 32
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

Ok. Then it's probably not that. I made some changes and now I can't reproduce the problem. Had WorldOfGoo (32bit) running for hours without any memory leak or kernel BUG.

What I changed was (other than killing gnome-screensaver) :

- Made a custom package of nvidia driver using the 32bit libs found at NVIDIA-Linux-x86_64-180.35-pkg2.run. The previous package (from rpmfusion) used the 32bit libs from the 32bit package. While the libs are the same the NVIDIA-Linux-x86_64-180.35-pkg2.run doesn't seem to have 32 bit version of libnvidia-cfg.so.180.35.

Code:
 diff -r NVIDIA-Linux-x86-180.35-pkg0/usr/lib/ NVIDIA-Linux-x86_64-180.35-pkg2/usr/lib32/
Only in NVIDIA-Linux-x86-180.35-pkg0/usr/lib/: libnvidia-cfg.so.180.35
I hope it helps.

Cheers
firewalker is offline   Reply With Quote
Old 03-04-09, 02:04 AM   #43
ahl
Registered User
 
Join Date: Feb 2009
Posts: 7
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

Quote:
Originally Posted by firewalker View Post
- Made a custom package of nvidia driver using the 32bit libs found at NVIDIA-Linux-x86_64-180.35-pkg2.run. The previous package (from rpmfusion) used the 32bit libs from the 32bit package. While the libs are the same the NVIDIA-Linux-x86_64-180.35-pkg2.run doesn't seem to have 32 bit version of libnvidia-cfg.so.180.35.

I hope it helps.
Didn't help me. My 32bit libs (installed by Gentoo) do not have libnvidia-cfg.so.180.35. I even tried various combinations of NVIDIA-provided 32bit libraries but nothing made a difference.
Giving up for now. I'm too tired of this problem. I hope next nvidia release fixes this.
ahl is offline   Reply With Quote
Old 03-06-09, 09:18 PM   #44
netarchy
Registered User
 
netarchy's Avatar
 
Join Date: Jul 2003
Location: San Antonio, TX
Posts: 19
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

Updated to 180.37, issue still exists.
Attached Files
File Type: gz nvidia-bug-report.log.gz (27.1 KB, 100 views)
__________________
System Specs:
Intel Core i7 920(C0) @ 3.3ghz
6 gigs Corsair Dominator ddr3-1600
nVidia GeForce GTX 580
Dual boot Windows 7 and Gentoo x86_64 on Kernel 2.6.37-RC1
netarchy is offline   Reply With Quote

Old 03-07-09, 10:54 AM   #45
niczar
Registered User
 
Join Date: Oct 2007
Posts: 12
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

Quote:
Originally Posted by ahl View Post
This problem is quite serious. I can't believe it hasn't been fixed yet. A simple glClear() will trigger the leak. Alternatively if you enable double buffering SwapBuffers() will do the same.

I was bored waiting for fix so I wrote a simple test program which can be used to test whether your OpenGL implementation is leaking or not. It continuously prints memory usage on console and exits if it rises above 200MB.

Edit #1: If using Ubuntu Hardy "sudo apt-get install gcc libglut3-dev" should install the necessary dependencies
Edit #2: This program puts little stress on your hardware
Edit #3: Uploaded v2 that does glFlush()
Excellent work, thank you. It starts leaking immediately, and when I quite the app, display freezes for a few seconds.
Hope nVidia will fix this soon.
niczar is offline   Reply With Quote
Old 03-10-09, 10:17 PM   #46
goldmember
Registered User
 
Join Date: Sep 2005
Posts: 24
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

Confirmed on Fedora x64. I compiled the same version of glxgears.c using 32bit and 64bit. The 32bit version is up to 200M memory after 40seconds, while the 64bit version keeps at about 10M memory.
I'm using version 180.37 of the driver.
goldmember is offline   Reply With Quote
Old 03-11-09, 04:27 AM   #47
Ixar
Registered User
 
Join Date: Mar 2009
Posts: 2
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

I reproduced the issue with glxgears and the provided test case:
- 6GB ram => KO
- 4GB (with mem=4G at boot) => OK
- 3GB (with mem=3G at boot) => OK

As it is easily reproducible I hope we will have nvidia feedback soon.

It looks like the 32bit opengl API cannot interface properly with the 64bit driver,
I think it could be related to textures stored in ram above the physical 4GB.
Ixar is offline   Reply With Quote
Old 03-11-09, 02:58 PM   #48
niczar
Registered User
 
Join Date: Oct 2007
Posts: 12
Default Re: Huge slowdown after 2 min in 3D games with >3GB RAM and Memory Remap Enabled

Is there nothing new on this?
niczar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.