Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-11-09, 09:11 AM   #1
mkossmann
Registered User
 
Join Date: Apr 2003
Posts: 26
Default 180.29 destroys non X11 textconsoles on Quadro FX 770M

After starting X11 with Nvidia-drivers on my HP8530w laptop with Quadro FX 770M all non X11 textconsoles show only a black screen. Is there a workaround for that problem.
mkossmann is offline   Reply With Quote
Old 02-11-09, 09:13 AM   #2
mkossmann
Registered User
 
Join Date: Apr 2003
Posts: 26
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

Forgot to attach nvidia-bug-report.log
Attached Files
File Type: gz nvidia-bug-report.log.gz (42.3 KB, 140 views)
mkossmann is offline   Reply With Quote
Old 02-11-09, 10:19 AM   #3
sambo57u
Registered User
 
Join Date: Jan 2006
Posts: 52
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

What desktop are you using? KDE>? GNOME? ..
sambo57u is offline   Reply With Quote
Old 02-11-09, 11:38 AM   #4
mkossmann
Registered User
 
Join Date: Apr 2003
Posts: 26
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

It makes no difference what desktop I start up. And the login manager doesn't matter ,too. The textconsoles get corrupted even if I start /usr/bin/X (without any windowmanager) from a textconsole in runlevel 3. And the problem definitely hardware specific. On a desktop with geforce 7800gt card and same environment (SUSE-11.1) there is no problem with the textconsoles.
mkossmann is offline   Reply With Quote
Old 02-11-09, 04:00 PM   #5
slusken
Registered User
 
Join Date: Feb 2009
Posts: 8
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

i have the exact same problems but with all Nvidia driver (tried 173.xx and up). 9600M GT card
slusken is offline   Reply With Quote
Old 02-11-09, 04:08 PM   #6
slusken
Registered User
 
Join Date: Feb 2009
Posts: 8
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

forgot to add bugreport
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (34.5 KB, 133 views)
slusken is offline   Reply With Quote
Old 02-11-09, 04:23 PM   #7
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

Same problem here. Has been so for ages on a laptop of mine, the text console are completely garbled with a colorful signal which resembles a CRT driven at the wrong frequencies. This happens at the moment the X server starts up. Then they stay that way until reboot, no fix possible. I've already reported the problem to Nvidia (bug email address) including all the necessary data. But the problem isn't fixed yet.

nVidia Corporation NV43 [GeForce Go 6600] (rev a2)
nVidia Driver 180.29
oyvind is offline   Reply With Quote
Old 02-11-09, 06:24 PM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

Are you guys talking about switching away from the X server to one of the consoles, or are you talking about just starting X from a text console with multiple displays attached?
AaronP is offline   Reply With Quote

Old 02-11-09, 07:11 PM   #9
slusken
Registered User
 
Join Date: Feb 2009
Posts: 8
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

Quote:
Originally Posted by AaronP View Post
Are you guys talking about switching away from the X server to one of the consoles, or are you talking about just starting X from a text console with multiple displays attached?
im talking about switching away from X to console. Also powermizer wont go further then to performance level 1 wich is kind of annyoing since i only have linux installed and cant play any games with more then 30 fps.
slusken is offline   Reply With Quote
Old 02-11-09, 11:38 PM   #10
mkossmann
Registered User
 
Join Date: Apr 2003
Posts: 26
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

Quote:
Originally Posted by AaronP View Post
Are you guys talking about switching away from the X server to one of the consoles, or are you talking about just starting X from a text console with multiple displays attached?
We are speaking from switching away from X to one of the parallel running textconsoles using the same display.
mkossmann is offline   Reply With Quote
Old 02-12-09, 06:16 AM   #11
olivluca
Registered User
 
Join Date: Feb 2009
Posts: 8
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

Same problem here (unsurprising, since it's the same elitebook 8530w).
@AaronP, switching away from X to one of the text consoles (ctrl+alt+f1..6).
Not only the screen is blank, but the backlight is off.
I also get no feedback while switching off the computer (the messages or the shutdown graph use the framebuffer and, again, the screen is black with no backlight).

Edit: I tried also to disable the framebuffer (i.e. plain text console) and various vga modes, with the same result.
olivluca is offline   Reply With Quote
Old 02-14-09, 05:52 PM   #12
Vitor Rodrigues
Registered User
 
Join Date: Feb 2009
Posts: 1
Default Re: 180.29 destroys non X11 textconsoles on Quadro FX 770M

I have the same problems running fedora on a HP 8530w. But I'm not sure if the keyboard shortcuts don't work because of the nvidia driver or because of something in the system configuration.

running xev I get:

KeyRelease event, serial 31, synthetic NO, window 0x4e00001,
root 0x25b, subw 0x0, time 1012286, (88,113), root1700,195),
state 0xc, keycode 67 (keysym 0x1008fe01, XF86_Switch_VT_1), same_screen YES

which seems to be correct but no action is taken.

Another problem is the fn+f4 to switch to external monitor. In http://www.linlap.com/wiki/HP+EliteBook+8530W people say that this problem is fixed for ubuntu but my fedora doesn't recognize the shortcut.

I've tried

setkeycodes 0xe06e 227

but the it doesn't work. I guess that code 227 is correct because running xmodmap I get

xmodmap -pk | grep XF86Display
235 0x1008ff59 (XF86Display) 0x0000 (NoSymbol) 0x1008ff59 (XF86Display) 0x0000 (NoSymbol) 0x1008ff59 (XF86Display)

Since the kernel codes differ by 8 to the xmodmap codes (and for other XF86 codes this is true) I wonder what can be the problem. I just don't know if this is a fedora issue or nvidia's.
Vitor Rodrigues is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Choosing The Right GPU To Take Adobe Workflows To The Max News Archived News Items 0 05-29-12 05:40 PM

All times are GMT -5. The time now is 01:07 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.