Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-25-10, 10:52 AM   #1
Nechushtan
Registered User
 
Join Date: Dec 2005
Posts: 21
Default GT220 on Ubuntu Lucid, can't restart X

Interesting issue I'm having.

So I've got a motherboard with an onboard 7050 GPU and a GT220 in the PCI slot. I've got Ubuntu Lucid with all the latest packages.

Upon initial boot everything loads fine, but if I, say either kill Xorg or stop gdm and then try to restart X I can't.

I get the following in my dmesg log:
<code>[ 1717.483473] NVRM: RmInitAdapter failed! (0x12:0x2b:1671)
[ 1717.483482] NVRM: rm_init_adapter(0) failed</code>

and this in the Xorg.0.log:
<code>
(EE) Jul 25 11:45:01 NVIDIA(0): Failed to initialize the NVIDIA graphics device
PCI:2:0:0.
(EE) Jul 25 11:45:01 NVIDIA(0): Please check your system's kernel log for ad
ditional error
(EE) Jul 25 11:45:01 NVIDIA(0): messages and refer to Chapter 8: Common Prob
lems in the
(EE) Jul 25 11:45:01 NVIDIA(0): README for additional information.
(EE) Jul 25 11:45:01 NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional informati
on.

ddxSigGiveUp: Closing log
</code>

everytime X tries to start

I've also tried installing the newer 256.35 via a PPA repo, and the "stock" 195.36 driver from the standard Ubuntu repo.

This is driving me a little crazy so I'm hoping someone here knows what's going on...

thanks!
Nechushtan is offline   Reply With Quote
Old 07-25-10, 12:31 PM   #2
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: GT220 on Ubuntu Lucid, can't restart X

Please include nan nvidia bug report as described here:


http://nvnews.net/vbulletin/showthread.php?t=46678
adamk75 is offline   Reply With Quote
Old 07-25-10, 02:02 PM   #3
Nechushtan
Registered User
 
Join Date: Dec 2005
Posts: 21
Default Re: GT220 on Ubuntu Lucid, can't restart X

here's the bug report
Attached Files
File Type: gz nvidia-bug-report.log.gz (68.3 KB, 62 views)
Nechushtan is offline   Reply With Quote
Old 07-25-10, 02:46 PM   #4
Nechushtan
Registered User
 
Join Date: Dec 2005
Posts: 21
Default Re: GT220 on Ubuntu Lucid, can't restart X

I don't know if this helps, but when MythTV is running and playing something (using VDPAU) and the error occurs, I get this in the Myth log:

2010-07-25 15:29:59.737 VDPAU: Created 2 output surfaces.
2010-07-25 15:29:59.737 VDPAU: Created VDPAU render device 1920x1200
2010-07-25 15:29:59.808 NVP(2): Forcing decode extra audio option on (Video method requires it).
2010-07-25 15:29:59.813 OSD Theme Dimensions W: 1280 H: 720
2010-07-25 15:29:59.952 TV: Changing from None to WatchingVideo
2010-07-25 15:29:59.954 The realtime priority setting is not enabled.
2010-07-25 15:29:59.962 Video timing method: USleep with busy wait
2010-07-25 15:29:59.979 VDPAU: Added 2 output surfaces (total 4, max 4)
2010-07-25 15:44:40.692 NVP(2): prebuffering pause
2010-07-25 15:44:42.353 NVP(2): Prebuffer wait timed out 10 times.
2010-07-25 15:44:44.013 NVP(2): Prebuffer wait timed out 20 times.
2010-07-25 15:44:45.674 NVP(2): Prebuffer wait timed out 30 times.
2010-07-25 15:44:47.335 NVP(2): Prebuffer wait timed out 40 times.
2010-07-25 15:44:48.996 NVP(2): Prebuffer wait timed out 50 times.
2010-07-25 15:44:50.657 NVP(2): Prebuffer wait timed out 60 times.
2010-07-25 15:44:52.318 NVP(2): Prebuffer wait timed out 70 times.
2010-07-25 15:44:53.978 NVP(2): Prebuffer wait timed out 80 times.
2010-07-25 15:44:55.639 NVP(2): Prebuffer wait timed out 90 times.
2010-07-25 15:44:57.300 NVP(2): Prebuffer wait timed out 100 times.
2010-07-25 15:44:57.300 NVP(2), Error: Timed out waiting for prebuffering too long. Exiting..
2010-07-25 15:44:57.322 TV: Attempting to change from WatchingVideo to None
2010-07-25 15:44:57.356 TV: Changing from WatchingVideo to None
2010-07-25 15:44:57.376 TV: Attempting to change from None to None
2010-07-25 15:44:57.402 TV: Attempting to change from None to WatchingVideo
2010-07-25 15:44:57.573 playCtx, Error: Attempting to setup a player, but it already exists.
2010-07-25 15:44:58.961 NVP(2): Prebuffer wait timed out 110 times.
2010-07-25 15:44:58.961 NVP(2), Error: Timed out waiting for prebuffering too long. Exiting..
2010-07-25 15:44:58.961 NVP(2), Error: Video frame buffering failed too many times.
2010-07-25 15:45:00.622 NVP(2): Prebuffer wait timed out 120 times.
2010-07-25 15:45:00.622 NVP(2), Error: Timed out waiting for prebuffering too long. Exiting..
2010-07-25 15:45:00.622 NVP(2), Error: Video frame buffering failed too many times.
2010-07-25 15:45:02.283 NVP(2): Prebuffer wait timed out 130 times.
2010-07-25 15:45:02.283 NVP(2), Error: Timed out waiting for prebuffering too long. Exiting..
2010-07-25 15:45:02.283 NVP(2), Error: Video frame buffering failed too many times.
2010-07-25 15:45:03.943 NVP(2): Prebuffer wait timed out 140 times.
2010-07-25 15:45:03.944 NVP(2), Error: Timed out waiting for prebuffering too long. Exiting..
2010-07-25 15:45:03.944 NVP(2), Error: Video frame buffering failed too many times.
Nechushtan is offline   Reply With Quote
Old 07-28-10, 11:57 PM   #5
laxxy
Registered User
 
Join Date: Jul 2010
Posts: 1
Default Re: GT220 on Ubuntu Lucid, can't restart X

Just wanted to confirm that exact same problem (ie. X cannot restart and fails with the RmInitAdapter message) is happening here with 256.35 drivers under fedora 13 (2.6.33.6-147.fc13.x86_64), the card is GTX 480.
laxxy is offline   Reply With Quote
Old 07-29-10, 10:21 AM   #6
Nechushtan
Registered User
 
Join Date: Dec 2005
Posts: 21
Default Re: GT220 on Ubuntu Lucid, can't restart X

this seems to be a PSU issue. I decided to start swapping components with another working machine to see what was wrong and when I swapped the PSU all the issues look to have gone away. I've put in an RMA for the powersupply and am running with a spare PSU I have for just such occasions. Two days in and no issues.
Nechushtan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.