Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-27-09, 05:58 PM   #37
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: 180.35 breaks terminal

Ah, yes I use evdev, too, since it seems to be the defacto standard input device driver (without an xorg.conf you get evdev).

Here is my log... which will show this.

I use the default Fedora 10 kernel, so I don't have anything special in the kernel.
Attached Files
File Type: gz nvidia-bug-report.tar.gz (26.9 KB, 124 views)
mooninite is offline   Reply With Quote
Old 02-27-09, 11:03 PM   #38
devsk
Registered User
 
Join Date: Jun 2006
Posts: 46
Default Re: 180.35 breaks terminal

I use evdev and 35 broke konsole for me. Something wrong with nvidia's QA dept. Linux driver keeps getting worse with every release. I have severe scrolling problems in firefox with 180.29 and 35. A busy cursor makes it use 40% cpu. These kick in after some time, may be ab hour of system usage.
devsk is offline   Reply With Quote
Old 02-28-09, 02:09 AM   #39
rapsure
Registered User
 
Join Date: Oct 2008
Posts: 47
Default Re: 180.35 breaks terminal

Well my config has nothing wrong with it. That config was auto generated by running
Code:
X -configure
It was generated with Xorg-server 1.6 which is why it has the dri2 module set to load. However that won't cause a failure with Xorg-server 1.5 which is what I switched to.

Well I don't know why mooninite isn't experiencing the bug as many of us are. After looking over his nvidia-bug-report log I couldn't pick out any single thing that would be seriously different from the two computers I am running that are experiencing the bug.

My two computers each are running respectively a
EVGA Geforce 7600GT OC
PNY Geforce 9600GT

I guess the dev on Gentoo that added the 180.35 driver isn't experiencing the bug on either of his computers. I've also tried several things myself to fix it such as upgrading to glibc 2.9 since both of my computers are running glibc 2.8, and then changing several options in the kernel and none of them have fixed the bug. I also upgraded to Xorg server 1.6 which didn't fix the problem either so I'm stumped until nVidia release a new driver. If nVidia has successfully reproduced the problem it would be nice to hear something from them as to the status of the bug.
rapsure is offline   Reply With Quote
Old 02-28-09, 02:45 AM   #40
const
Registered User
 
Join Date: Jul 2006
Posts: 1
Unhappy Re: 180.35 breaks terminal

I also catch this problem in following environment:

Linux 2.6.28.5/x86_64
X.org server 1.5.3
XFCE 4.4.3
xf86-input-evdev 2.1.3
xterm 241 and urxvt 9.06
NVIDIA 180.35

Ctrl-C/Ctrl-Z doesn't interrupt/stop application. Ctrl-D works (tested with 'cat' executed without arguments). Downgrade to any older version of NVIDIA driver solves problem.
const is offline   Reply With Quote
Old 02-28-09, 03:13 AM   #41
pacho2
Registered User
 
Join Date: Jan 2008
Posts: 20
Default Re: 180.35 breaks terminal

I am also affected, I am using evdev, .29 works fine

I attach nvidia-bugreport.log file

Thanks for getting this fixed in newer releases :-)
Attached Files
File Type: log nvidia-bug-report.log (97.0 KB, 172 views)
pacho2 is offline   Reply With Quote
Old 02-28-09, 10:46 AM   #42
mdriftmeyer
Registered User
 
Join Date: Feb 2009
Posts: 40
Default Re: 180.35 breaks terminal

Quote:
Originally Posted by rapsure View Post
Well my config has nothing wrong with it. That config was auto generated by running
Code:
X -configure
It was generated with Xorg-server 1.6 which is why it has the dri2 module set to load. However that won't cause a failure with Xorg-server 1.5 which is what I switched to.

Well I don't know why mooninite isn't experiencing the bug as many of us are. After looking over his nvidia-bug-report log I couldn't pick out any single thing that would be seriously different from the two computers I am running that are experiencing the bug.

My two computers each are running respectively a
EVGA Geforce 7600GT OC
PNY Geforce 9600GT

I guess the dev on Gentoo that added the 180.35 driver isn't experiencing the bug on either of his computers. I've also tried several things myself to fix it such as upgrading to glibc 2.9 since both of my computers are running glibc 2.8, and then changing several options in the kernel and none of them have fixed the bug. I also upgraded to Xorg server 1.6 which didn't fix the problem either so I'm stumped until nVidia release a new driver. If nVidia has successfully reproduced the problem it would be nice to hear something from them as to the status of the bug.
What errors do you have under .xsession-errors with respect to terminal services?
mdriftmeyer is offline   Reply With Quote
Old 02-28-09, 05:37 PM   #43
sternklang
Registered User
 
Join Date: Apr 2006
Posts: 13
Default Re: 180.35 breaks terminal

I have the same issue with ctrl-c or ctrl-z in gnome-terminal as well as defunct processes. This is running on a GTX 280. Also all Mono applications fail to load, including Gnome-Do, Banshee and Tomboy. Compiz takes much longer to load at session start. None of these issues exist with 180.29. I use evdev for keyboard and mouse.

I have attached a bug report and my kernel config, let me know if there's anything else that would be useful.

Gentoo 2008.0
Linux 2.6.28.7/x86_64 (vanilla kernel)
X.org server 1.5.3-r2
Gnome 2.24
xf86-input-evdev 2.1.3
nvidia-drivers 180.35
Attached Files
File Type: log nvidia-bug-report.log (102.6 KB, 291 views)
File Type: txt kernel-config.txt (47.7 KB, 135 views)
sternklang is offline   Reply With Quote
Old 03-02-09, 07:09 AM   #44
j0n
Registered User
 
Join Date: Feb 2009
Posts: 16
Default Re: 180.35 breaks terminal

Quote:
Originally Posted by g.krist View Post
Count me in! When using KDE 4.2 on 180.35 and starting konsole makes my Kicker and main panel not responsive also when screen is locked, you can't unlock it.

Guess thats the fate of us users which are running bleeding edge Running 180.29 again and no problem
Exactly!

My bug report.
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (48.5 KB, 115 views)
j0n is offline   Reply With Quote

Old 03-02-09, 02:03 PM   #45
tomaszg
Registered User
 
tomaszg's Avatar
 
Join Date: Dec 2005
Posts: 5
Send a message via Skype™ to tomaszg
Default Re: 180.35 breaks terminal

I have xorg-1.3.0.0 and same problems.
tomaszg is offline   Reply With Quote
Old 03-02-09, 04:48 PM   #46
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 180.35 breaks terminal

Just a quick update: we've tracked down the problem and it should be fixed in the next release.
AaronP is offline   Reply With Quote
Old 03-02-09, 04:51 PM   #47
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: 180.35 breaks terminal

Quote:
Originally Posted by AaronP View Post
Just a quick update: we've tracked down the problem and it should be fixed in the next release.
Good to hear, thank you !
oyvind is offline   Reply With Quote
Old 03-02-09, 06:34 PM   #48
loftwyr
Registered User
 
Join Date: Mar 2005
Posts: 10
Default Re: 180.35 breaks terminal

Thank you!
loftwyr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gigabyte Breaks Ivy Bridge and DDR3 Overclocking World Records News Archived News Items 0 05-30-12 05:00 PM
Chip Shot: Intel Breaks the Top 10 on "The Gartner Supply Chain Top 25" List News Archived News Items 0 05-26-12 06:00 AM

All times are GMT -5. The time now is 02:23 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.