Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-02-09, 12:01 PM   #1
dproduzioni
Registered User
 
Join Date: Feb 2009
Location: between Siena and Pisa
Posts: 8
Send a message via Skype™ to dproduzioni
Default visual issues with nVidia proprietary drivers on Debian 64bit

Hi all out there!
I have encountered many problems installing nVidia proprietary drivers; here is my configuration:
nVidia GeForce 7600GT graphic card
AMD Athlon 64 processor
Debian Lenny AMD64 linux distro

I succesfully install the 180.29 version of the driver, but when I restart KDM this is what I get (it's a pic taken with my digicam):


This is what happens: it cuts out all useful modes and switches to a "safe" 640x480 mode with the wrong refresh rate (this is the reason why my screen appears "stretched" in height); here is a portion of my Xorg.0.log:
Code:
...
(--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
(--) NVIDIA(0): DFP-1: Internal Single Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-1
(WW) NVIDIA(0): No valid modes for "1280x1024"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0): No valid modes for "800x600"; removing.
(WW) NVIDIA(0): 
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):     "nvidia-auto-select".
(WW) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(**) NVIDIA(0): DPI set to (47, 44); computed from "DisplaySize" Monitor
(**) NVIDIA(0):     section option
(==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
...
I also tried to override those weird settings and activate a more useful mode 1024x768 with xrandr:
Code:
gunther@hell:~$ xrandr -v --newmode "1024x768"   56.00  1024 1072 1104 1184  768 771 775 790 +hsync -vsync
gunther@hell:~$ xrandr --addmode default 1024x768
gunther@hell:~$ xrandr --output default --mode 1024x768
xrandr: Configure crtc 0 failed
Anyway, the kernel module is loaded succesfully and even the 3D acceleration works; I checked that with glxinfo, glxgears, lsmod.

I tried also 96, 71, 173, 177, 1 series of the nVidia proprietary drivers. Each one (plus the one I am now workin on: 180.29) with my custom kernel (2.6.28.6 series) and the standard kernel shipped with my distro (2.6.18-6-amd64).

I do not attach my nvidia-bug-report.log; if anyone of you thinks that it can be useful in any way, I will provide it. It is attached my xorg.conf, here you can find the line
Code:
Option         "ModeValidation" "NoVertRefreshCheck, NoHorizSyncCheck, NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNon60HzDFPModes"
with I tried to override the mode validation on KDM startup.

Any help will be appreciated.
Thanks in advance!
Attached Files
File Type: txt xorg.conf.txt (3.8 KB, 95 views)
dproduzioni is offline   Reply With Quote
Old 03-02-09, 12:28 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

Quote:
Originally Posted by dproduzioni View Post
I do not attach my nvidia-bug-report.log; if anyone of you thinks that it can be useful in any way, I will provide it.
Of course it would be useful. As per the forum sticky posts, a bug report is required if you expect help. Please pay special attention to the part about generating a verbose mode validation log, as you are having a mode validation problem. When you generate your bug report, please first remove or comment out the mode validation overrides you added to xorg.conf.
AaronP is offline   Reply With Quote
Old 03-02-09, 01:48 PM   #3
dproduzioni
Registered User
 
Join Date: Feb 2009
Location: between Siena and Pisa
Posts: 8
Send a message via Skype™ to dproduzioni
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

I'm so sorry. I can't attach my log because it exceedes the size limit. I uploaded on another server here:
http://www.udsiena.net/temp/webmaste...bug-report.log.
dproduzioni is offline   Reply With Quote
Old 03-02-09, 02:07 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

Thanks, dproduzioni. In the future, you can compress the log file with gzip so you can attach it. Unfortunately, this log file was generated with a configuration that still has the mode validation overrides, and is missing the verbose mode validation log:
Code:
(**) NVIDIA(0): Option "UseEDID" "FALSE"
(**) NVIDIA(0): Option "UseEdidFreqs" "FALSE"
(**) NVIDIA(0): Option "ModeValidation" "NoVertRefreshCheck, NoHorizSyncCheck, NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNon60HzDFPModes"
(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
(**) NVIDIA(0):     disabled on all display devices.
(**) NVIDIA(0): Ignoring EDIDs
(II) NVIDIA(GPU-0): Not probing EDID on DFP-0.
AaronP is offline   Reply With Quote
Old 03-03-09, 01:43 PM   #5
dproduzioni
Registered User
 
Join Date: Feb 2009
Location: between Siena and Pisa
Posts: 8
Send a message via Skype™ to dproduzioni
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

:shy: :shy:

I've commented out that line, now...
Attached Files
File Type: gz nvidia-report.tar.gz (29.7 KB, 48 views)
dproduzioni is offline   Reply With Quote
Old 03-03-09, 03:09 PM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

That's better, but you're still disabling EDIDs. Also, you're still missing the verbose mode validation log. You need to start X with "startx -- -logverbose 6" before generating the bug report.
Code:
    Option         "UseEDID" "FALSE"
    Option         "UseEDIDFreqs" "FALSE"
Code:
(II) NVIDIA(GPU-0): Not probing EDID on DFP-0.
Sorry, I should have been clearer. Please comment out all of the EDID options. While you're at it, please also comment out the Display subsections, since without them the server should choose reasonable defaults.
AaronP is offline   Reply With Quote
Old 03-04-09, 12:57 PM   #7
dproduzioni
Registered User
 
Join Date: Feb 2009
Location: between Siena and Pisa
Posts: 8
Send a message via Skype™ to dproduzioni
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

I'm sooo sorry and I feel sooo stupid. Sorry again. Shuld go fine now.
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (39.8 KB, 51 views)
dproduzioni is offline   Reply With Quote
Old 03-04-09, 03:13 PM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

Thank you, that's much better. It looks like the driver is failing to read the EDID out of your monitor:
Code:
(WW) NVIDIA(GPU-0): Unable to read EDID for display device DFP-0
I would recommend wiggling or unplugging and reconnecting the connectors on both ends of the cable between the monitor and the GPU. Also, please check both ends to see if any pins are bent or aren't sticking out far enough. If you have a different cable you can try, it would be worth trying that too. If you have a KVM switch between the monitor and GPU, please try bypassing that and connecting the monitor directly.

Alternatively, if your monitor has a VGA input you could see if that successfully returns an EDID. If so, you can save it to a file with nvidia-settings and then feed it back into the driver using the CustomEDID option. There's a good chance that an EDID read that way will still work when connected via DVI.

Barring that, you'll have to manually enter the refresh ranges of the monitor, which you should be able to get from the manufacturer's spec sheets. You may also need the ExactModeTimingsDVI option and possibly the NoDFPNativeResolutionCheck ModeValidation option.
AaronP is offline   Reply With Quote

Old 03-05-09, 04:59 PM   #9
mdriftmeyer
Registered User
 
Join Date: Feb 2009
Posts: 40
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

Quote:
Originally Posted by dproduzioni View Post
Hi all out there!
I have encountered many problems installing nVidia proprietary drivers; here is my configuration:
nVidia GeForce 7600GT graphic card
AMD Athlon 64 processor
Debian Lenny AMD64 linux distro

I succesfully install the 180.29 version of the driver, but when I restart KDM this is what I get (it's a pic taken with my digicam):


This is what happens: it cuts out all useful modes and switches to a "safe" 640x480 mode with the wrong refresh rate (this is the reason why my screen appears "stretched" in height); here is a portion of my Xorg.0.log:
Code:
...
(--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
(--) NVIDIA(0): DFP-1: Internal Single Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-1
(WW) NVIDIA(0): No valid modes for "1280x1024"; removing.
(WW) NVIDIA(0): No valid modes for "1024x768"; removing.
(WW) NVIDIA(0): No valid modes for "800x600"; removing.
(WW) NVIDIA(0): 
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):     "nvidia-auto-select".
(WW) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(**) NVIDIA(0): DPI set to (47, 44); computed from "DisplaySize" Monitor
(**) NVIDIA(0):     section option
(==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
...
I also tried to override those weird settings and activate a more useful mode 1024x768 with xrandr:
Code:
gunther@hell:~$ xrandr -v --newmode "1024x768"   56.00  1024 1072 1104 1184  768 771 775 790 +hsync -vsync
gunther@hell:~$ xrandr --addmode default 1024x768
gunther@hell:~$ xrandr --output default --mode 1024x768
xrandr: Configure crtc 0 failed
Anyway, the kernel module is loaded succesfully and even the 3D acceleration works; I checked that with glxinfo, glxgears, lsmod.

I tried also 96, 71, 173, 177, 1 series of the nVidia proprietary drivers. Each one (plus the one I am now workin on: 180.29) with my custom kernel (2.6.28.6 series) and the standard kernel shipped with my distro (2.6.18-6-amd64).

I do not attach my nvidia-bug-report.log; if anyone of you thinks that it can be useful in any way, I will provide it. It is attached my xorg.conf, here you can find the line
Code:
Option         "ModeValidation" "NoVertRefreshCheck, NoHorizSyncCheck, NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNon60HzDFPModes"
with I tried to override the mode validation on KDM startup.

Any help will be appreciated.
Thanks in advance!
Here are my pertinent sections:

Section "Device"
Identifier "Nvidia 8600 GTS"
Driver "nvidia" //needed if you're using latest 180...driver
VendorName "NVIDIA Corporation"
BoardName "gEfORCE 8600 GTS"
#BusID "PCI:0:2:0"
BusID "PCI:4:0:0"
VideoRam 262144
# Option "AperTexSize" "131,072"
# Option "XVideo" "true"
# Option "XAA" "true"
# Option "BackingStore" "true"
Option "AllowSHMPixmaps" "true"
EndSection

Section "Monitor"
Identifier "SC190"
ModelName "Sylvania SC190" // CRT panel
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Nvidia 8600 GTS"
Monitor "SC190"
DefaultDepth 24
Option "CustomEDID" "CRT-0:/etc/X11/edid.bin"
Option "TwinView" "0"
....
EndSection

First: Is your system a Digital Flat CRT?, CRT?, LCD?

Using the Nvidia-Settings acquire EDID:

http://www.nvnews.net/vbulletin/showthread.php?t=125693

I moved my edid.bin file as listed above.
mdriftmeyer is offline   Reply With Quote
Old 03-05-09, 05:24 PM   #10
dproduzioni
Registered User
 
Join Date: Feb 2009
Location: between Siena and Pisa
Posts: 8
Send a message via Skype™ to dproduzioni
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

Thanks, I'll try as soon as I can. I use an LCD screen, anyway, connected with a DVI cable.
My pertinent question is: if it fails to detect the correct mode trhu EDID, can I specify modes manually? It seems to override xorg.conf declarations.
dproduzioni is offline   Reply With Quote
Old 03-06-09, 08:33 AM   #11
mdriftmeyer
Registered User
 
Join Date: Feb 2009
Posts: 40
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

Here is the rest of my display modes:

Option "metamodes" "1600x1200_75 +0+0; 1600x1200 +0+0; 1280x1024 +0+0; 1280x960 +0+0; 1152x864 +0+0; 1024x768 +0+0; 832x624 +0+0; 800x600 +0+0; 720x400 +0+0; 640x480 +0+0"
SubSection "Display"
Depth 1
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection
mdriftmeyer is offline   Reply With Quote
Old 03-24-09, 10:25 AM   #12
dproduzioni
Registered User
 
Join Date: Feb 2009
Location: between Siena and Pisa
Posts: 8
Send a message via Skype™ to dproduzioni
Default Re: visual issues with nVidia proprietary drivers on Debian 64bit

GREAT!
All is working now. What I have changed is simply unplug DVI cable and replace it with VGA cable.
The question now is: can I save in some way EDID informations and use it falling back to DVI cable??
Thanks a lot.
dproduzioni is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Maximus Fires Up Visual Effects In Men in Black 3 News Archived News Items 0 06-26-12 06:00 PM
NVIDIA Drivers Receive Windows 8 Certification News Archived News Items 0 06-01-12 05:30 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Debian + Nvidia drivers, bad compilation Prodigy NVIDIA Linux 16 09-10-02 07:13 PM

All times are GMT -5. The time now is 05:23 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.