Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-06-09, 06:52 PM   #1
falolaf
Registered User
 
Join Date: Sep 2004
Posts: 40
Default 180.37: Allmost usable

Hi

I Have now tested 180.37 and for a couple of minutes it's allmost usable. But I have to go back to 180.18. Compared to the other released drivers > 180.18, it's now sometimes possible to kill X with ctrl+alt+bkspce (when the system freezes). That don't work at all with the others. The system still freezez very often so I can't use it for daily work.

There are sometimes screen corruptions with this driver, which I haven't seen previously. E.g. horizontal lines in firefox while scrolling.

I have posted dump-files with earlier drivers, but sadly I don't bother anymore.

openSUSE 11.1
KDE4.2
GeForce 7500LE
AMD Athlon X2 3800+

180.18 is solid like a rock.

/Anders
falolaf is offline   Reply With Quote
Old 03-06-09, 07:20 PM   #2
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: 180.37: Allmost usable

I noticed a strange behavior with firefox and the flashplayer plugin (64bit) this maybe is worst then 180.35
marchetto is offline   Reply With Quote
Old 03-06-09, 08:37 PM   #3
dragonagat
Registered User
 
Join Date: Jan 2009
Posts: 3
Default Re: 180.37: Allmost usable

Quote:
Originally Posted by falolaf View Post
Hi

I Have now tested 180.37 and for a couple of minutes it's allmost usable. But I have to go back to 180.18. Compared to the other released drivers > 180.18, it's now sometimes possible to kill X with ctrl+alt+bkspce (when the system freezes). That don't work at all with the others. The system still freezez very often so I can't use it for daily work.
/Anders
Try setting DontZap in your /etc/X11/xorg.conf :

Code:
Section "ServerFlags"
    Option "DontZap" "false"
EndSection
Setting to "true" disables "Ctrl+Alt+Bkspace", setting to false enables it.
dragonagat is offline   Reply With Quote
Old 03-07-09, 05:15 AM   #4
mkyral
Registered User
 
Join Date: Mar 2009
Posts: 14
Default Re: 180.37: Allmost usable

Quote:
Originally Posted by falolaf View Post
The system still freezez very often so I can't use it for daily work.

/Anders

I had the same problem, it always freezes several minutes after login to KDE4. I solved the problem by removing all special options from the nvidia section in xorg.conf.

Now it works without freeze and Device section contains only:
Code:
Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "GeForce 8400M GS"
        BusID       "PCI:1:0:0"
EndSection
mkyral is offline   Reply With Quote
Old 03-07-09, 07:21 AM   #5
pcxz
Registered User
 
Join Date: Jan 2005
Posts: 50
Default Re: 180.37: Allmost usable

Quote:
Originally Posted by mkyral View Post
I had the same problem, it always freezes several minutes after login to KDE4. I solved the problem by removing all special options from the nvidia section in xorg.conf.

Now it works without freeze and Device section contains only:
Code:
Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "GeForce 8400M GS"
        BusID       "PCI:1:0:0"
EndSection
Please ..post your xorg.conf ..thx
pcxz is offline   Reply With Quote
Old 03-07-09, 01:28 PM   #6
mkyral
Registered User
 
Join Date: Mar 2009
Posts: 14
Default Re: 180.37: Allmost usable

Quote:
Originally Posted by pcxz View Post
Please ..post your xorg.conf ..thx
I'm using xorg-server 1.5.3, so keyboard and mouse configuration is covered by hal.

Code:
marian@gool ~ $ cat /etc/X11/xorg.conf
Section "ServerLayout"                
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0     
EndSection                               

Section "Files"
        ModulePath   "/usr/lib64/xorg/modules"
        FontPath     "/usr/share/fonts/misc/" 
        FontPath     "/usr/share/fonts/TTF/"  
        FontPath     "/usr/share/fonts/OTF"   
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/100dpi/"
        FontPath     "/usr/share/fonts/75dpi/" 
EndSection                                     

Section "Module"
        Load  "xtrap"
        Load  "extmod"
        Load  "dri"   
#       Load  "GLcore"
        Load  "record"
#       Load  "glx"   
        Load  "dbe"   
        Load  "freetype"
        Load  "type1"   
EndSection              

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model" 
        Option       "DPI"   "96 x 96"
  Gamma   0.70  0.70  0.70  # created by KGamma
EndSection                                     

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"             
        ### [arg]: arg optional                                      
        #Option     "SWcursor"                  # [<bool>]           
        #Option     "HWcursor"                  # [<bool>]           
        #Option     "NoAccel"                   # [<bool>]           
        #Option     "ShadowFB"                  # [<bool>]           
        #Option     "UseFBDev"                  # [<bool>]           
        #Option     "Rotate"                    # [<str>]            
        #Option     "VideoKey"                  # <i>                
        #Option     "FlatPanel"                 # [<bool>]           
        #Option     "FPDither"                  # [<bool>]
        #Option     "CrtcNumber"                # <i>
        #Option     "FPScale"                   # [<bool>]
        #Option     "FPTweak"                   # <i>
        #Option     "DualHead"                  # [<bool>]
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "GeForce 8400M GS"
        BusID       "PCI:1:0:0"
#        Option      "DPMS"   "1"
#        Option      "NvAGP"  "1"
#        Option      "TripleBuffer" "True"
#        Option      "BackingStore" "True"
#        Option      "RenderAccel" "true"
#        Option      "AddARGBGLXVisuals" "True"
#        Option      "AllowGLXWithComposite" "True"
#        Option      "AllowIndirectPixmaps" "True"
#        Option      "FlatPanelProperties" "Scaling = Centered"
#        Option      "CursorShadow" "true"
#       Option      "PixmapCacheSize" "5000000"
#        Option      "OnDemandVBlankInterrupts" "True"
#        Option      "Coolbits" "1"
#        Option      "UseEvents" "False"
#       Option      "AllowSHMPixmaps" "0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection
mkyral is offline   Reply With Quote
Old 03-07-09, 04:29 PM   #7
quadtree
Registered User
 
Join Date: Jan 2009
Posts: 34
Default Re: 180.37: Allmost usable

180.37 has fixed all the signal-related problems that 180.35 gave me with mythtv.
quadtree is offline   Reply With Quote
Old 03-07-09, 04:36 PM   #8
NSLW
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: 180.37: Allmost usable

I've got Fedora 10 i386 installed. I'm using 180.37 drivers which are almost stable because after an hour or two there are the same problems as with 180.35 which means graphical corruptions and system freeze with hard reset. As desktop environment i use GNOME + CompizFusion. My gfx is 9600M GT

btw.
When i open up terminal and type init3 i get black screen and nothing is displayed, it looks like the screen is not working. If i change in "/etc/inittab" "id:5:initdefault:" to "id:3:initdefault:" and reboot then I'am in init 3 but I would like to do it without reboot. Anybody knows how to fix it?
NSLW is offline   Reply With Quote

Old 03-07-09, 05:15 PM   #9
thetoastman
Registered User
 
Join Date: Feb 2009
Posts: 7
Default Re: 180.37: Allmost usable

I'm also using Fedora 10 i386. I have a 7600GS AGP card which I've overclocked a bit. Resetting the clock to factory defaults does not change my observations.

This is the first 180.xx driver that's been usable. While I run Gnome (no desktop effects), I'll occasionally use KDE applications. None of previous 180.xx drivers would allow me to run KDE applications even in Gnome.

Performance is back up to slightly better than the 177.82 driver, as measured by glxgears.

Flash video seems much smoother in this release, although I've not done quantitative studies (frame drop rates via mplayer, etc.).

KDE unfortunately is completely unusable. If I move my mouse over the start menu plasmoid, X will immediately crash. Right-mouse anywhere, and X will immediately crash.

At one point I had KDE running under 177.82 with desktop effects enabled, but starting Firefox and right-mouse clicking to open a new tab would crash X. I turned off desktop effects, and now have not been able to use KDE.

One thing to note on all 177 and 180 drivers to date with AGP: they don't seem to support SBA or fast writes. This is odd, since the card and host bridge support these features. Also, on the exact same system running XP/SP3 (dual boot, separate disks), SBA and fast writes are enabled.

All in all, progress seems to have been made. Now if KDE would work and AGP would work properly (fast writes, SBA), this old system might still have some life left in it.

Details follows (nvidia-bug-report.log and agp-info.txt) for those interested.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (29.8 KB, 104 views)
File Type: txt agp-info.txt (531 Bytes, 87 views)
thetoastman is offline   Reply With Quote
Old 03-07-09, 05:58 PM   #10
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: 180.37: Allmost usable

Quote:
Originally Posted by thetoastman View Post
KDE unfortunately is completely unusable. If I move my mouse over the start menu plasmoid, X will immediately crash. Right-mouse anywhere, and X will immediately crash.
Disable BackingStore or get a more recent X Server, it is broken up to 1.6 and leads to exactly this crash.

Fuchs
NvFuchs is offline   Reply With Quote
Old 03-07-09, 07:07 PM   #11
thetoastman
Registered User
 
Join Date: Feb 2009
Posts: 7
Default Re: 180.37: Allmost usable

Thanks for the BackingStore information.

And yes, Fedora 10 is at 1.5.3 of the Xorg xserver. The AGP issues remain (of course).

I'll see how stable various desktop effects are with this arrangement (and the potential hit to GL performance).

Thanks again.
thetoastman is offline   Reply With Quote
Old 03-07-09, 07:13 PM   #12
twbos
Registered User
 
Join Date: Jul 2008
Posts: 14
Default Re: 180.37: Allmost usable

Uh, I was getting the same crash with 1.5.3 and 180.37, and it usually dumps this:
Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4dc27e]
1: /usr/bin/X(xf86SigHandler+0x39) [0x46ae3e]
2: /lib/libc.so.6 [0x7f9f303d5270]
3: /usr/bin/X(miValidateTree+0x2a5) [0x4cdc4c]
4: /usr/lib64/xorg/modules/drivers//nvidia_drv.so [0x7f9f2dfd0f7d]
5: /usr/bin/X(MapWindow+0x2b5) [0x43560a]
6: /usr/bin/X(ProcMapWindow+0x46) [0x4476c3]
7: /usr/bin/X(Dispatch+0x34d) [0x447e42]
8: /usr/bin/X(main+0x442) [0x4309bd]
9: /lib/libc.so.6(__libc_start_main+0xf4) [0x7f9f303c25e4]
10: /usr/bin/X [0x42fe59]

Is this the backing store error ? I now solved all problems by going back to xorg-server 1.3.0, but if I of course could get to 1.5.3 again, with backing store disabled, that would be great.
twbos is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:13 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.