Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-09-09, 09:01 AM   #1
herr_tichy
Registered User
 
Join Date: Mar 2009
Posts: 6
Default 8800 gtx/Phenom X4/Linux x64 freezes on startup

Hello forum

I have a freshly installed version of Ubuntu 8.10 64bit running on the hardware above. Connected are two screens, one TFT using DVI, one TFT using a DVI-VGA adapter. The error occurs with the nvidia packages from Ubuntu (173, 177 and 180) as well as with the newest .run package from NVidia. That was the last thing I've tried and yes, I did remove the Ubuntu packages before installing it

The hardware itself runs fine under Windows XP. I did some excessive stress testing using benchmarks - the CPU temperature never exceeds 40C (104F) while the GPU never exceeds 66C (150F), so I assume, we can rule out overheating/stability issues.

Under Linux, the hardware runs fine with the nv driver. Dual-screen, video playback - everything works, apart from 3D acceleration, of course.

When I start X with the nvidia driver, the machine becomes extremely sluggish. I can't switch to a local text-console, but I can still log in via ssh - although it takes up to 50 seconds, before the password prompt appears. It's so sluggish, that when pinging the machine via the local LAN, it looks like this:

--- 192.168.1.10 ping statistics ---
45 packets transmitted, 40 received, 11% packet loss, time 44036ms
rtt min/avg/max/mdev = 70.165/3302.336/6645.146/1928.903 ms, pipe 7

I did manage to log in via ssh and generate the nvidia bug report - although it took ages, because every keystroke only shows up after 10 seconds or so - I've scanned through the file and I assume, for now there's nothing else I should attach, because it seems to contain the kernel log and almost everything else I deem important so far. Frankly, I'm not even sure, where to start looking for the error - anybody help?

Thanks!

nvidia-bug-report.log @ Ubuntu-pastebin
Attached Files
File Type: zip nvidia-bug-report.log.zip (32.2 KB, 38 views)
herr_tichy is offline   Reply With Quote
Old 03-09-09, 06:03 PM   #2
herr_tichy
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Re: 8800 gtx/Phenom X4/Linux x64 freezes on startup

I've just tried building my own kernel with the latest stable source from kernel.org - same result as above.
herr_tichy is offline   Reply With Quote
Old 03-09-09, 07:30 PM   #3
jcornwall
Registered User
 
Join Date: Aug 2007
Location: Austin, TX
Posts: 120
Default Re: 8800 gtx/Phenom X4/Linux x64 freezes on startup

I can't fix this for you but I can point to the error in your log:

Quote:
[ 5090.613514] BUG: soft lockup - CPU#3 stuck for 61s! [scsi_eh_4:2206]
...
[ 5090.613518] RIP: 0010:[<ffffffff8021a517>] [<ffffffff8021a517>] native_read_tsc+0x7/0x30
...
[ 5090.613518] <IRQ> [<ffffffff803ab93c>] ? delay_tsc+0x4c/0x90
[ 5090.613518] [<ffffffffa0d16b10>] ? _nv006991rm+0x0/0xaf [nvidia]
[ 5090.613518] [<ffffffff803aba13>] ? __const_udelay+0x53/0x60
[ 5090.613518] [<ffffffffa10cb56a>] ? os_delay+0x1fa/0x290 [nvidia]
jcornwall is offline   Reply With Quote
Old 03-09-09, 09:12 PM   #4
herr_tichy
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Re: 8800 gtx/Phenom X4/Linux x64 freezes on startup

Yup, thanks - I'd already nailed the problem down to that, but thanks anyways. After googling around a bit, it seems there are more people with this problem and that only AMD platforms are affected (haven't found any bugreport on Intel anyways). This is probably a bug with the kernel module, that NVidia has to fix
herr_tichy is offline   Reply With Quote
Old 03-10-09, 09:30 AM   #5
herr_tichy
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Re: 8800 gtx/Phenom X4/Linux x64 freezes on startup

Hm. As nobody seems to have any idea how to fix this and NVidia support hasn't reacted in any way to my bug report to linux-bugs@nvidia.com, I assume I'm going to start browsing eBay for an equal ATI-card
herr_tichy is offline   Reply With Quote
Old 03-12-09, 10:32 AM   #6
herr_tichy
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Re: 8800 gtx/Phenom X4/Linux x64 freezes on startup

So, I have replaced the 8800GTX with an Ati HD3870 and things work just fine. And with the radeonhd-project making huge progress, even full open-source 3d support is on the horizon
herr_tichy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:04 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.