Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-09-09, 10:44 AM   #1
jurjur
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Mplayer Vdpau error

Hi ,

I am trying to play a x264 video with mplayer and vdpau , and with other video i have the same response ........

Code:
mplayer -vo vdpau -vc ffh264vdpau Lost.ts          
MPlayer dev-SVN-r28348-4.3.2 (C) 2000-2009 MPlayer Team                     
CPU: Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz (Family: 6, Model: 15, Stepping: 13)                                                                 
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1                  
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2                      

Playing Lost.ts.
TS file format detected.
VIDEO H264(pid=512) AUDIO A52(pid=660) NO SUBS (yet)!  PROGRAM N. 1
FPS seems to be: 25.000000                                         
==========================================================================
Forced video codec: ffh264vdpau                                           
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family          
[VD_FFMPEG] VDPAU accelerated codec.                                      
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))    
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52                  
Using SSE optimized IMDCT transform                                       
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 1920 x 1080 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 H.264 HIGH VDPAU acceleration
[ASPECT] Warning: No suitable new res found!
[ASPECT] Warning: No suitable new res found!
[ASPECT] Warning: No suitable new res found!
Error 23 at libvo/vo_vdpau.c:749
jurjur is offline   Reply With Quote
Old 03-09-09, 11:28 AM   #2
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Mplayer Vdpau error

Quote:
Originally Posted by jurjur View Post
I am trying to play a x264 video with mplayer and vdpau , and with other video i have the same response ........
Please test with latest MPlayer svn.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 03-09-09, 04:53 PM   #3
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Mplayer Vdpau error

You are most likely running out of video memory. It's possible that depending on exactly why, using MPlayer SVN will help.
Stephen Warren is offline   Reply With Quote
Old 03-09-09, 05:13 PM   #4
jurjur
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Re: Mplayer Vdpau error

Quote:
Originally Posted by Stephen Warren View Post
You are most likely running out of video memory. It's possible that depending on exactly why, using MPlayer SVN will help.
I install mplayer svn , and now have sound , but black screen:

Code:
Error while decoding frame!                                                  
[h264_vdpau @ 0xc3f980]non-existing SPS 32 referenced in buffering period
[vdpau] Error when calling vdp_video_surface_create: An invalid handle value was provided.                                                                
[vdpau] no surfaces available in get_image                                   
vf_get_image: Tried to allocate a format that can not be allocated!          
[h264_vdpau @ 0xc3f980]get_buffer() failed (-1 0 0 (nil))                    
[h264_vdpau @ 0xc3f980]decode_slice_header error                             
[h264_vdpau @ 0xc3f980]no frame!                                             
Error while decoding frame!                                                  


MPlayer interrupted by signal 2 in module: sleep_timer
[vdpau] Error when calling vdp_video_surface_destroy: An invalid handle value was provided.                                                               
[vdpau] Error when calling vdp_video_surface_destroy: An invalid handle value was provided.                                                               
[vdpau] Error when calling vdp_video_mixer_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_presentation_queue_destroy: An invalid handlevalue was provided.
[vdpau] Error when calling vdp_presentation_queue_target_destroy: An invalidhandle value was provided.
[vdpau] Error when calling vdp_output_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_output_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_output_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_device_destroy: An invalid handle value was provided.

Exiting... (Quit)
other file .....

Code:
[vdpau] Error when calling vdp_video_surface_create: An invalid handle value was provided.                                                                
[vdpau] no surfaces available in get_image                                   
vf_get_image: Tried to allocate a format that can not be allocated!          
[h264_vdpau @ 0xc3f980]get_buffer() failed (-1 0 0 (nil))                    
[h264_vdpau @ 0xc3f980]decode_slice_header error                             
[h264_vdpau @ 0xc3f980]no frame!                                             
Error while decoding frame!                                                  

Too many audio packets in the buffer: (4097 in 6292992 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.   
A:   0.3 V:   0.0 A-V:  0.341 ct:  0.000   0/  0 ??% ??% ??,?% 2871 0 
[vdpau] Error when calling vdp_video_surface_destroy: An invalid handle value was provided.                                                               
[vdpau] Error when calling vdp_video_surface_destroy: An invalid handle value was provided.                                                               
[vdpau] Error when calling vdp_video_mixer_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_presentation_queue_destroy: An invalid handlevalue was provided.
[vdpau] Error when calling vdp_presentation_queue_target_destroy: An invalidhandle value was provided.
[vdpau] Error when calling vdp_output_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_output_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_output_surface_destroy: An invalid handle value was provided.
[vdpau] Error when calling vdp_device_destroy: An invalid handle value was provided.
My card has 256mb of memory
jurjur is offline   Reply With Quote
Old 03-09-09, 05:21 PM   #5
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Mplayer Vdpau error

It looks like ffmpeg, Mplayer, or VDPAU are having problems with the streams you're playing. Can you please provide samples. That will help various people debug the issue.
Stephen Warren is offline   Reply With Quote
Old 03-09-09, 05:32 PM   #6
jurjur
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Re: Mplayer Vdpau error

Quote:
Originally Posted by Stephen Warren View Post
Can you please provide samples
What have i to do ??? i am not certain that mean provide samples
jurjur is offline   Reply With Quote
Old 03-09-09, 05:33 PM   #7
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Mplayer Vdpau error

Quote:
Originally Posted by jurjur View Post
I install mplayer svn , and now have sound , but black screen:
Please confirm that you did:
svn up && make distclean && ./configure && make
That svn di . libavutil libavformat libavcodec shows no output
That the videos in question play fine with -vc ffh264
Then please try with -v and post the complete output (that is including your command line until the next prompt)
And a link to the sample (or upload to ftp://ffmpeg.org/MPlayer/incoming/ which is write-only) may also help!

Carl Eugen
cehoyos is offline   Reply With Quote
Old 03-09-09, 06:13 PM   #8
jurjur
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Re: Mplayer Vdpau error

Quote:
Originally Posted by cehoyos View Post
Please confirm that you did:
svn up && make distclean && ./configure && make
That svn di . libavutil libavformat libavcodec shows no output
That the videos in question play fine with -vc ffh264
Then please try with -v and post the complete output (that is including your command line until the next prompt)
And a link to the sample (or upload to ftp://ffmpeg.org/MPlayer/incoming/ which is write-only) may also help!

Carl Eugen
I verified the svn
Code:
svn up && make distclean && ./configure && make
That svn di . libavutil libavformat libavcodec shows no output

i play video fine with
Code:
-vc ffh264
This is my complete output :

Code:
/usr/local/bin/mplayer -vo vdpau -vc ffh264vdpau -v  beta.mkv                                                  
MPlayer SVN-r28924-4.3.3 (C) 2000-2009 MPlayer Team                          
CPU vendor name: GenuineIntel  max cpuid level: 10                           
CPU: Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz (Family: 6, Model: 15, Stepping: 13)                                                                 
extended cpuid-level: 8                                                      
extended cache-info: 134242368                                               
Detected cache-line size is 64 bytes                                         
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 1       
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2 SSSE3 CMOV           
get_path('codecs.conf') -> '/home/gentoo/.mplayer/codecs.conf'               
Reading /home/gentoo/.mplayer/codecs.conf: Can't open '/home/gentoo/.mplayer/codecs.conf': No such file or directory                                      
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory                                    
Using built-in default codecs.conf.                                          
Configuration:                                                               
CommandLine: '-vo' 'vdpau' '-vc' 'ffh264vdpau' '-v' 'Beta.mkv'         
init_freetype                                                                
get_path('font/font.desc') -> '/home/gentoo/.mplayer/font/font.desc'         
font: can't open file: /home/gentoo/.mplayer/font/font.desc                  
font: can't open file: /usr/local/share/mplayer/font/font.desc               
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay                     
get_path('fonts') -> '/home/gentoo/.mplayer/fonts'                           
Using nanosleep() timing                                                     
get_path('input.conf') -> '/home/gentoo/.mplayer/input.conf'                 
Can't open input config file /home/gentoo/.mplayer/input.conf: No such file or directory                                                                  
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory                                                                 
Falling back on default (hardcoded) input config                             
get_path('Beta.mkv.conf') -> '/home/gentoo/.mplayer/Beta.mkv.conf'                                                                            

Playing Beta
get_path('sub/') -> '/home/gentoo/.mplayer/sub/'
[file] File size is 1294181328 bytes            
STREAM: [file] Beta.mkv                                                
STREAM: Description: File                                                    
STREAM: Author: Albeu                                                        
STREAM: Comment: based on the code from ??? (probably Arpi)                  
LAVF_check: Matroska file format                                             
Checking for YUV4MPEG2                                                       
ASF_check: not ASF guid!                                                     
Checking for REAL                                                            
Checking for SMJPEG                                                          
[mkv] Found the head...                                                      
[mkv] + a segment...                                                         
[mkv] /---- [ parsing seek head ] ---------                                  
[mkv] /---- [ parsing seek head ] ---------                                  
[mkv] \---- [ parsing seek head ] ---------                                  
[mkv] /---- [ parsing cues ] -----------                                     
[mkv] \---- [ parsing cues ] -----------                                     
[mkv] \---- [ parsing seek head ] ---------                                  
[mkv] |+ segment information...                                              
[mkv] | + timecode scale: 1000000                                            
[mkv] | + duration: 2506.720s                                                
[mkv] |+ segment tracks...                                                   
[mkv] | + a track...                                                         
[mkv] |  + Track number: 1                                                   
[mkv] |  + Track type: Video                                                 
[mkv] |  + Default flag: 1                                                   
[mkv] |  + Codec ID: V_MPEG4/ISO/AVC                                         
[mkv] |  + CodecPrivate, length 39                                           
[mkv] |  + Default duration: 41.708ms ( = 23.976 fps)                        
[mkv] |  + Language: eng                                                     
[mkv] |  + Name: Beta                                                  
[mkv] |  + Video track                                                       
[mkv] |   + Pixel width: 1280                                                
[mkv] |   + Pixel height: 720                                                
[mkv] |   + Display width: 16                                                
[mkv] |   + Display height: 9                                                
[mkv] | + a track...                                                         
[mkv] |  + Track number: 2                                                   
[mkv] |  + Track type: Audio                                                 
[mkv] |  + Default flag: 1                                                   
[mkv] |  + Codec ID: A_AC3                                                   
[mkv] |  + Default duration: 32.000ms ( = 31.250 fps)                        
[mkv] |  + Language: spa                                                     
[mkv] |  + Name: beta                                         
[mkv] |  + Audio track                                                       
[mkv] |   + Sampling frequency: 48000.000000                                 
[mkv] |   + Channels: 2                                                      
[mkv] | + a track...                                                         
[mkv] |  + Track number: 3                                                   
[mkv] |  + Track type: Audio                                                 
[mkv] |  + Default flag: 0                                                   
[mkv] |  + Codec ID: A_AC3                                                   
[mkv] |  + Default duration: 32.000ms ( = 31.250 fps)                        
[mkv] |  + Language: eng                                                     
[mkv] |  + Name: Ingles Beta                                          
[mkv] |  + Audio track                                                       
[mkv] |   + Sampling frequency: 48000.000000                                 
[mkv] |   + Channels: 6                                                      
[mkv] | + a track...                                                         
[mkv] |  + Track number: 4                                                   
[mkv] |  + Track type: Subtitle                                              
[mkv] |  + Default flag: 1                                                   
[mkv] |  + Codec ID: S_TEXT/UTF8                                             
[mkv] |  + Language: spa                                                     
[mkv] |  + Name: Beta                                         
[mkv] | + a track...                                                         
[mkv] |  + Track number: 5                                                   
[mkv] |  + Track type: Subtitle                                              
[mkv] |  + Default flag: 0                                                   
[mkv] |  + Codec ID: S_TEXT/UTF8                                             
[mkv] |  + Language: eng                                                     
[mkv] |  + Name: Inlges Beta                                           
[mkv] |+ found cluster, headers are parsed completely :)                     
==> Found video stream: 1                                                    
[mkv] Aspect: 1.777778                                                       
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC) "Beta", -vid 0               
==> Found audio stream: 2                                                    
[mkv] Track ID 2: audio (A_AC3) "Español Beta", -aid 0, -alang spa    
==> Found audio stream: 3                                                    
[mkv] Track ID 3: audio (A_AC3) "Ingles Beta", -aid 1, -alang eng      
[mkv] Track ID 4: subtitles (S_TEXT/UTF8) "Español Beta", -sid 0, -slang spa                                                                       
[mkv] Track ID 5: subtitles (S_TEXT/UTF8) "Inlges Beta", -sid 1, -slang eng                                                                         
[mkv] Will play video track 1.                                               
Matroska file format detected.                                               
VIDEO:  [avc1]  1280x720  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)       
[V] filefmt:31  fourcc:0x31637661  size:1280x720  fps:23.976  ftime:=0.0417  
get_path('sub/') -> '/home/gentoo/.mplayer/sub/'                             
X11 opening display: :0.0                                                    
vo: X11 color mask:  FFFFFF  (R:FF0000 G:FF00 B:FF)                          
vo: X11 running at 1280x800 with depth 24 and 32 bpp (":0.0" => local display)                                                                            
[x11] Detected wm supports NetWM.                                            
[x11] Detected wm supports FULLSCREEN state.                                 
[x11] Detected wm supports ABOVE state.                                      
[x11] Detected wm supports BELOW state.                                      
[x11] Detected wm supports STAYS_ON_TOP state.                               
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X atoms                                                                          
==========================================================================   
Forced video codec: ffh264vdpau                                              
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family             
[VD_FFMPEG] XVMC-accelerated MPEG-2.                                         
INFO: libavcodec init OK!                                                    
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))       
==========================================================================   
==========================================================================   
Opening audio decoder: [liba52] AC3 decoding with liba52                     
dec_audio: Allocating 3840 bytes for input buffer.                           
dec_audio: Allocating 6144 + 65536 = 71680 bytes for output buffer.          
Using SSE optimized IMDCT transform                                          
AC3: 2.0 (stereo)  48000 Hz  384.0 kbit/s                                    
A52 flags before a52_frame: 0x2A                                             
A52 flags after a52_frame: 0x2
jurjur is offline   Reply With Quote

Old 03-09-09, 06:13 PM   #9
jurjur
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Re: Mplayer Vdpau error

Code:
Using MMX optimized resampler                                                
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)       
Selected audio codec: [a52] afm: liba52 (AC3-liba52)                         
==========================================================================   
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...           
[libaf] Adding filter dummy                                                  
[dummy] Was reinitialized: 48000Hz/2ch/s16le                                 
[dummy] Was reinitialized: 48000Hz/2ch/s16le                                 
Trying every known audio driver...                                           
ao2: 48000 Hz  2 chans  s16le                                                
audio_setup: using '/dev/dsp' dsp device                                     
audio_setup: using '/dev/mixer' mixer device                                 
audio_setup: using 'pcm' mixer device                                        
audio_setup: sample format: s16le (requested: s16le)                         
audio_setup: using 2 channels (requested: 2)                                 
audio_setup: using 48000 Hz samplerate (requested: 48000)                    
audio_setup: frags:  16/16  (4096 bytes/frag)  free:  65536                  
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)                             
AO: Description: OSS/ioctl audio output                                      
AO: Author: A'rpi                                                            
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...    
[dummy] Was reinitialized: 48000Hz/2ch/s16le                                 
[dummy] Was reinitialized: 48000Hz/2ch/s16le                                 
Starting playback...                                                         
Increasing filtered audio buffer size from 0 to 65536                        
[VD_FFMPEG] XVMC-accelerated MPEG-2.                                         
[ffmpeg] aspect_ratio: 0.000000                                              
VDec: vo config request - 1280 x 720 (preferred colorspace: H.264 VDPAU acceleration)                                                                     
Trying filter chain: vo                                                      
VDec: using H.264 VDPAU acceleration as output csp (no 0)                    
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.                 
VO Config (1280x720->1280x720,flags=0,'MPlayer',0x1DC80003)                  
VO: [vdpau] 1280x720 => 1280x720 H.264 VDPAU acceleration                    
VO: Description: VDPAU with X11                                              
VO: Author: Rajib Mahapatra <rmahapatra@nvidia.com> and others               
*** [vo] Direct Rendering (slices) mp_image_t, 1280x720x0bpp RGB packed, 0 bytes                                                                          
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[h264_vdpau @ 0xc3f8c0]no picture                                            
*** [vo] Direct Rendering (slices) mp_image_t, 1280x720x0bpp RGB packed, 0 bytes                                                                          
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[h264_vdpau @ 0xc3f8c0]no picture 
*** [vo] Direct Rendering (slices) mp_image_t, 1280x720x0bpp RGB packed, 0 bytes                                                                          
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
get_path('subfont.ttf') -> '/home/gentoo/.mplayer/subfont.ttf'               
New_Face failed. Maybe the font path is wrong.                               
Please supply the text font file (~/.mplayer/subfont.ttf).                   
subtitle font: load_sub_face failed.                                         
get_path('subfont.ttf') -> '/home/gentoo/.mplayer/subfont.ttf'               
New_Face failed. Maybe the font path is wrong.                               
Please supply the text font file (~/.mplayer/subfont.ttf).                   
subtitle font: load_sub_face failed.
*** [vo] Direct Rendering (slices) mp_image_t, 1280x720x0bpp RGB packed, 0 bytes                                                                          
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
get_path('subfont.ttf') -> '/home/gentoo/.mplayer/subfont.ttf'               
New_Face failed. Maybe the font path is wrong.                               
Please supply the text font file (~/.mplayer/subfont.ttf).                   
subtitle font: load_sub_face failed.                                         
get_path('subfont.ttf') -> '/home/gentoo/.mplayer/subfont.ttf'               
New_Face failed. Maybe the font path is wrong.                               
Please supply the text font file (~/.mplayer/subfont.ttf).                   
subtitle font: load_sub_face failed.                                         
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
*** [vo] Direct Rendering (slices) mp_image_t, 1280x720x0bpp RGB packed, 0 bytes                                                                          
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.                        
Uninit audio filters... 0.006 ct:  0.000   0/  0 34%  0%  0.9% 5 0
[libaf] Removing filter dummy
Uninit audio: liba52
Uninit video: ffmpeg
vo: uninit ...

Exiting... (Quit)
The rest of the output

I am playing popular and standar mkv videos
jurjur is offline   Reply With Quote
Old 03-09-09, 06:16 PM   #10
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Mplayer Vdpau error

Disregard statement that ffmpeg/MPlayer/VPDAU may be having problems with the files you're trying to play. I was confusing this with another thread. It does look like you simply don't have enough free video RAM.
Stephen Warren is offline   Reply With Quote
Old 03-09-09, 06:22 PM   #11
jurjur
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Re: Mplayer Vdpau error

Quote:
Originally Posted by Stephen Warren View Post
Disregard statement that ffmpeg/MPlayer/VPDAU may be having problems with the files you're trying to play. I was confusing this with another thread. It does look like you simply don't have enough free video RAM.
I have another card 9400 GT with 1 giga of ram , and play fine (the same videos) but when "fasters movings" happen it do "freezes" .
The problematic card is a 8400m GT .
jurjur is offline   Reply With Quote
Old 03-09-09, 06:51 PM   #12
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Mplayer Vdpau error

Quote:
Originally Posted by jurjur View Post
Code:
[vdpau] Failed creating VDPAU decoder: The system does not have enough resources to complete the requested operation at this time.
Not much we can do. The decoder is created with the necessary number of reference frames to decode the stream. If not enough memory for the reference frames is available, the creation fails.
I added additional output to mplayer svn, so it tells now how many reference frames are needed.

Carl Eugen
cehoyos is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
295.40 295 cannot be compiled on 3.2 kernel delta32 NVIDIA Linux 4 05-27-12 09:47 PM
RPM Source problems LaoTzuTao NVIDIA Linux 10 01-19-03 05:15 AM
Mandrake 9 and nVidia drivers HunterA3 NVIDIA Linux 9 10-09-02 02:54 AM
Mandrake 8.2 Nvidia src.rpm problems Mr_Malcontent NVIDIA Linux 8 09-11-02 09:53 PM

All times are GMT -5. The time now is 07:50 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.