Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-14-09, 03:00 AM   #1
cova
Registered User
 
Join Date: Mar 2005
Posts: 25
Default 185.13 possible bug

I've tried 185.13 release, and I got some problems just after firing up xorg:
- mouse is slugghis and the cursor moves with high delay
- an IRQ problem quickly appeared on dmesg log.
- keyboard started to act in weird ways: keys repeated or not showed, delays and so on.
It seems that the usb layer got hit by this irq issue:

NVRM: loading NVIDIA UNIX x86_64 Kernel Module 185.13 Fri Mar 13 02:47:10 PST 2009
irq 21: nobody cared (try booting with the "irqpoll" option)
Pid: 0, comm: swapper Tainted: P 2.6.28.7 #3
Call Trace:
<IRQ> [<ffffffffa0f0d99a>] nv_kern_isr+0x2a/0x70 [nvidia]
[<ffffffff80267f0e>] __report_bad_irq+0x1e/0x90
[<ffffffff80268118>] note_interrupt+0x198/0x1e0
[<ffffffff80268a05>] handle_fasteoi_irq+0xd5/0x100
[<ffffffff8020e58a>] do_IRQ+0xca/0x120
[<ffffffff8020bdc6>] ret_from_intr+0x0/0xa
<EOI> [<ffffffff8021357a>] default_idle+0x3a/0x40
[<ffffffff80213694>] c1e_idle+0x34/0x100
[<ffffffff802551a9>] __atomic_notifier_call_chain+0x19/0x50
[<ffffffff8020a9e4>] cpu_idle+0x74/0xb0
handlers:
[<ffffffffa0033760>] (usb_hcd_irq+0x0/0x70 [usbcore])
[<ffffffffa0f0d970>] (nv_kern_isr+0x0/0x70 [nvidia])
Disabling IRQ #21

report attached
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (32.9 KB, 70 views)
cova is offline   Reply With Quote
Old 03-14-09, 08:55 PM   #2
hyfans
Registered User
 
Join Date: Apr 2005
Posts: 75
Default Re: 185.13 possible bug

how about using MSI interrupt system?
hyfans is offline   Reply With Quote
Old 03-14-09, 09:29 PM   #3
cova
Registered User
 
Join Date: Mar 2005
Posts: 25
Default Re: 185.13 possible bug

Quote:
Originally Posted by hyfans View Post
how about using MSI interrupt system?

Well, MSI is already enabled in kernel config, could you give me some hint about what is your suggestion?
cova is offline   Reply With Quote
Old 03-14-09, 09:45 PM   #4
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default Re: 185.13 possible bug

Try adding "options nvidia NVreg_EnableMSI=1" to your /etc/modprobe.d/options file (if you run a Debian/Ubuntu like system)
thefirstm is offline   Reply With Quote
Old 03-14-09, 10:08 PM   #5
hyfans
Registered User
 
Join Date: Apr 2005
Posts: 75
Default Re: 185.13 possible bug

#4 is what i'm using now.

mouse sluggh? i have this when there is sourcecode compiling in the background, but i think it's a common problem with xorg.
hyfans is offline   Reply With Quote
Old 03-15-09, 06:20 AM   #6
cova
Registered User
 
Join Date: Mar 2005
Posts: 25
Default Re: 185.13 possible bug

ok, thanks to suggestions I've set MSI for nvidia. This fixed the irq lost (even I think that it shouldn't happen anyway) and now I'm running 185.13.
Problems are far from gone, nevertheless:
- I've seen a "ohci disabled" error, never happened before 185.13, and keyboard/mouse was gone. It happened only once, so I can't report further on this.
- with MSI enabled, turning on desktop effect in kde 4.2.1 causes immediate freeze with screen messed up; (freeze in this case means not even ssh or ping answers). Interesting enough, MSI setting changed behaviour for 180.37 also: with 180, turning on desktop effects caused, after some time and windows resizing, the infamous Xvid error and a Xorg lockup. with MSI on, 180.37 locks up as described above for 185.13.
A common behaviour for all those issues is that the USB subsystem is hit (keyboard acting in a weird way, usb pendrives reporting errors and so on happens on my box when nvidia driver starts to act in a strange way), so it seems that nvidia drivers messes up (180,185) with interrupts handling or something like that.

Thanks for the MSI suggestion.

ps: mouse slugginess was not due to machine load
cova is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
I got a computer bug!!! sillyeagle General Hardware 16 06-05-12 02:44 AM
GLX bug? (1.0-3123) marc NVIDIA Linux 2 09-21-02 04:58 PM
athlon agp bug?? crazyowl NVIDIA Linux 17 08-28-02 10:13 PM
Antialiasing bug in 31.00 drivers? Mark_fox NVIDIA Windows Graphics Drivers 7 08-26-02 02:48 PM
TwinView & Console bug topman NVIDIA Linux 3 08-16-02 09:32 AM

All times are GMT -5. The time now is 01:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.