Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-15-09, 04:31 AM   #1
mlauss
Registered User
 
Join Date: Aug 2007
Posts: 43
Default 185.13: vdpau: mplayer -vo vdpau immediately kills X

The title says it all: "mplayer -vo vdpau" kills X and leaves a Xid in the kernel logs.
(185.13, x64, 8800gt, mplayer svn, xorg git sources).
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (31.8 KB, 71 views)
mlauss is offline   Reply With Quote
Old 03-15-09, 12:05 PM   #2
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: 185.13: vdpau: mplayer -vo vdpau immediately kills X

for the time being come back to Xorg 1.5 series - alot of people have problems with nVidia drivers and Xorg 1.6
__________________
  • Linux Debian Sid x86_64/ 3.2.0
  • Lenovo T61p
  • NVIDIA driver 295.33
  • Xorg/XServer 7.6+12/1.11.4
  • GNOME 3.2.2
dk75 is offline   Reply With Quote
Old 03-16-09, 04:13 PM   #3
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: 185.13: vdpau: mplayer -vo vdpau immediately kills X

I think these problems aren't related to VDPAU itself, but more some code path that MPlayer is triggering
A few questions:

Are you running a compositing manager (compiz, kwin, ...)? What happens if you turn that off?

I see you have the Composite X extension enabled. Does the problem still happen if you turn it off?

What if you use SW decoding in MPlayer (don't use a -vc option); is the problem still there?

What if you use SW decoding and Xv/X11 output (e.g. "-vo xv" or "-vo x11").

Finally, can you run MPlayer (with VDPAU -vo/-vc options) from an SSH session, and follow the instructions in the sticky on reporting VDPAU problems; it's possible that VDPAU will print some more detailed error messages in this case.
Stephen Warren is offline   Reply With Quote
Old 03-17-09, 11:19 AM   #4
mlauss
Registered User
 
Join Date: Aug 2007
Posts: 43
Default Re: 185.13: vdpau: mplayer -vo vdpau immediately kills X

I believe this is an X issue; I currently don't have access to the machine in question until the
weekends; however my work machine with otherwise identical hw/sw (kde4 w. effects enabled,but
xorg-server-1.5) doesn't exhibit this. Will confirm later, but I'm 99% certain this is a bad interaction
between xorg-git and the nvidia drivers.

EDIT: Stephen: "-vo x11" or "-vo xv" work fine; simply playing any kind of video with -vo vdpau kills X
(the last thing I see is the mplayer [ASPECT] line.
mplayer -vo vdpau video.mpg -> instant death
mplayer -vo xv -vc ffh264hdpau video.mkv -> lots of vdpau debug messages, no video, but no X death
)
mlauss is offline   Reply With Quote
Old 03-21-09, 07:58 AM   #5
mlauss
Registered User
 
Join Date: Aug 2007
Posts: 43
Default Re: 185.13: vdpau: mplayer -vo vdpau immediately kills X

Okay, here's more info:

(xorg git as of 21-march-09 12:00 CET)

- doesn't happen on non-compositing wm's like fluxbox
- mplayers trace (attached) shows this:

X: symbol lookup error: /usr/lib64/xorg/modules/drivers/nvidia_drv.so: undefined symbol: CreateUnclippedWinSize

which is I assume the reason X is killed.

Thanks!
Attached Files
File Type: txt 185.13-mplayercrashlog.txt (6.9 KB, 191 views)
mlauss is offline   Reply With Quote
Old 03-21-09, 11:33 PM   #6
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: 185.13: vdpau: mplayer -vo vdpau immediately kills X

I'm not sure why X is even letting the NVIDIA driver load with unresolved symbols. I think the symbol will get value 0 in this case, and is probably called, and as you say leading to the crash.
Stephen Warren is offline   Reply With Quote
Old 03-23-09, 01:30 AM   #7
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 185.13: vdpau: mplayer -vo vdpau immediately kills X

The removal of this function was an ABI change in the X server, and it will need to either be reverted or the ABI version bumped to 6.0. I'll see if I can update the driver to not use that function, but in the meantime, please use a supported X server version.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.