Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-14-09, 12:32 AM   #1
ottdmk
Registered User
 
Join Date: Feb 2009
Posts: 3
Default Hoping for help with KDE 4.2

Hi,

I've got a GeForce 7300 SE card in a FreeBSD 7.1-RELEASE i386 computer. I'm running xorg-server-1.5.3_5,1 with nvidia-driver 180.29.

My problem is with KWin in KDE 4.2. No matter what I do, I can't seem to get Desktop Effects running. Which is really, really irritating, because it was definitely working in KDE 4.1.4.

I was hoping someone here might be able to advise me on whether or not I could tweak some settings to make KWin realize that my card is more than capable of handling Desktop Effects. (3D performance is actually quite good.)

Thanks,
DMK
ottdmk is offline   Reply With Quote
Old 02-14-09, 07:16 AM   #2
Vla
Registered User
 
Join Date: Aug 2006
Posts: 26
Default Re: Hoping for help with KDE 4.2

Is KDE 4.2 now in ports? Or are you using the overlay?
Whatever, have you tried moving or deleting your .kde4 directory as it's suggested somewhere in UPDATES or UPDATES-area51
Vla is offline   Reply With Quote
Old 02-14-09, 11:03 AM   #3
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Re: Hoping for help with KDE 4.2

Yeah, definitely try renaming your .kde4 directory... I had to do that as I had some very odd behavior with things freezing up and stuff not getting detected right. Afterwords, perfect!

Rusty
rnejdl is offline   Reply With Quote
Old 02-14-09, 11:44 AM   #4
ottdmk
Registered User
 
Join Date: Feb 2009
Posts: 3
Default Re: Hoping for help with KDE 4.2

Hi folks,

Yeah, I re-named my .kde4 directory first thing. And to answer your question, vla, 4.2 is now in ports. This box was installed using the overlay though.
ottdmk is offline   Reply With Quote
Old 04-02-09, 04:13 PM   #5
dsieborger
Registered User
 
Join Date: Apr 2009
Posts: 1
Default Re: Hoping for help with KDE 4.2

I think I'm experiencing the same problem with my 7300 card.

I've got a PC (running a recent RELENG_7 kernel and world, xorg-server 1.5.3_8,1, KDE 4.2.1, nvidia-driver-180.29) and I have three NVIDIA graphics cards available:
  • GeForce 6200 TurboCache 128MB (of on-board memory, that is)
  • GeForce 7300LE 256MB
  • GeForce 8500GT 512MB
If I plug in the 8500 and start KDE, desktop effects work properly. Likewise with the 6200. But if I reboot and plug in the 7300 (without changing any software settings), KDE won't enable desktop effects because kwin gives the error: "Compositing self-check failed, disabling compositing." Ticking the "Disable functionality checks" tickbox in the Desktop Effects control panel causes the screen to partially repaint then freeze for ten seconds before KDE gives up and reverts to the previous settings.

I've also tried running the 7300 with NVIDIA drivers 180.44 and the 173.14.12, but had the same problem.

I'm now wondering whether there's a Linux live CD with KDE 4.2 and the NVIDIA driver that I could try with my 7300 to see whether that works.
dsieborger is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVidia Display Drivers screw up KDE Webgraph NVIDIA Linux 11 10-08-02 08:57 PM
poor kde X windows performance after restart HeadStrong NVIDIA Linux 5 08-19-02 07:17 PM

All times are GMT -5. The time now is 09:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.