Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-04-09, 02:51 PM   #1
tadawson
Registered User
 
Join Date: May 2009
Posts: 44
Default Scondary non-SLI monitor with SLI config

Well, not sure exactly how to explain this, so I'll start in general. My system has three GPU's in it - two 9800GLX+ PCIe cards, and a 780a SLI on the motherboard. I have the 180.xx drivers on both WinXP and Linux (2.6.29 kernel, XFree86 4.7.0), and note a difference in the capabilities of display configuration.

In XP, I can turn on SLI, and the two 9800's will pair up and drive my primary display just fine, and I can *ALSO* run a secondary display on the 780a in NON-SLI mode. Note that this is not multi-monitor, and the release notes specifically state that it is a valid config . . . .

Now Linux . . . .

The SLI pairing of the 9800's works fine, *BUT* I can only get it to work if I disable the 780a - it appears that the driver can't comprehend that it isn't the same type of card, and it barfs *BOTH* the 9800's, and brings up only my secondary display on the 780a.

Considering that I have seen zero mention of hybrid support on Linux, would this not be an error in the driver, that it is trying to SLI link incompatible cards?

And for that matter, is there any way in the config to allow SLI to be active on *JUST* the 9800s and *NOT* the 780a, to give me the same display config as in XP - IE 9800's in SLI, driving the primary display, and a secondary, non-SLI display on the 780a? I have a hunch if the on-board was *NOT* an NVIDIA chipset, that this would work, but I have no options there . . . .

Oh, and I have downloaded the Beta drivers, but not tested yet. I am not encouraged, since the release notes make no mention of anything being different in the SLI area . . . .

Any insights folks?

- Tim
tadawson is offline   Reply With Quote
Old 05-04-09, 03:16 PM   #2
tadawson
Registered User
 
Join Date: May 2009
Posts: 44
Default Re: Scondary non-SLI monitor with SLI config

Quick update - just loaded the 185.18.04 beta drivers. A little better, but still no joy. This driver no longer pukes with all three GPU's active, but will still not allow the non-SLI participating GPU to have an active display, nor will nvidia-settings admit to the existence of the second 9800, although adding the SLI options to the XF86Config file and seeing the results makes it pretty clear that it is working . . .

- Tim
tadawson is offline   Reply With Quote
Old 05-05-09, 11:28 AM   #3
tadawson
Registered User
 
Join Date: May 2009
Posts: 44
Default Re: Scondary non-SLI monitor with SLI config

Hello? I see traffic on a lot of other topics . . . has nobody else wanted to do this, or do I somehow just smell bad or something?

- Tim
tadawson is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.