Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-02-09, 02:45 PM   #1
mbobak
Registered User
 
Join Date: Jan 2009
Posts: 32
Default X won't start w/ best available resolution...

Hi,

I'm running:
Ubuntu 8.10
NVidia driver 180.29
XFX 9500 GT
Pioneer Elite PRO-151FD Plasma Display (1080p)
Connection from 9500GT to TV is DVI to HDMI

Whenever I restart X, it insists on starting up X in 1024x768 mode. But, if I go to nvidia-settings, I have no problem at all selecting 1920x1080. So, if it's capable of that mode, how do I get it to *start* X in that mode??

In my /etc/X11/xorg.conf, I have:
Option "metamodes" "nvidia-auto-select +0+0; 1920x1080 +0+0"

One (failed) suggestion was to reverse the position of the auto-select and 1920x1080 in the line above. That doesn't appear to have any effect.

Does anyone have any thoughts or ideas?

Here's the complete /etc/X11/xorg.conf:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder57)  Thu Mar  5 18:47:52 PST 2009

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder57)  Thu Mar  5 18:48:47 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"

#    RgbPath         "/usr/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "PIONEER-TV"
    HorizSync       15.0 - 69.0
    VertRefresh     23.0 - 61.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9500 GT"
EndSection

Section "Screen"

# Removed Option "metamodes" "1920x1080 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TVStandard" "HD1080p"
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0; 1920x1080 +0+0"
    Option         "TripleBuffer" "true"
    Option         "NoLogo" "false"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection
Thanks in advance for any help or suggestions,

-Mark
mbobak is offline   Reply With Quote
Old 04-03-09, 01:54 PM   #2
mbobak
Registered User
 
Join Date: Jan 2009
Posts: 32
Default Re: X won't start w/ best available resolution...

I tried upgrading to 185.13 beta driver, no luck there.....

Is this possibly related to EDID?

-Mark
mbobak is offline   Reply With Quote
Old 04-05-09, 07:55 AM   #3
mbobak
Registered User
 
Join Date: Jan 2009
Posts: 32
Default Re: X won't start w/ best available resolution...

Bit more progress today....

I was looking at nvidia-settings and it's command line options, and found that I can do this:
mjb@jupiter:~$ nvidia-settings -q FlatpanelNativeResolution

Attribute 'FlatpanelNativeResolution' (jupiter:0.0; display device: DFP-0):
1920,1080.
'FlatpanelNativeResolution' is a packed integer attribute.
'FlatpanelNativeResolution' is a read-only attribute.
'FlatpanelNativeResolution' is display device specific.
'FlatpanelNativeResolution' can use the following target types: X Screen,
GPU.

mjb@jupiter:~$ nvidia-settings -q FlatpanelBestFitResolution

Attribute 'FlatpanelBestFitResolution' (jupiter:0.0; display device: DFP-0):
1024,768.
'FlatpanelBestFitResolution' is a packed integer attribute.
'FlatpanelBestFitResolution' is a read-only attribute.
'FlatpanelBestFitResolution' is display device specific.
'FlatpanelBestFitResolution' can use the following target types: X Screen,
GPU.

So, it's returning 1920x1080 for Native Resolution, but only 1024x768 for Best Fit Resolution.

Is this an EDID error? Something else? Any ideas?

AdvThanksance,

-Mark
mbobak is offline   Reply With Quote
Old 04-05-09, 08:05 AM   #4
P.Kosunen
Registered User
 
Join Date: Jan 2009
Posts: 57
Default Re: X won't start w/ best available resolution...

http://www.nvnews.net/vbulletin/showthread.php?t=130969

Code:
Option "FlatPanelProperties" "Scaling = Native"
Put this in xorg.conf.
P.Kosunen is offline   Reply With Quote
Old 04-05-09, 08:55 PM   #5
mbobak
Registered User
 
Join Date: Jan 2009
Posts: 32
Default Re: X won't start w/ best available resolution...

Quote:
Originally Posted by P.Kosunen View Post
http://www.nvnews.net/vbulletin/showthread.php?t=130969

Code:
Option "FlatPanelProperties" "Scaling = Native"
Put this in xorg.conf.
Tried that.... No luck....

I'm still reading through that thread, and some of the links I found there......

I'll report if I find anything else.

Meanwhile, if anyone wants to throw me a bone.... :-)


-Mark
mbobak is offline   Reply With Quote
Old 04-08-09, 05:52 AM   #6
P.Kosunen
Registered User
 
Join Date: Jan 2009
Posts: 57
Default Re: X won't start w/ best available resolution...

Check Xorg.0.log for more info about why setting correct resolution fails.
P.Kosunen is offline   Reply With Quote
Old 04-08-09, 01:12 PM   #7
mbobak
Registered User
 
Join Date: Jan 2009
Posts: 32
Default Re: X won't start w/ best available resolution...

Ok, Looking through the Xorg.0.log file, here are some messages that are apparently related to this issue:
Code:
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "false"
(**) NVIDIA(0): Option "TVStandard" "HD1080p"
(**) NVIDIA(0): Option "UseEdidFreqs" "false"
(**) NVIDIA(0): Option "TwinView" "0"
(**) NVIDIA(0): Option "MetaModes" "1920x1080_24 +0+0"
(**) NVIDIA(0): Option "TripleBuffer" "true"
(**) NVIDIA(0): Option "FlatPanelProperties" "Scaling = Native"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): TV Standard string: "HD1080p"
(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
(**) NVIDIA(0):     disabled on all display devices.
(II) NVIDIA(0): NVIDIA GPU GeForce 9500 GT (G96) at PCI:3:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 62.94.4b.00.71
(II) NVIDIA(0): Detected PCI Express Link width: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 9500 GT at PCI:3:0:0:
(--) NVIDIA(0):     PIONEER-TV (DFP-0)
(--) NVIDIA(0): PIONEER-TV (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): PIONEER-TV (DFP-0): Internal Dual Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1920x1080_24+0+0"
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(--) NVIDIA(0): DPI set to (44, 44); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
        [0] -1  0       0xffffffff - 0xffffffff (0x1) MX[b]
        [1] -1  0       0x000f0000 - 0x000fffff (0x10000) MX[b]
        [2] -1  0       0x000c0000 - 0x000effff (0x30000) MX[b]
        [3] -1  0       0x00000000 - 0x0009ffff (0xa0000) MX[b]
        [4] -1  0       0x0000ffff - 0x0000ffff (0x1) IX[b]
        [5] -1  0       0x00000000 - 0x00000000 (0x1) IX[b]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode "1920x1080_24+0+0"
So, up to there, everything seems fine, and it seems to be ok w/ 1920x1080.

Then there's a bunch of info about enabling extensions and loading modules, then at the very end, I see:
Code:
(II) NVIDIA(0): Setting mode "1024x768"
(II) NVIDIA(0): Setting mode "1920x1080_24+0+0"
(II) NVIDIA(0): Setting mode "DFP-0:1920x1080@1920x1080+0+0"
And then my screen comes up in 1024x768! There's no mention of 1024x768 until the very end!

Also, I'm attaching the complete Xorg.0.log file.

Any thoughts or suggestions would be greatly appreciated!

Thanks!

-Mark
Attached Files
File Type: log Xorg.0.log (14.0 KB, 80 views)
mbobak is offline   Reply With Quote
Old 04-08-09, 02:45 PM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: X won't start w/ best available resolution...

This sounds like a known problem with GNOME, where it changes the screen resolution as you're logging in. Make sure the resolution selected in the GNOME screen resolution control panel matches the one you want.
AaronP is offline   Reply With Quote

Old 04-08-09, 03:32 PM   #9
mbobak
Registered User
 
Join Date: Jan 2009
Posts: 32
Default Re: X won't start w/ best available resolution...

Wow! Really? Damn, it actually wouldn't surprise me.

If that's the problem, then my apologies to NVidia!

I'll check it as soon as I get home tonight!

-Mark
mbobak is offline   Reply With Quote
Old 04-08-09, 09:01 PM   #10
Leech
Registered User
 
Join Date: Jul 2004
Posts: 86
Default Re: X won't start w/ best available resolution...

I'm having the same issue here. Can't for the life of me get 1920x1080 to work without the overscan issue.

I finally managed to get everything to fit on my screen with 1360x768 resolution, but it also always starts up in 1024x768. The Gnome display utility (in Ubuntu 9.04 updated today) just tells me that it can't work with the Nvidia display driver, and asks to load up the vendor controlled display utility. If I tell it YES then it just loads up nvidia-settings. If I put no, it does display the Gnome utility, but the max resolution is 1024x768.

That could be the issue right there. I'll do some further testing, but I think that with either
Code:
Option          "ExactModeTimingsDVI" "TRUE"
or
Code:
Option  "UseEDID"       "False"
the driver is thinking my monitor does a max of 1024x768 (though nvidia-settings lists 1360x768 as the highest resolution.)

This has been driving me nuts since I bought my HDTV a month or so ago.

The main problem has been that every program I've tried on it tells me I have different refresh rates. X detects 29-49 Horizontal and Powerstrip said it was 15-63 or something like that. It's an RCA L42FHD37 (which from what I can tell is identical to a Tech. Concepts 42" TV that is made in China by TLC.)

Leech
Leech is offline   Reply With Quote
Old 04-08-09, 09:12 PM   #11
Leech
Registered User
 
Join Date: Jul 2004
Posts: 86
Default Re: X won't start w/ best available resolution...

If I remove those two lines, I get 1920x1080 again, but then I get the overscan.

I get a lot of this throughout the Xorg.0.log

Code:
The EDID for Tech. Concepts RCA (DFP-0) contradicts itself:
(WW) NVIDIA(0):     mode "1920x1080" is specified in the EDID; however, the
(WW) NVIDIA(0):     EDID's valid HorizSync range (39.000-49.000 kHz) would
(WW) NVIDIA(0):     exclude this mode's HorizSync (67.5 kHz); ignoring
(WW) NVIDIA(0):     HorizSync check for mode "1920x1080".
It really does sound like the OP is having the same issue I do. If I try tweaking the resolution of mine more than 1 pixel one way or the other, then I get "Unusable signal" Though on my end, it looks like X itself starts fine.
Attached Files
File Type: log Xorg.0.log (19.9 KB, 73 views)
Leech is offline   Reply With Quote
Old 04-09-09, 12:52 AM   #12
mbobak
Registered User
 
Join Date: Jan 2009
Posts: 32
Default Re: X won't start w/ best available resolution...

Ok, almost there!

AaronP was right on about the Gnome Screen Resolution preference. When I set that, the system now logs me in at 1920x1080.

Here's the one remaining weirdness....which I'm happy to live with, by the way.....

When I login, my monitor says "1080i", which I I thought was strange. What's even stranger, when I start mythfrontend, the monitor blanks, then comes back as "1080p"....??

Any idea on that one?

Anyhow, as I said, I can live with that, I'm just happy that I can login at the correct resolution.

To Leech: I think our issues are totally separate. To my knowledge, my problem was w/ the Gnome Screen Resolution preference resetting my resolution from 1920x1080 down to 1024x768. I don't have any overscan issues or anything else. For me, 1920x1080 always worked perfectly, except that I couldn't automatically get that resolution on login. Now I can. I think the issue you describe is quite different.

Thanks again to AaronP!

-Mark
mbobak is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microsoft explained why they killed start button AthlonXP1800 Microsoft Windows 8 19 10-28-12 10:07 AM
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 01:23 PM
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 04:22 PM
Opinions on 1280x1024 resolution skipparoo NVIDIA GeForce 7, 8, And 9 Series 103 06-23-12 12:38 AM
30.82 and 40.41 resolution + monitor OSD. Max3D NVIDIA Windows Graphics Drivers 2 09-05-02 03:15 AM

All times are GMT -5. The time now is 06:15 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.