Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-09-03, 04:38 PM   #1
quelx
Registered User
 
Join Date: Jun 2003
Location: Columbus
Posts: 27
Send a message via AIM to quelx
Default geForce 5200 Ultra linux 2.4.21-0.13mdk lockup

I just purchased a PNY geForce 5200 Ultra to replace my geForce 2 MX. After unintaling the drivers and then reinstalling them from the console, Xwindows refuses to start. I get the NVidia spalsh screen and then nothing... I can ssh into the box and poke around and found nothing in the XFree86.0.log out of the ordinary everything seemed to load fine. I checked the CPU load and found it was running at 100% a ps -A showed
3374 ? 00:17:43 X
as the only noteworhty process that could be doing that.

Here is the Device section and module section of my XF86Config

Section "Device"
Identifier "NVidia5200"
Driver "nvidia"
#VideoRam 131072
# Insert Clocks lines here if appropriate
EndSection

Section "Module"
Load "dbe"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
Load "type1"
Load "speedo"
Load "glx"
# Load "dri"

any help on what went wrong appreciated,

Thanks,

Travis

PS for giggles I threw my old card back in and it worked, my mainboard is an Abit KT-7Raid and does support AGP 4x, so the card should work, correct?

Last edited by quelx; 06-09-03 at 05:54 PM.
quelx is offline   Reply With Quote
Old 06-09-03, 05:39 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Option "IgnoreEDID" "true"

You can replace true with 1 or on, if you want.

This is the standard fix for "X takes a long time to start!" (according to the README), so I'm thinking it might be applicable here too.

Failing that, there have been a bunch of "X stops, using up 99% of my CPU!" threads posted here. Maybe some of them have solutions? (I don't usually respond to or follow them, so I don't know)
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 06-09-03, 08:42 PM   #3
quelx
Registered User
 
Join Date: Jun 2003
Location: Columbus
Posts: 27
Send a message via AIM to quelx
Default

Firstly thanks for the reply...

Things still aren't working, the system still refuses to start X, basicly pegging the CPU at 100% and stopping (I've waited up to an hour to let it start) though I am getting some more useful error messages namely:
_____________________________________
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4363
Module class: XFree86 Video Driver
_____________________________________
(The "compiled for 4.0.2", is that okay if I'm running 4.3? if not what do I need to do?)

and
_____________________________________
(WW) NVIDIA(0): Not using mode "1152x768":
(WW) NVIDIA(0): horizontal sync start (1178) not a multiple of 8
(WW) NVIDIA(0): Not using mode "768x576":
(WW) NVIDIA(0): horizontal sync width (846 - 832 = 14) not a multiple of 8
(WW) NVIDIA(0): Not using mode "576x384":
(WW) NVIDIA(0): horizontal sync start (589) not a multiple of 8
(WW) NVIDIA(0): Not using mode "360x200":
(WW) NVIDIA(0): horizontal sync start (378) not a multiple of 8
_____________________________________

I added the lines you suggested and then some. Attached is my XFree86.0.log and XF86Config-4.

Thank you,

Travis
Attached Files
File Type: txt xfree86.0.log.txt (23.8 KB, 110 views)
quelx is offline   Reply With Quote
Old 06-09-03, 08:44 PM   #4
quelx
Registered User
 
Join Date: Jun 2003
Location: Columbus
Posts: 27
Send a message via AIM to quelx
Default

Here is my config with all the "stop probing" lines added XF86Config-4
Attached Files
File Type: txt xf86config-4.txt (2.9 KB, 137 views)
quelx is offline   Reply With Quote
Old 06-09-03, 08:57 PM   #5
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

The "compiled for 4.0.2" message is fine. The binary interface to X hasn't changed since then -- or at least, according to Andy Mecham (the guy from nVidia that pops up here right about every driver release, then disappears for a while) that's the case.

Those other warning lines are just modes that aren't getting validated. Shouldn't be any big deal there, either...

And whoops, I see that my original post was way off base. I should have said "IgnoreDisplayDevices" "DFP, TV" (instead of IgnoreEDIDs), but I see that you already have that option in there, too, and it isn't helping. The screen is going back to black after the nVidia splash, right?

Hmm... I'm not really sure, other than what I've said already...
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 06-09-03, 09:21 PM   #6
quelx
Registered User
 
Join Date: Jun 2003
Location: Columbus
Posts: 27
Send a message via AIM to quelx
Default

Nope, no black screen, just the NVidia "eye" staring at me blankly. Can it see what I'm thinking?

I've added to my lilo.conf what another post suggested the "noapic acpi=off" to no avail.

If will keep playing with it, any ideas will be helpful and tried, if I get anywhere I'll be sure to post it.

Thanks,

Travis

-The eye told me to do it.
quelx is offline   Reply With Quote
Old 06-10-03, 02:33 PM   #7
quelx
Registered User
 
Join Date: Jun 2003
Location: Columbus
Posts: 27
Send a message via AIM to quelx
Default

So I recompiled a kernel (w/o agpgarp) to try the nvidia drivers with that, no success.

here is my 'cat cat /proc/driver/nvidia/cards/0'
Model: GeForce FX 5200 Ultra
IRQ: 5
Video BIOS: 04.34.20.23.00
Card Type: AGP

mainboard:
ABit KT7-RAID

processor:
AMD Athlon 1300

driver:
NVIDIA XFree86 Driver 1.0-4363

distribution:
Mandrake 9.1 (kernel 2.4.21-0.13)

make of card:
This is a PNY GeForce 5200 Ultra AGP

My config and log files are in previous posts in this thread

Thanks,

Travis
quelx is offline   Reply With Quote
Old 06-10-03, 05:02 PM   #8
quelx
Registered User
 
Join Date: Jun 2003
Location: Columbus
Posts: 27
Send a message via AIM to quelx
Default

This is fun posting to myself., So I'm gonna make some more notes here for safe keeping:

*********/etc/X11/XFConfig-4*********
Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
EndSection

Section "Device"

#BoardName "NVIDIA GeForce2 DDR (generic)"
Identifier "Videocard0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "GeForce FX 5200 Ultra"
# Option "DPMS"
# Option "NvAGP" "3"
Option "ConnectedMonitor" "CRT"
# Option "IgnoreEDID" "true"
BusID "PCI:1:0:0"
Option "IgnoreDisplayDevices" "DFP, TV"
EndSection

*********/etc/lilo.conf*********

*********/etc/modprobe.conf*********
# AGP
install agpgart /sbin/modprobe --ignore-install agpgart && /sbin/modprobe intel-agp
remove agpgart /sbin/modprobe -r intel-agp ; /sbin/modprobe -r --ignore-remove agpgart



*********Kernel*********
I have recompiled my kernel (yes, the newbie is advancing) to remove
agpgart and add support for the nvidia agp driver which supposedly runs
faster with the VIA chipset I have. (note: it didn't change the fps
(Frames Per Second) at all.)
I removed support for all other motherboard chipsets, even if it was
loaded as a module.
I made a few other tweaks also, (added NTFS read support, added DOS
support, and a few other things that I forget at the moment) even if not
related to game performance, just because I was there and I thought
would enhance my OS for one reason or another. I never compiled a kernel
before, it wasn't too hard, following the generic directions.
end of notes

I have exams tomorrow, so I need to get on that, I'll try recompiling the kernel again more carefully, since the nasty /dev/agrgart (I presume this is not supposed to happen if he kernel has been compiled w/o agpgart?) showed up again, and I ended up breaking some othere things...

-Travis
quelx is offline   Reply With Quote

Old 06-10-03, 05:21 PM   #9
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Maybe try commenting out the BoardName option?

And yeah, unfortunately, that's the best I can come up with...

If you have no agpgart support whatsoever, and are SURE that you'll never want it again, then you can delete the /dev/agpgart file after booting into that kernel. If, that is, it isn't gone already -- if you use devfs, then files in /dev show up and disappear as modules load and unload already. So if your distro uses devfs, then the only reason the /dev/agpgart file would be there is if you loaded the module (intentionally or not).
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 06-10-03, 06:34 PM   #10
quelx
Registered User
 
Join Date: Jun 2003
Location: Columbus
Posts: 27
Send a message via AIM to quelx
Default

Rock on, that is helpful... I'm pretty sure Mandrake uses devfs, I'll check though, and I'll keep that in mind when I break stuff tomorrow.

Thanks!

-Travis
quelx is offline   Reply With Quote
Old 06-13-03, 11:57 PM   #11
quelx
Registered User
 
Join Date: Jun 2003
Location: Columbus
Posts: 27
Send a message via AIM to quelx
Default

Whoo hooo!

I've compiled 3 different kernels and not a one of them wokred (2.4.20, 2.4.21, 2.5.70) I disabled AGPGART cuz it don't like my chipset (VIA). So I play rtcw and et in Windows for now, till nvidia fixes, kernel fixes, or by a miracle I happen across a kernel configuration that works. Wheeeee!!
quelx is offline   Reply With Quote
Old 06-14-03, 08:15 AM   #12
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Which Via chipset do you have?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
Gnome3 with composite is very slow on Geforce FX 5200 with 173.14.31 driver Artox NVIDIA Linux 0 05-26-12 10:33 AM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 03:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.