Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-05-09, 09:31 AM   #1
TheOnlyDan
Registered User
 
Join Date: Apr 2009
Location: London
Posts: 4
Unhappy Black screen after installing new NVidia linux driver on OpenSuse 11.1

Hi,

I'm running 11.1 and it was stuck on Mesa drivers even though I had a recognised graphics card ( Nvidia 6600 ). So I decided to install the latest Linux drivers from Nvidia. I followed their instructions, added their repositories to the update list, updated using software management and rebooted my machine. Now I have a black screen instead of the login screen. The machine seems to hang and do nothing. I noticed that I forgot to run the "sax2 -r" command after installing. So I restarted the machine in text mode, logged in as root and run the command. Still got a black screen.

I'm using a DELL Latitude 4400 with a GF6600 AGP and OpenSuse 11.1 and a Dell flat screen display.

Any ideas on how to fix this ? As I want to do opengl programming on Linux I really need the 3d acceleration.

I can start the distro in failsafe mode which seems to allow X11 to run in software mode. Running the "sax2 -r" command hangs after displaying "XServer : 0.0 -> grant".

Cheers,
Pascal.
TheOnlyDan is offline   Reply With Quote
Old 04-05-09, 10:18 AM   #2
busbus
Registered User
 
Join Date: Nov 2008
Posts: 24
Default Re: Black screen after installing new NVidia linux driver on OpenSuse 11.1

have you checked your xorg.log? on some cards the nvidia driver seems to be unable to display the ttys and only shows a blank screen. it could be that your x does not start properly and leaves you with this blank screen. i have this problem aswell, you are still able to pass commands to the console but you dont see nothing..
busbus is offline   Reply With Quote
Old 04-05-09, 10:40 AM   #3
TheOnlyDan
Registered User
 
Join Date: Apr 2009
Location: London
Posts: 4
Unhappy Re: Black screen after installing new NVidia linux driver on OpenSuse 11.1

Hi,

No I haven't checked the log yet but that sounds very similar. Do you know how to fix this ?

Alternatively is there a linux distro which is easy to install and will allow me to do OpenGL work without having to jump through hoops supporting the latest NVidia features ? I want to do some shader work in Linux but this is getting painful.

Cheers,
Pascal.
TheOnlyDan is offline   Reply With Quote
Old 04-05-09, 12:16 PM   #4
MD25
Registered User
 
Join Date: Feb 2009
Posts: 3
Default Re: Black screen after installing new NVidia linux driver on OpenSuse 11.1

Quote:
Originally Posted by TheOnlyDan View Post
Hi,
Running the "sax2 -r" command hangs after displaying "XServer : 0.0 -> grant".
Have you tried sax2 -r -m 0=nvidia ? (digit 0 not letter O)
MD25 is offline   Reply With Quote
Old 04-05-09, 12:45 PM   #5
TheOnlyDan
Registered User
 
Join Date: Apr 2009
Location: London
Posts: 4
Unhappy Re: Black screen after installing new NVidia linux driver on OpenSuse 11.1

Yeah doesn't do anything.
TheOnlyDan is offline   Reply With Quote
Old 10-18-09, 10:26 AM   #6
TheOnlyDan
Registered User
 
Join Date: Apr 2009
Location: London
Posts: 4
Default Re: Black screen after installing new NVidia linux driver on OpenSuse 11.1

sax2 -r -m 0=nvidia gives the same result. It hangs after Sax : XServer : : 0.0 -> grant. Any other ideas ?

Thanks,
Pascal.
TheOnlyDan is offline   Reply With Quote
Old 10-18-09, 11:34 AM   #7
DrSuSE
Registered User
 
DrSuSE's Avatar
 
Join Date: Feb 2006
Posts: 91
Default Re: Black screen after installing new NVidia linux driver on OpenSuse 11.1

You should/could... (in no particular order)

1. Try the latest RC (see sticky)
2. Generate the needed reports/logs to properly troubleshoot (see sticky)
DrSuSE is offline   Reply With Quote
Old 10-19-09, 08:12 PM   #8
cheongi
Registered User
 
Join Date: Oct 2009
Posts: 6
Default Re: Black screen after installing new NVidia linux driver on OpenSuse 11.1

Having struggled for many days to get my nvidia card recognised on 11.1, it can be made to work but didn't really do anything useful.

Check here:
http://forums.opensuse.org/hardware/...nt-change.html
http://forums.opensuse.org/install-b...upgrade-2.html

openSUSE 11.2-RC1 uses the graphics acceleration properly.
http://forums.opensuse.org/pre-relea...ml#post2053096
cheongi is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 01:52 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 10:55 AM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM

All times are GMT -5. The time now is 01:44 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.