Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-04-09, 03:53 AM   #1
jpnub
Registered User
 
Join Date: Apr 2009
Posts: 4
Question 2 Nvidia cards, 1 problem

Hello
Thanks for taking a look at this for me. I am a recent convert to linux (well, almost...still dualbooting with windows 7) and am not very experienced with a command line and code. I love ubuntu and am happy I have switched but I bassically need a gui to function.
I currently have 3 monitors, and to run these I have two video cards. 1 video card is a Nvidia 8500 PCI-E. This is what I am currently using to run Ubuntu 8.10, and it works fine with two monitors. All is good.


My other card is a Nvidia 6200. I installed ubuntu, did a full update and restarted the machine. I then installed the restricted Nvidia drivers(177) and then when I restart I see the splash but after the orange bar loads on the splash screen a command line prompt asks me to log in. So I then log in and can not go any farther.
When I try:

Startx

I get:

Server error: no screens found

So basically, my nvidia 6200 does not work. Even with the new drivers. When I unplug the 6200 from it's PCI slot I boot up fine and the 8500 works.
I have used the 6200 and 8500 together with windows 7, and they function properly.
I have also set my default video device to pci-e in my bios, if that helps.(tried it the other way, same thing)


Happy to provide any more information if it will help. Thank you!
jpnub is offline   Reply With Quote
Old 04-04-09, 08:38 AM   #2
Tux
Registered User
 
Join Date: Nov 2002
Location: United States
Posts: 60
Default Re: 2 Nvidia cards, 1 problem

The problem is X cannot determine what card to use for the display and nvidia-xconfig doesnt write the BusID by default.

Type nvidia-xconfig -a and i bet it will work then
__________________
Intel Core 2 Quad Q6600
Abit IN9 32x Max
2x BFG 8800GT OC (SLI Mode)
4GB (4x1gb) Corsair XMS2 PC6400 4-4-4-5 @2T
Tux is offline   Reply With Quote
Old 04-04-09, 01:08 PM   #3
jpnub
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: 2 Nvidia cards, 1 problem

Okay thanks for the help.

I tried sudo nvidia-xconfig -a

and I get
Using X configuration file: "et/x11/xorg.conf"

WARNING: error opening libnvidia-cfg.so.1: libnvidia-cfg.so.1: cannot open shared object file: No such file or directory.

ERROR: Unable to determine number of GPUs in system; cannot honor '--enable-all-gpus' option.

Backed up file 'etc/x11/xorg.conf' as 'etc/x11/xorg.conf.backup'
New X configuration file written to 'etc/x11/xorg.conf
'


And then when I startx I get the same error, tried a restart.
jpnub is offline   Reply With Quote
Old 04-05-09, 01:04 PM   #4
jpnub
Registered User
 
Join Date: Apr 2009
Posts: 4
Question Re: 2 Nvidia cards, 1 problem

Still no luck. Anyone have a fix for this? What do you think I should do to solve it?
jpnub is offline   Reply With Quote
Old 04-06-09, 08:03 PM   #5
jpnub
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: 2 Nvidia cards, 1 problem

Haha getting desperate here. What other forums do you think I should post to?
jpnub is offline   Reply With Quote
Old 04-06-09, 08:08 PM   #6
Tux
Registered User
 
Join Date: Nov 2002
Location: United States
Posts: 60
Default Re: 2 Nvidia cards, 1 problem

I would suggest going to irc.freenode.net and asking in the #ubuntu channel. For some reason it seems installing drivers on ubuntu is difficult. I dont know from experience just from what i have seen. It always seems to be a chore for ubuntu users.


First try typing, as root, nvidia-uninstall then after that try reinstalling the driver as root. See if that works...if not try the ubuntu channel..if that doesnt work try fedora

I suggest dumping ubuntu and using Fedora...
__________________
Intel Core 2 Quad Q6600
Abit IN9 32x Max
2x BFG 8800GT OC (SLI Mode)
4GB (4x1gb) Corsair XMS2 PC6400 4-4-4-5 @2T
Tux is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem connecting Pioneer VSX-S300 to Nvidia Ion - flat panel scaling solves it? wild_oscar NVIDIA Linux 3 06-17-12 07:18 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 04:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.