Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-04-09, 10:12 AM   #1
hofix32
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Resolution in Ubuntu

I cant change the resolution on my notebook with ubuntu.
I have a dell inspiron 1720
hofix32 is offline   Reply With Quote
Old 04-04-09, 11:07 AM   #2
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Resolution in Ubuntu

Please read

http://nvnews.net/vbulletin/showthread.php?t=46678

first. There is a good reason it is sticky and even marked with ---> <--- (maybe it should be huge and blink and no threads can be opened if it wasn't read first ...)

With this much information (almost none) it is more a quiz show than a support case.

It might be that

1) EDID misdetection, so you only have one resolution available
2) you are using XRandR based tools
3) you are not even using the nvidia driver

For all of those there are good solutions, but we first need to know what the problem is.

Please attach a bug report as described in the above mentioned thread.

Fuchs
NvFuchs is offline   Reply With Quote
Old 04-05-09, 12:44 PM   #3
hofix32
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: Resolution in Ubuntu

My notebook has a 8600m gt graphical card.
The maximum resolution of screen is 1920x1200, but I see everything very small.
I want to put 1440x900.
For the software Nvidia X Server Setting....i can't select another resolution apart 1920x1200.
I have tried it modifying the xorg.conf.
Thanks you very much for trying tu help me.
Attached Files
File Type: log nvidia-bug-report.log (118.1 KB, 65 views)
hofix32 is offline   Reply With Quote
Old 04-05-09, 02:36 PM   #4
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Resolution in Ubuntu

In fact nvidia detects the other resolutions you specified as not valid.

Probably the EDID of your monitor is a bit special.

In order to know why he doesn't accept the other resolutions, could you please try the following:

`sudo /etc/init.d/gdm stop`

You should then be on a terminal. Log yourself in with username and password

`startx -- -logverbose 5`

you should be in a graphic environment

`sudo nvidia-bug-report.sh`

CTRL+ALT+Backspace

you should be back on the terminal

`sudo /etc/init.d/gdm start`

then upload the new bug report created, which should contain information about each resolution rejected.

Fuchs
NvFuchs is offline   Reply With Quote
Old 04-06-09, 12:10 PM   #5
hofix32
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: Resolution in Ubuntu

I attach the new bug.
Thanks very much.
Attached Files
File Type: log nvidia-bug-report2.log (128.0 KB, 66 views)
hofix32 is offline   Reply With Quote
Old 04-06-09, 04:02 PM   #6
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Resolution in Ubuntu

In fact your monitor seems to specify this as the native and only valid resolution. You can try to not use EDID modes as described here:

http://us.download.nvidia.com/XFree8...ppendix-b.html

and specify own resolution via X Server Modelines.

There are tools out there to create these, as it is quite a pain in the arse to do this manually.

Fuchs
NvFuchs is offline   Reply With Quote
Old 04-07-09, 07:00 AM   #7
hofix32
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: Resolution in Ubuntu

I'm not advanced linux user, and i don't understand these manual very well.
I tried to disable EDID, adding in the xorg.conf Option "UseEDID" "FALSE", and when i starts the x server i hear the sounds of ubuntu starts, but i don't see anything.
Thank you for your comprehension
hofix32 is offline   Reply With Quote
Old 04-08-09, 02:35 AM   #8
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Resolution in Ubuntu

Quote:
Originally Posted by hofix32 View Post
I'm not advanced linux user, and i don't understand these manual very well.
I tried to disable EDID, adding in the xorg.conf Option "UseEDID" "FALSE", and when i starts the x server i hear the sounds of ubuntu starts, but i don't see anything.
Thank you for your comprehension
Sorry, but I have currently not too much time at hand.

To explain the situation: A Monitor specifies in it's EDID what frequencies, pixel clocks, resolutions etc. it is able to display / perform.

Disabling the EDID with the option you named was not wrong, but if you do so, the driver has no information what the monitor is able to display. Therefore it might send something to the monitor which the monitor can't show, so all you get is a black screen.

In order to specify this data by yourself, you can use X org Modelines.

There is an overview available here:
http://howto-pages.org/ModeLines/

and some more information here:
http://www.x.org/wiki/FAQVideoModes

I hope this helps.

Kind regards,

Fuchs
NvFuchs is offline   Reply With Quote

Old 04-08-09, 03:25 AM   #9
k0tuk
Registered User
 
Join Date: May 2008
Posts: 8
Default Re: Resolution in Ubuntu

You may try this... i had a similar problem

http://ubuntuforums.org/showthread.php?t=1087922
k0tuk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 03:22 PM
Linux gaming on the rise: EA arrives on Ubuntu and Valve plans Steam port News Gaming Headlines 0 06-15-12 04:20 PM
Canonical partners with Microsoft to support Ubuntu on Azure News Archived News Items 0 06-08-12 05:20 AM
Precision and purpose: Ubuntu 12.04 and the Unity HUD reviewed News Archived News Items 0 05-28-12 02:20 PM
30.82 and 40.41 resolution + monitor OSD. Max3D NVIDIA Windows Graphics Drivers 2 09-05-02 02:15 AM

All times are GMT -5. The time now is 07:29 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.