Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-10-09, 12:44 PM   #1
Seelenfeuer
Registered User
 
Join Date: Apr 2009
Posts: 2
Default 173xx-drivers and RealTime-patchset

Hi there!

I've just installed a new kernel (2.6.29) together with the rt-patchset (can be found on kernel.org in the kernel/projects/rt repository). Since than the nvidia-driver fails to compile (I have a 5500FX so I have to stick with the 173xx-series :S ).

The errormessage seems to be quite well known around here ("Unable to determine the target kernel version"), but so far I haven't found a solution (for 173xx-drivers). From what I read I think the driver should work if it would utilize the kernels build-system, but thats beyond my capabilities.

Anyway, is there even a faint hope which doesn't involve buying a new card to use the newer drivers?

Regards~
Seelenfeuer is offline   Reply With Quote
Old 04-11-09, 07:12 AM   #2
eskuai
Registered User
 
Join Date: Aug 2007
Posts: 35
Default Re: 173xx-drivers and RealTime-patchset

Are you doing a full install ?

Try with -K parameter
eskuai is offline   Reply With Quote
Old 04-11-09, 08:28 AM   #3
Seelenfeuer
Registered User
 
Join Date: Apr 2009
Posts: 2
Default Re: 173xx-drivers and RealTime-patchset

With this the installer complains about the driver missing.

I extracted the package and went to usr/src/nv/ and tried 'make module', but the error remains the same.

If I bypass the checks in conftest.sh so it just uses the Makefile.kbuild the compilation starts but fails after a short time with
Code:
error: kmem_cache_create() unavailable
(the line is actually longer but I don't have the output right now. If further output is required I can still post it). This is a little irritating as this function is definitely present in include/linux/slab.h and wasn't changed by the patch. Changing the kernel-setting from SLAB to SLUB didn't change anything.

I tried compiling the driver with an active, unpatched kernel, too (it worked) and using it with the patched kernel, but modprobe complains about an invalid module format and if I try to force it with modprobe -f (doesn't work, too) I get complains about undefined symbols in dmesg...

For now I use the unpatched kernel, but that's not the solution I hoped for =\

Regards
Seelenfeuer is offline   Reply With Quote
Old 04-11-09, 09:04 AM   #4
Fackamato
User
 
Join Date: Mar 2005
Posts: 366
Default Re: 173xx-drivers and RealTime-patchset

I could get 185.19 to work with the -rt6 patch (didn't try -rt7), I had to keep the directory where I compiled the kernel, and point the nvidia package to that. ( --with-kernel-source=... I think)
Fackamato is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.