Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-16-09, 02:04 AM   #1
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Angry [BUG REPORT] Fonts breakage with kwin4 FX effects turned on

As soon as I enable desktop effects in KDE 4.2.1 KWin window manager, all my fonts start looking like a garbage to the point of being unable to read.

Screenshots of a bug and KWin options (quite default) are attached.

GPU: nVidia Corporation C51PV [GeForce 6150] (rev a2)
MB: ASUS M2NPV-VM ACPI BIOS Revision 0901
Drivers: 180.37 (all others too).
Attached Thumbnails
Click image for larger version

Name:	bug.png
Views:	195
Size:	24.1 KB
ID:	36042  Click image for larger version

Name:	kwin_options.png
Views:	201
Size:	86.3 KB
ID:	36044  
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (34.1 KB, 76 views)
artem is offline   Reply With Quote
Old 03-17-09, 05:39 AM   #2
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Default Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

Can anyone else confirm this bug?
artem is offline   Reply With Quote
Old 03-20-09, 01:41 AM   #3
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Unhappy Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

Still happens with 185.13. even without kwin effects
Attached Thumbnails
Click image for larger version

Name:	bug.png
Views:	105
Size:	80.0 KB
ID:	36097  
artem is offline   Reply With Quote
Old 03-20-09, 04:15 AM   #4
Fackamato
User
 
Join Date: Mar 2005
Posts: 366
Default Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

What distribution are you using?
Fackamato is offline   Reply With Quote
Old 03-20-09, 05:35 AM   #5
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Default Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

Fedora 10 with all updates installed.
artem is offline   Reply With Quote
Old 03-23-09, 02:06 PM   #6
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Default Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

Bump.
artem is offline   Reply With Quote
Old 03-23-09, 02:37 PM   #7
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

I saw this too - it mostly happens after using intensive openGL applications.
I can reproduce it most times by:
- enabling effects
- starting Google earth
- use it a bit
- closing google earth

fonts will be smeared after that. Geforce 7600GT @ 1600x1200.
I think this started to appear after using InitialPixmapPlacement=2.

So try:
nvidia-settings -a InitialPixmapPlacement=1
or 0.

Last edited by kriko; 05-31-11 at 02:34 PM.
kriko is offline   Reply With Quote
Old 03-25-09, 03:40 AM   #8
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Default Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

I don't use any performance related hacks to run X.org with NVIDIA (after all I have GeForce 6xxx which has never had any serious performance problems aside from being terribly slow in all heavy OpenGL applications ), but I will certainly try your suggestion.
artem is offline   Reply With Quote

Old 03-25-09, 05:40 AM   #9
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

It's not a performance "hack" it is being used by nvidia in recent drivers, but I'm not sure.
If IPP is set to 2 then it uses graphic card memory to cache fonts, but it seems to do it badly in some cases.
Please report back if it works.
kriko is offline   Reply With Quote
Old 03-25-09, 06:27 AM   #10
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Unhappy Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

With IPP=1.

Now testing with IPP=0.
Attached Thumbnails
Click image for larger version

Name:	bug.png
Views:	109
Size:	55.9 KB
ID:	36189  
artem is offline   Reply With Quote
Old 03-25-09, 07:12 AM   #11
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

What about ipp 0?
try also "-a GlyphCache=0"
kriko is offline   Reply With Quote
Old 03-25-09, 08:47 AM   #12
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Default Re: [BUG REPORT] Fonts tearing with kwin4 FX effects turned on

With IPP=0 this problems causes less effects, but still it's here.
Attached Thumbnails
Click image for larger version

Name:	bug.png
Views:	75
Size:	41.2 KB
ID:	36190  
artem is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:08 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.