Go Back   nV News Forums > Linux Support Forums > NVIDIA Solaris

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-09, 03:10 PM   #13
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: Can't enable Desktop Effect after upgrading to snv_111

I only have a few more suggestions.

1) Try installing nv112 now available.

http://www.opensolaris.org/jive/thre...start=0#368315

Also, this build comes with 180.44 driver, you'll have to add the 180.50 manually. Also, please note the workarounds on this page.

2) Try the workaround I gave you earlier now that you've progressed with the 180.50 driver.

3) If all else fails, try posting to xwin_discuss forum for Opensolaris/SXCE

http://www.opensolaris.org/jive/forum.jspa?forumID=25

Sun graphics engineers monitor this forum and quite often respond to end user problems.
paulgress is offline   Reply With Quote
Old 04-17-09, 04:01 PM   #14
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Quote:
Originally Posted by zander View Post
@shaoxuan: I didn't mean to suggest that you install 180.50 on your system - since you had already installed 180.44, X.Org's libwfb.so binary may already have been clobbered. 180.50 also has a bug that prevents it from working correctly on pre-G80 (GeForce 8) series GPUs. We hope to release an updated 180.xx driver addressing this problem either sometime today or early next week. Please see http://www.nvnews.net/vbulletin/show...50&postcount=7 for a workaround.
Hello,

The screen is corrupted, how can I input commands?

What can I do in single user mode? the "xrander" command can't be found.

Shao
shaoxuan is offline   Reply With Quote
Old 04-17-09, 04:45 PM   #15
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Can't enable Desktop Effect after upgrading to snv_111

If the 180.50 NVIDIA graphics driver packages can't be uninstalled in single-user mode, you may still be able to temporarily disable the automatic graphical login service, such that you're presented with a text-mode login.
zander is offline   Reply With Quote
Old 04-17-09, 05:10 PM   #16
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: Can't enable Desktop Effect after upgrading to snv_111

If you install nv112 it will clear all the graphics driver issues.

To try and clear nv111 you need copy the libwfb.so libraries into the directories I posted earlier. To do this will require some work. You have to boot into Failsafe mode and when it asks to mount the root filesystem as /a enter "y" for yes. Instead of finding the libraries on the nv111 DVD, I've taken the liberty to put them on my company website so you can download them.

http://www.rad-electronics.com/Downloads/X11/libwfb.so
http://www.rad-electronics.com/Downl...md64/libwfb.so

You'll need to burn it on a CD or usb stick and mount it manually.
To mount it manually you need to determine the driver for mounting it is. You have to issue the command "rmformat" without the quotes. If you had a usb stick in when you entered rmformat, then to mount that:

mount -F pcfs /dve/dsk/c0t0d0p0:c /mnt

If it's a CD issue:

mount -F hsfs /dev/dsk/c0t0d0s2 /mnt

Where the "c0t0d0s2 or c0t0d0p0 is replaced by what comes from the output of rmformat.

Then copy them over:

cp /mnt/libwfb.so /a/usr/X11/lib/modules/libwfb.so
cp /mnt/amd64/libwfb.so /a/usr/X11/lib/modules/amd64/libwfb.so


It will probably be far easier to just upgrade again to nv111 or nv112.
paulgress is offline   Reply With Quote
Old 04-17-09, 05:30 PM   #17
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Can't enable Desktop Effect after upgrading to snv_111

For what it's worth, 180.51 is now available (see ftp://download.nvidia.com/solaris/180.51), which fixes the libwfb.so clobber problem and doesn't suffer from the GeForce 6/7 series regression 180.50 did.
zander is offline   Reply With Quote
Old 04-18-09, 11:12 PM   #18
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: Can't enable Desktop Effect after upgrading to snv_111

I've thought of what I believe an easier way to get the libraries into nv111. Even though you cant see the login screen, your there. If you login as root you should be at the console even though you don't see it (you can test it by typing "reboot" after loging in). At this point you can turn telnet and ftp services on, this way you can ftp the files over, then telnet login as regular user and su to root. At this point you can copy the files to their proper location. It should go something like this:

root
your-password
svcadm enable ftp
svcadm enable telnet

go to another computer on the same internet, get to a terminal window (in windows the command prompt) and type:

ftp 192.168.1.100

The IP address is the one assigned to the nv111 box. You can only login as a regular user, not root. Put the files to a location you remember.

Now open another terminal window and type:

telnet 192.168.1.100

The IP address is the one assigned to the nv111 box. You can only login as a regular user, not root. now type:

su
your-root-password

now you have root privileges, simply copy the files now to their proper location.
paulgress is offline   Reply With Quote
Old 04-19-09, 09:21 AM   #19
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Hello,

After upgrading video driver to 180.51 in single user mode, now I'm in graphical mode to post. I'm working on libwfb.so issue now. I'll report later.

Thanks for your help.
Shao
shaoxuan is offline   Reply With Quote
Old 04-19-09, 09:42 AM   #20
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Hello,

I have upgraded the video driver to 180.51, but can't enable desktop effect too, Even using the libwfb.so file which paulgress provided. Why?

By the way, I'm not using SCXE, I'm using opensolaris, so snv111 is the most recent version. Can't upgrade it to 112 now.

Thanks,
Shao
shaoxuan is offline   Reply With Quote

Old 04-19-09, 07:01 PM   #21
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: Can't enable Desktop Effect after upgrading to snv_111

With the incorrect libwfb.so library installed you won't get any graphics display, not even the login prompt. Also, you will need to be careful in the future, as Sun is talking about upgrading to XOrg 1.6 soon.

What error message do you get if you enter:

/usr/bin/compiz &

From a terminal window.
paulgress is offline   Reply With Quote
Old 04-19-09, 10:30 PM   #22
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Hello paulgress,

Thanks for your quick reply.

yurippe@Mars:~$ /usr/bin/compiz &
[1] 958
yurippe@Mars:~$ /usr/bin/compiz-bin (core) - Fatal: Root visual is not a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on display :0.0
shaoxuan is offline   Reply With Quote
Old 04-19-09, 11:42 PM   #23
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: Can't enable Desktop Effect after upgrading to snv_111

OK, were going to try again. If you look at the post on this link:

http://www.opensolaris.org/jive/thre...start=0#368315

They show the error message they are getting:

"Error message: /usr/bin/compiz-bin (core) - Fatal: Root visual is not
a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on
display :0.0"

It looks identical to yours. The only difference is they started it with the command "compiz-bin, it's basically the same, compiz is a shell script to start "compiz-bin". So we established you have the same problem, so you should require the same solution.

At the root prompt enter:

# svccfg -s application/opengl/ogl-select setprop options/vendor=nvidia
# svcadm restart application/opengl/ogl-select

This time I discovered an error with the previous post. The word application doesn't end with an "s". If you look at the previous posts there was an "s" showing as "applications". So just copy and paste the above entry and you should be good.
paulgress is offline   Reply With Quote
Old 04-20-09, 02:39 AM   #24
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Quote:
Originally Posted by paulgress View Post
OK, were going to try again. If you look at the post on this link:

http://www.opensolaris.org/jive/thre...start=0#368315

They show the error message they are getting:

"Error message: /usr/bin/compiz-bin (core) - Fatal: Root visual is not
a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on
display :0.0"

It looks identical to yours. The only difference is they started it with the command "compiz-bin, it's basically the same, compiz is a shell script to start "compiz-bin". So we established you have the same problem, so you should require the same solution.

At the root prompt enter:

# svccfg -s application/opengl/ogl-select setprop options/vendor=nvidia
# svcadm restart application/opengl/ogl-select

This time I discovered an error with the previous post. The word application doesn't end with an "s". If you look at the previous posts there was an "s" showing as "applications". So just copy and paste the above entry and you should be good.
Hello Paulgress,

amazing! now the Desktop Effect works, Thanks Paul, I have wasted you too much time.
shaoxuan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
3DNA 3d desktop prydah General Software 2 08-01-02 11:59 AM

All times are GMT -5. The time now is 11:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.