Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-11-09, 05:41 AM   #1
arz
Registered User
 
Join Date: Feb 2009
Posts: 1
Default Jerky playback in xine with subtitles enabled

Video playback lags and jerks reproducibly when very large or huge subtitles
are enabled in xine. This also affects all applications that use xine such as totem and kaffeine.
Desktop effects, player frontend, codec or bitrate of the video do not affect this behaviour.

If the playback window is scaled to a small size the lags do not occur. The X server processor usage jumps up at the precise moment a subtitle is displayed.

I've verified that this problem only occurs with the nvidia driver. I've tested the 177.80, 180.11 and 180.29 releases.

I've disabled all sync to vblank options and also added Option "UseEvents" "true" to my xorg.conf, to no perceptible effect.

My configuration:
Kubuntu 8.10 + KDE 4.2
libxine-1.1.15-0ubuntu3.1
xserver-xorg-1:7.4~5ubuntu3
GeForce 9800GT with proprietary nvidia driver version 180.29 (also tested 177.80, 180.11)
Window size: 2048x1152

Xine bug: http://bugs.xine-project.org/show_bug.cgi?id=206
Ubuntu bug: https://bugs.launchpad.net/ubuntu/+s...ib/+bug/158190

Please note that I had to split the dmesg output from the nvidia-bug-report.log because the file was above the boards max. size.
Attached Files
File Type: txt dmesg.txt (44.8 KB, 110 views)
File Type: log nvidia-bug-report.log (118.7 KB, 105 views)
File Type: txt xine-config.txt (14.4 KB, 94 views)
arz is offline   Reply With Quote
Old 03-07-09, 04:46 AM   #2
Linux_Fan
Open Source User
 
Linux_Fan's Avatar
 
Join Date: Jan 2009
Location: Poland
Posts: 5
Default Re: Jerky playback in xine with subtitles enabled

I can confirm that on my Arch Linux (Core Dump) 64-bit machine. Below are the details.

Code:
kernel26 2.6.28.7-1
xine-lib 1.1.16.2-1
kaffeine 0.8.7-1
xorg-server 1.5.3-4
nvidia-beta 180.35-1
KDEmod 3.5.10
GeForce 8600M GT
Strangely enough this bug doesn't seem to affect mkv files, like it does avi and mp4.
Linux_Fan is offline   Reply With Quote
Old 03-07-09, 07:52 AM   #3
P.Kosunen
Registered User
 
Join Date: Jan 2009
Posts: 57
Default Re: Jerky playback in xine with subtitles enabled

Quote:
Originally Posted by arz View Post
I've tested the 177.80, 180.11 and 180.29 releases.
16x.x doesn't have this problem (but picture freezes sometimes).
P.Kosunen is offline   Reply With Quote
Old 03-07-09, 03:58 PM   #4
Linux_Fan
Open Source User
 
Linux_Fan's Avatar
 
Join Date: Jan 2009
Location: Poland
Posts: 5
Default Re: Jerky playback in xine with subtitles enabled

Seems I was wrong...this bug does also affect mkv files, but not as much as the other two mentioned above, I guess.
__________________
"... being a Linux user is sort of like living in a house inhabited by a large family of carpenters and architects. Every morning when you wake up, the house is a little different. Maybe there is a new turret, or some walls have moved. Or perhaps someone has temporarily removed the floor under your bed."
Linux_Fan is offline   Reply With Quote
Old 04-21-09, 06:11 PM   #5
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: Jerky playback in xine with subtitles enabled

Even here, some problem with kaffeine in full screen. Jerky. Compiz is enabled.
marchetto is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:02 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.