Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-23-09, 10:26 AM   #1
macjohn4
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Can't start X server in Mandriva KDE 2009

I installed my updated kernal, downloaded the most recent nvidia driver, backed up my xorg.conf file and then hit control + alt + F1 to bring up the terminal, logged on as root, stopped the x server (service dm stop), changed to the directory where my driver was, and typed in: sh NVIDIA-Linux-x86-180.51-pkg1.run

For the first time, the install went all the way to completion without any errors. I was excited. I then typed 'service dm start' and.... nothing. Reboot... right back to the prompt. Logged on as root, navigated to my xorg.conf backup and restored it. Reboot... back to the prompt.

So my question is... it appears that installing this driver has me using something other than my xorg.conf? If so, how do I start the new x server or can I? Or is there away to remove the driver and go back to my old xorg.conf?

Thanks
macjohn4 is offline   Reply With Quote
Old 04-23-09, 11:48 AM   #2
spooge
Registered User
 
Join Date: Apr 2003
Posts: 5
Default Re: Can't start X server in Mandriva KDE 2009

post your xorg.conf
__________________
Slakware12.2
spooge is offline   Reply With Quote
Old 04-23-09, 07:40 PM   #3
macjohn4
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: Can't start X server in Mandriva KDE 2009

unfortunately, I don't know how to get the file copied over to another drive from the command prompt. I brought the file up and will type out what I think are the important bits here... it looks like it's not even reading this file as this is the same file I had before and was working fine before the driver install:

standard mouse and keyboard stuff...
then:

Section "Monitor"
Identifier "monitor1"
VendorName "Plug' n Play"
ModelName "Sceptre X22WG-1080P"
HorizSync 15-94
VertRefresh 24-77
Option "preferredMode" "1680x1050"

then it lists a bunch of modeLine's
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 6100 and later"
Driver "nvidia"
Option "DPMS"
Option "DynamicTwinView" "false"
Option "AddARGBGLXVisuals"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Then a bunch of subsections...
EndSection

Section "ServerLayout"
Indentifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
macjohn4 is offline   Reply With Quote
Old 04-23-09, 08:22 PM   #4
macjohn4
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: Can't start X server in Mandriva KDE 2009

OK, I found my xorg log file and found the error:
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!

which according to the README indicates a kernel mismatch and to run dmesg which says:
NVRM: API mismatch: the client has the version 180.51, but this kernel module has the version 180.44. Please make sure that this kernel modual and all NVIDIA driver components have the same version.

So my question...

From the command prompt, how can I get these versions in line?
macjohn4 is offline   Reply With Quote
Old 04-23-09, 09:00 PM   #5
macjohn4
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: Can't start X server in Mandriva KDE 2009

I'm back in the xserver, I changed my xorg.conf from nvidia to nv and rebooted and I'm at least back in... now I'm off to try and get my kernel and nvidia in sync, any advice?
macjohn4 is offline   Reply With Quote
Old 04-23-09, 10:59 PM   #6
macjohn4
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: Can't start X server in Mandriva KDE 2009

carrying on a conversation with myself, I know... but in case someone wants to see how this all shook out:

got dual monitors finally working with my nvidia 6200 card on my athlon 3200 system running mandriva kde 2009

I initially had the problem where my kernel and nvidia driver weren't the same version, I looked at my kernel packages and didn't see 180.51 so I found the 180.44 nvidia driver on their site and downloaded it and installed it.

I then ran the Nvidia X server settings program found in the tools menu and configured my second display. I had problems where every time I restarted, all my settings had to be setup again in this applet. When I tried to save from the nvidia settings panel to the xorg.conf file, it crashed the program until I moved the xorg.conf file and the program popped up a box asking me to name a file name. It also allowed me to see what it was going to paste in the file, so I just copied it out of that window, into my xorg.conf and rebooted and now everything is perfect!

Phew.... this has been a trying couple of weeks getting this to work. Too bad I'll probably never even use it since this is a tri boot system and I think I like my mac boot better... but it's close, this mandriva is nice.
macjohn4 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Base mosaic and rotation? happyfunbot NVIDIA Linux 5 07-13-12 12:23 PM
X Server 1.11.3(Ubuntu 12.04) crashes just after start on Geforce 9400(driver 295.40) peat NVIDIA Linux 1 05-10-12 06:00 AM
NVidia Display Drivers screw up KDE Webgraph NVIDIA Linux 11 10-08-02 08:57 PM

All times are GMT -5. The time now is 11:14 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.