Go Back   nV News Forums > Linux Support Forums > NVIDIA Solaris

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-16-09, 09:59 AM   #1
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Can't enable Desktop Effect after upgrading to snv_111

Hello gurus,

I'm using opensolaris 2008.10 snv_101b for a few months, and the Desktop Effect works fine (Nvidia Geforce 7100 + 630i). But after live-upgrading to snv_111 via "pkg image-update"(the video card driver has upgraded to 180.22), the Desktop Effect can't be enabled. How can I do to enable Desktop Effect?

Thanks.
shaoxuan is offline   Reply With Quote
Old 04-16-09, 05:09 PM   #2
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: Can't enable Desktop Effect after upgrading to snv_111

This is a problem with nv111 and 112 that should be corrected in nv113. It's not the 180.22 driver.

Bug Title: compiz fails to start at login for nvidia graphics cards

Bug description: compiz fails to launch upon login because Xserver is not loading GLX extensions. This is due to The SMF service svc:/application/opengl/ogl-select:default picking the wrong type of GLX extension, it points to the generic Mesa library.

Error message: /usr/bin/compiz-bin (core) - Fatal: Root visual is not a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on display :0.0

Workaround: Set vendor string manually :
$ svccfg -s applications/opengl/ogl-select setprop options/vendor = nvidia
$ svcadm restart applications/opengl/ogl-select

Restart X server and re-login
paulgress is offline   Reply With Quote
Old 04-16-09, 09:19 PM   #3
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Hello paulgress,

Thanks for your comprehensive advice, I will try it ,thanks!
shaoxuan is offline   Reply With Quote
Old 04-16-09, 09:55 PM   #4
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Quote:
Originally Posted by paulgress View Post
This is a problem with nv111 and 112 that should be corrected in nv113. It's not the 180.22 driver.

Bug Title: compiz fails to start at login for nvidia graphics cards

Bug description: compiz fails to launch upon login because Xserver is not loading GLX extensions. This is due to The SMF service svc:/application/opengl/ogl-select:default picking the wrong type of GLX extension, it points to the generic Mesa library.

Error message: /usr/bin/compiz-bin (core) - Fatal: Root visual is not a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on display :0.0

Workaround: Set vendor string manually :
$ svccfg -s applications/opengl/ogl-select setprop options/vendor = nvidia
$ svcadm restart applications/opengl/ogl-select

Restart X server and re-login

Hello, can't set vendor string manually:

yurippe@Mars:~$ svccfg -s applications/opengl/ogl-select setprop options/vendor = nvidia
svccfg: mode 'applications/opengl/ogl-select' does not match all instance or service (translated from Chinese)
yurippe@Mars:~$
shaoxuan is offline   Reply With Quote
Old 04-17-09, 09:19 AM   #5
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Try:
$ svccfg -s applications/opengl/ogl-select setprop options/vendor=nvidia
$ svcadm restart applications/opengl/ogl-select

I removed the spaces between "vendor = nvidia"

This is what worked for me, I copied and pasted from another area with spaces.
paulgress is offline   Reply With Quote
Old 04-17-09, 10:04 AM   #6
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Quote:
Originally Posted by paulgress View Post
Try:
$ svccfg -s applications/opengl/ogl-select setprop options/vendor=nvidia
$ svcadm restart applications/opengl/ogl-select

I removed the spaces between "vendor = nvidia"

This is what worked for me, I copied and pasted from another area with spaces.
I have tried, but with no luck. I copied and pasted to execute too.
The terminal returned the same messages as before.
shaoxuan is offline   Reply With Quote
Old 04-17-09, 10:19 AM   #7
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

By the way, the video chip I'm using is not a independent video card, it's intergrated with the motherboard. But it did support desktop effect when the OS is 2008.10 snv_101b.

Before I tried these two commands, I have upgraded the video card driver to 180.44, the driver was downloaded from Nvidia web site.
shaoxuan is offline   Reply With Quote
Old 04-17-09, 12:17 PM   #8
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: Can't enable Desktop Effect after upgrading to snv_111

How did you install the latest 180.44 driver?
I was under the impression that you couldn't just yet install into SXCE or Opensolaris without certain workarounds. The workarounds are as follows:

cd /usr/X11/lib/modules
mv libwfb.so libwfb.so.copy
cd amd64
mv libwfb.so libwfb.so.copy
/tmp/NVIDIA-Solaris-x86-180.44.run
.
.
.
mv libwfb.so libwfb.so.nvidia
mv libwfb.so.copy libwfb.so
cd ..
mv libwfb.so libwfb.so.nvidia
mv libwfb.so.copy libwfb.so

This assumes you have the correct libwfb.so installed from the nv111 DVD. Suns library needs to be used due to the upgrade to X.Org 1.5. You may need to copy libwfb.so from the DVD (both 32 & 64 bit versions). You can also use this procedure to downgrade to the previous 173 or 177 series drivers.
paulgress is offline   Reply With Quote

Old 04-17-09, 12:50 PM   #9
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Can't enable Desktop Effect after upgrading to snv_111

On a related note, the libwfb.so workarounds should no longer be needed with NVIDIA Solaris graphics driver releases >= 180.50 (see e.g. ftp://download.nvidia.com/solaris/180.50).
zander is offline   Reply With Quote
Old 04-17-09, 01:07 PM   #10
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Quote:
Originally Posted by paulgress View Post
How did you install the latest 180.44 driver?
I was under the impression that you couldn't just yet install into SXCE or Opensolaris without certain workarounds. The workarounds are as follows:

cd /usr/X11/lib/modules
mv libwfb.so libwfb.so.copy
cd amd64
mv libwfb.so libwfb.so.copy
/tmp/NVIDIA-Solaris-x86-180.44.run
.
.
.
mv libwfb.so libwfb.so.nvidia
mv libwfb.so.copy libwfb.so
cd ..
mv libwfb.so libwfb.so.nvidia
mv libwfb.so.copy libwfb.so

This assumes you have the correct libwfb.so installed from the nv111 DVD. Suns library needs to be used due to the upgrade to X.Org 1.5. You may need to copy libwfb.so from the DVD (both 32 & 64 bit versions). You can also use this procedure to downgrade to the previous 173 or 177 series drivers.
Hello,

I first uninstall NVDAgraphics, and then install the Nvidia-Solaris-x86-180.44.run without any problem (except the desktop effect issue). It's odd? :o

Thanks zender, I'm downloading the 180.50 driver.

Shao
shaoxuan is offline   Reply With Quote
Old 04-17-09, 01:42 PM   #11
shaoxuan
Registered User
 
shaoxuan's Avatar
 
Join Date: Jun 2007
Location: Beijing, China
Posts: 14
Send a message via ICQ to shaoxuan Send a message via MSN to shaoxuan
Default Re: Can't enable Desktop Effect after upgrading to snv_111

Hello,

After installing the 180.50 driver, I can't see the login window now. When the system wait for login input ,the screen is whole blue, I can see the mouse curser and I can move it too. But I can't see the login window. when you tap in the user/password blindly, the system can log you into, but the screen is still whole blue.

By the way, I chmod a+x and execute Nvidia-Solaris-x86-180.50.run directly to upgrade the driver (Is this method right?).

What can I do to correct this? I'm using another PC now.

Thanks,
Shao
shaoxuan is offline   Reply With Quote
Old 04-17-09, 02:02 PM   #12
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Can't enable Desktop Effect after upgrading to snv_111

@shaoxuan: I didn't mean to suggest that you install 180.50 on your system - since you had already installed 180.44, X.Org's libwfb.so binary may already have been clobbered. 180.50 also has a bug that prevents it from working correctly on pre-G80 (GeForce 8) series GPUs. We hope to release an updated 180.xx driver addressing this problem either sometime today or early next week. Please see http://www.nvnews.net/vbulletin/show...50&postcount=7 for a workaround.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
3DNA 3d desktop prydah General Software 2 08-01-02 10:59 AM

All times are GMT -5. The time now is 03:57 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.