Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-02-09, 08:26 AM   #1
pstehlik
Registered User
 
Join Date: May 2009
Posts: 1
Default GF8x/9x annoying overscan on DVI to LCD TV

Hi,

in my HTPC I have GF7300 connected via DVI and DVI-HDMI cable to my 32" Thomson LCD with 1366x768 native resolution. With the Xorg resolution set to "1360x768" I get pixel perfect image with a very minimal overscan - just 3 pixels on each side of the screen - please see a photo of my TV at http://joy.sophics.cz/tmp/gf7300.jpg (too large to attach here) displaying the attached test image kriz_1360.png.

Now I'd like to upgrade the gfx to get VDPAU working so I borrowed GF8400 and GF9500 for testing. Both cards suffer from the same problem - they generate the picture somehow incorrectly so the TV shows it with huge overscan - see http://joy.sophics.cz/tmp/gf9500.jpg - it's at least 2x60 pixels horizontal and 2x30 pixels vertical overscan - completely unusable.

The TV, software (clean Ubuntu Jaunty 32bit with 180.44 nvidia driver) and hardware (an AM2 ASUS motherboard with nvidia MCP55 chipset) configuration is identical in these tests, I am just exchanging the gfx cards. The Xorg.conf contains nothing special, not even a custom modeline. For the 8400/9500 I tried playing with modelines and nVidia configuration options for several days but nothing helped. The huge overscan is there even for 1280x720 resolution (which the EDID claims to support natively, contrary to 1360x768). There is nothing I can change in the TV setup to get rid of the overscan.

I believe the problem lies in the new 8x/9x graphics cards (since my old FX5200 used to and current GF7300 does generate perfect picture). Is there some Xorg.conf setting I could use to disable the overscan or somehow instruct the card to produce the same picture the GF7300 does, please? I'd really like to upgrade to VDPAU capable card but will nto give up on pixel-perfect image (pixel-perfect = there is no scaling or stretching of the picture in the TV, the graphics card DVI resolution fits perfectly on the TV LCD pixel matrix - thus the resolution 1360x768).

Two more screen shots showing the nvidia-settings in action: http://joy.sophics.cz/tmp/settings-7300.jpg and http://joy.sophics.cz/tmp/settings-9500.jpg. Please note the TV in its EDID _lies_ about its native resolution - the 1920x1080 is a complete nonsense, it's really 1366x768 TV. Also note that I tried disabling the EDID using the various --ignore-edid-freqs etc. It doesn't matter for GF7300 and doesn't help on GF8400/GF9500.

Thanks in advance for help with this

Petr
Attached Thumbnails
Click image for larger version

Name:	kriz_1360.png
Views:	108
Size:	15.9 KB
ID:	36710  
Attached Files
File Type: gz gf7300.log.gz (12.9 KB, 70 views)
File Type: gz gf9500.log.gz (15.7 KB, 68 views)
File Type: txt xorg.conf.txt (2.5 KB, 137 views)
pstehlik is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
HDMI overscan fix for multiple resolutions + Zod Engine Problem. cheechr1 NVIDIA Linux 0 06-11-12 02:27 PM
LCD DVI support in Linux drivers? salobaas NVIDIA Linux 1 07-31-02 03:29 AM

All times are GMT -5. The time now is 09:54 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.