Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-12-03, 08:33 PM   #1
capoeirista
Registered User
 
Join Date: Mar 2003
Location: Hamvegas, New Zealand
Posts: 8
Unhappy Please Help with nvaudio dependencies!!

Hey, i've compiled the nforce drivers for my slackware 8.1 distribution, and the nvnet module loads, but not nvaudio. modules.conf complains that it can't load the module :
alias sound-slot-0 nvaudio

And when i try and insert the module manually, using /sbin/insmod nvaudio I get the following errors :

bash-2.05a$ /sbin/insmod nvaudio

Using /lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_probe_codec

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol unregister_sound_dsp

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol register_sound_dsp

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol register_sound_mixer

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol unregister_sound_mixer

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_dac_rate

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_adc_rate

So i'm guessing that i've missing some modules, but I don't know which ones. Can anyone give me a hand?

I did a depmod and this is what it told me, if it's of any use...

bash-2.05a$ /sbin/depmod nvaudio
# module id=string
# pci module vendor device subvendor subdevice class class_mask driver_data
# isapnp module cardvendor carddevice driver_data vendor function ...
# usb module match_flags idVendor idProduct bcdDevice_lo bcdDevice_hi bDeviceClass bDeviceSubClass bDeviceProtocol bInterfaceClass bInterfaceSubClass bInterfaceProtocol driver_info
# module pattern
# ieee1394 module match_flags vendor_id model_id specifier_id version
# module id
bash-2.05a$

Cheers,
Oliver Sneyd (Capoeirista)
capoeirista is offline   Reply With Quote
Old 06-13-03, 01:03 AM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

First I'm not using an nforce board.

The driver depends on other small sound drivers one of them is ac97 (not sure if that is the full module name), it also might depend on "soundcore".
When you use modprobe instead of insmod depending modules get loaded automaticly.
Thunderbird is offline   Reply With Quote
Old 06-13-03, 01:13 AM   #3
capoeirista
Registered User
 
Join Date: Mar 2003
Location: Hamvegas, New Zealand
Posts: 8
Default

Any idea what the lines that I need to put in my modules.conf are that will load ac97_codec and soundcore automatically?
capoeirista is offline   Reply With Quote
Old 06-13-03, 03:05 AM   #4
Kiamu
Registered User
 
Join Date: Apr 2003
Location: Germany
Posts: 77
Default

you have to build the i810 module in your kernel in addition to the nvaudio module to get the ac97 codec support you need.


or use alsa...
Kiamu is offline   Reply With Quote
Old 06-13-03, 04:43 AM   #5
capoeirista
Registered User
 
Join Date: Mar 2003
Location: Hamvegas, New Zealand
Posts: 8
Question

I have the modules that I need already compiled, it's just that I have to run modprobe nvaudio when I log in for audio to work. I don't know what to put in my modules.conf that will automatically load ac97_codec, soundcore and nvaudio

Cheers,
Olly (Capoeirista)
capoeirista is offline   Reply With Quote
Old 06-13-03, 08:56 AM   #6
Locke Averame
Registered User
 
Join Date: Jun 2003
Posts: 2
Default

Use the i810 audio module from alsa instead, it works perfectly for a friend of mine.
__________________
"Everyone is connected" - The
Wire
Locke Averame is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
Cannot load nvaudio driver (NVidia nforce) thahn01 NVIDIA Linux 4 09-13-02 01:28 AM
Rh7.3 & Nforce k0fcc NVIDIA Linux 10 08-11-02 06:10 PM

All times are GMT -5. The time now is 09:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.