Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-10-09, 03:16 AM   #1
jbrown
Registered User
 
Join Date: May 2009
Posts: 5
Default Console not restored properly when switching (or returning) from X with TV-out

My graphics card is a GeForce2 MX/MX 400 and I'm using driver 96.43.11 which is AFAIK the latest driver supporting it.

My kernel version is 2.6.28 and I'm working with a normal vga (text) console, no framebuffer.

If I configure X without TV-out, everything's fine. I can switch from X to the console and work there, and after quitting X everything's normal with the console.

But simply activating TV-out changes this. When switching to the console from X now, the cursor stays in the upper left corner of each console. Typed input can be seen, output only if no scrolling is needed (scrolled stuff becomes visible when switching to another console and back again). After quitting X, the console acts almost normal again, but the console font (set with setfont) is destroyed and the cursor repetition delay speed is slightly higher. Thus, the console isn't restored properly.

Without the X server's libint10 module (temporarily removed), the display problems and cursor repetition delay speed problem remain, but the console font won't be touched!

What are the driver's problems with normal vga (text) consoles?

Any hints and help appreciated.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (17.6 KB, 87 views)
jbrown is offline   Reply With Quote
Old 05-12-09, 06:38 PM   #2
jbrown
Registered User
 
Join Date: May 2009
Posts: 5
Default Re: Console not restored properly when switching (or returning) from X with TV-out

Come on. Nobody?

Can't somebody confirm at least?

What about a short statement from the support?
jbrown is offline   Reply With Quote
Old 05-12-09, 07:41 PM   #3
buchholz
Registered User
 
Join Date: Feb 2006
Location: Portland, Oregon
Posts: 1
Default Re: Console not restored properly when switching (or returning) from X with TV-out

Let me guess ... when you return to the console, the console font proportions seem to be a bit off, and, more importantly, the gap between the lines looks almost like someone set a typewriter to a line spacing setting of "1.5" or "2"?

We'd been seeing this with ATI adapters for 4-5 years now. And then the NVIDIA drivers started doing it this summer. :-(

We used to do two things to setup the console font (this is a Red Hat
Enterprise Linux - release 4 environment) so we'd get more than 80x25 text:
(a) added "vga=ext" to the kernel options in the grub.conf filehttp://www.nvnews.net/vbulletin/images/smilies/surrender.gif
(b) changed the SYSFONT value in /etc/sysconfig/i18n to "lat0-08".

It was item "(b)" which left us with unviewable, but apparently active, lines below the bottom of the console screen. Now, we simply leave the SYSFONT setting at it's default value of "latarcyrheb-sun16", and suffer the normal 80x25 text mode. (But at least we can see everything.)
buchholz is offline   Reply With Quote
Old 05-13-09, 05:59 PM   #4
jbrown
Registered User
 
Join Date: May 2009
Posts: 5
Default Re: Console not restored properly when switching (or returning) from X with TV-out

Quote:
Originally Posted by buchholz View Post
Let me guess ... when you return to the console, the console font proportions seem to be a bit off
Oops! I forgot to describe what "destroyed" means. And "destroyed" is the wrong word. I should have rather written "partly replaced".

No, it is not destroyed in the sense of missing, compressed or moved pixels. The characters themselves are fine, it is simply that I get some wrong characters when typing. For example:

former becomes
former becomes
former becomes ⁿ
former becomes
former becomes Σ
former becomes
former becomes
former becomes

The main part of the other characters seem to be ok.

Because I want to work with the normal vga (text) console as established by the kernel, any vga parameter during booting isn't a solution for me.

BTW, when switching to a vga (text) console while in X with TV-out, the display on TV vanishes and returns after switching back to X again. Is this as supposed to be?
jbrown is offline   Reply With Quote
Old 05-14-09, 11:41 AM   #5
jbrown
Registered User
 
Join Date: May 2009
Posts: 5
Default Re: Console not restored properly when switching (or returning) from X with TV-out

Ok, I did some testing and can provide further information which should help to track down the problem (provided that the support is reading here - please give some feedback).

1. The cursor repetition delay speed issue wasn't the driver's but X server's fault. It changes the speed which will remain after quitting X. With option AutoRepeat I set the same delay and speed as in the console and everything's fine now.

2. The font problem is as follows: After quitting X the font is restored to the default vga (text) console font (e. g. the DOS font of the graphics card) and not to the font previously changed with setfont.

3. When switching to the vga (text) console while X is running, there is a problem with the cursor and with scrolling / screen update. The cursor isn't at the input position but in the upper left corner, and scrolling / screen update isn't directly visible.

So, the two real bugs (numbers 2. and 3.) should be clearly described. Please support, comment.
jbrown is offline   Reply With Quote
Old 05-16-09, 04:12 PM   #6
jbrown
Registered User
 
Join Date: May 2009
Posts: 5
Default Re: Console not restored properly when switching (or returning) from X with TV-out

After quitting X today I noticed that the disturbed picture I usually seen on my tv then had the some colors which were on my vga (text) console on my computer monitor. And indeed, clearing the console cleared the disturbances on tv also. The same thing happens when switching to the CRT vga (text) console while X ist running.

So the problem seems to be that the driver tries to give a console on the tv, too. With Option "ConnectedMonitor" "CRT" the vga (text) console on my computer monitor is fine again when switching while X is running - no bug #3 (see earlier posting), but I do not have a second screen (tv output) under X.

Maybe the problem will disappear if the driver stops TV-out when witching to a vga (text) console with a CRT attached.

So far, there seems to be no option available for this, is it?
jbrown is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Console Killers News Archived News Items 0 06-11-12 10:10 PM
Official Linux driver 1.0-3123 thread bammbamm808 NVIDIA Linux 126 12-05-02 06:21 PM

All times are GMT -5. The time now is 09:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.